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Preface

Webtop is a WDK-based application. A WDK-based application is built on WDK (Web Development
Kit) functionality. A WDK-based application lets you access an EMC Documentum repository over
the web. WDK functionality lets you access, edit, and manage content in multiple repositories. WDK
functionality lets you distribute content through automated business processes, restrict access to
content according to permission sets, and assign version numbers to content to help keep track of
revisions.

A repository is a virtual storehouse for the content you work on, and share with other employees.
Each repository provides security, tools, and processes for sharing content among many users.
Processes control the automated routing of content, and assign document lifecycles to content.
Processes allow you to create, edit, and forward content regardless of your technical expertise.

A repository stores two kinds of information for a content file:

* The content, which is the text, graphics, sound, video, binary content, or other content that makes
up the file.

¢ The properties, which are descriptive characteristics about the file, such as creation date, author,
version number, and other information. Property values can only be edited by the file’s creator
or a user with high enough security settings.

This guide explains how to use EMC Documentum Webtop, and describes the behavior of the default
Webtop interface. Your installation might be customized. If so, the interface items you see might not
correspond to those described in this manual.

Intended Audience

The manual assumes that you are familiar with the conventions of Microsoft Windows, and Web
browsers, and that you know how to open, close, resize, and move windows, as well as navigate
using hyperlinks, and buttons. You should also know how to work with multiple windows, and
manage files on your personal computer, and you should be able to perform basic operations such as
copying, and pasting files.
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Revision History

The following changes have been made to this document.

Revision date Description

December 2014 Initial publication.
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Chapter 1

Repositories

Log in to a repository

To log in to a repository, you need:

Webtop URL or WebSEAL URL

Repository name

Your user name, and password for the repository
Webtop Network location (if applicable)

Microsoft Windows NT domain name (if applicable)

Language (if applicable)

To log in to a repository:

1.

EMC Documentum Webtop Version 6.8 User Guide

In your web browser, type the Webtop URL.

If you use either saved credentials or an SSO-based authentication, Webtop prompts you to
select a repository in the Repository list of the Login screen, if you log in the first time or if the
repository information is not available in the cache. Select a repository and click OK to log in to
Webtop. Alternatively, the SSO-based authentication logs you in to Webtop automatically when
you access the Webtop URL. Skip the rest of this procedure.

If the Login page appears, type your login name, and password for the repository. Login names,
and passwords are case-sensitive.

In the Repository list, select the repository.

In the Location list (if available), select the location on your organization network from which
you are accessing Webtop.

This allows you to access content from the nearest storage area in the network. Depending on
your organization’s setup, this location might be a fixed value.

To save credentials so that you log in automatically the next time you run Webtop from this
computer, select Remember my credentials for next time.

Tip: Once you are logged in, you can view or delete your saved credentials through your
preferences.

To enter a Microsoft Windows NT domain name, click More Options, and enter the domain.

To select language, click More Options, and select the language.

To use accessibility features, click More Options, and select Additional Accessibility Options.

The accessibility mode provides linear navigation; tab navigation; lists instead of menus; and
additional descriptive text.

To change your password, complete these steps:
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a. Click More Options.

b. Click Change Password.

c. Type your current password, and new password.
d. Click Apply.

Note: If your organization uses Lightweight Directory Access Protocol (LDAP), you cannot
change your password from the login page. Ask your system administrator how you can change
your password.

10. Click Login.

Log in to a repository using WebSEAL SSO
Authentication

WebSEAL acts as a reverse web proxy server by receiving HTTP or HTTPS requests from a web
browser and delivering content from back-end application servers. Requests that pass through
WebSEAL will be evaluated by its own authorization service to determine whether the user is
authorized to access Webtop.

To log in to a repository:

1. In your web browser, type the WebSEAL URL. The WebSEAL URL is specific to the Documentum
application you access. If the application you want to access is Webtop, enter a WebSEAL URL
that corresponds to Webtop.

Example 1-1. WebSEAL URL
http://WEBSEAL:90/myjunction/webtop
http://<Host Name>:<PORT>/<Junction Name>/<Application>

2. Enter your username and password in the WebSEAL Login dialog box.

3.  Webtop prompts you to select a repository in the Repository list of the Login screen, if you log in
the first time or if the repository information is not available in the cache. Select a repository and
click OK to log in to Webtop. Alternatively, the SSO-based authentication logs you in to Webtop
automatically when you access the Webtop URL.

4. In the Location list (if available), select the location on your organization network from which
you are accessing Webtop.

This configuration allows you to access content from the nearest storage area in the network.
Depending on the setup of your organization, this location might be a fixed value.

5. To select language, click More Options, and select the language.

6. To use accessibility features, click More Options, and select Additional Accessibility Options.

The accessibility mode provides linear navigation; tab navigation; lists instead of menus; and
additional descriptive text.

7. To change your password, complete these steps:

a. Click More Options.
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b.

C.

d.

Click Change Password.
Type your current password, and new password.

Click Apply.

Note: If your organization uses Lightweight Directory Access Protocol (LDAP), you cannot
change your password from the login page. Ask your system administrator how you can change
your password.

8. Click Login.

Log in as an express user

If your application includes the express user role, and if you have been assigned that role, then when
you log in you are given limited access to repository functionality.

If you have been assigned the express user role, you log in with the usual procedure for logging in,
as described in Log in to a repository, page 15

Log into another repository

To log into another repository:

1. If the repository is listed in the navigation pane, select the repository, and skip to Step 3.

2. If the repository is not listed in the navigation pane, do these:

a.

b.

e.

f.

Select Add Repository.

If the repository is listed on the Add a Repository page, select the repository, and click OK.
Skip to Step 3.

If the repository is not listed on the Add a Repository page, click more repositories.

On the Connection Brokers page, enter the name of a connection broker, and click Add. A
connection broker determines the repositories available to log into. Ask your administrator
for the names of connection brokers your organization uses.

Click OK.
On the Add a Repository page, select the repository, and click OK.

3. Type your user name, and password for the repository.

4. Click Login.

Log out of all repositories

To log out, select File > Logout.

EMC Documentum Webtop Version 6.8 User Guide

17



Repositories

Set your favorite repositories

To set your favorite repositories:

1. Select Tools > Preferences.

2. Select the Repositories tab.

3. In the Select a Repository list, select the repository to add, and click the add arrow.
4

To remove a repository from your Favorite Repositories list, select the repository, and click the
remove arrow.

5. To change the order in which repositories appear, select a repository in the Favorite Repositories
list, and click the up or down arrow.

6. Click OK.

Navigate a repository

A repository is a virtual storehouse for your organization’s content. Your organization might use
multiple repositories. Each repository is comprised of nodes that give access to the repository’s
content, and functions. For example, the My Home Cabinet node contains your personal files, and
folders. Webtop displays the repository’s nodes in the navigation pane.

To navigate the repository, do any of these. Try each to see how the actions differ:
* Click a node in the navigation pane.

* Double-click a node in the navigation pane.

* Click the plus sign adjacent to the node in the navigation pane.

* Click a location in the content pane.

* Click a location in the navigation path at the top of the content pane.

To select an item in the content pane, click the item.

To select multiple items that are adjacent to each other in the content pane, click the first item, and
then hold down Shift, and click the last item.

To select multiple items in the content pane that are not adjacent to each other, click each item while
hold down Ctrl.

To select all items in the content pane, select an item in the content pane and press Ctrl+A.
To deselect a single selected item, click the item.

To deselect an item in a group of selected items, hold down Ctrl, and click the item.

To change how items are displayed in the content pane, do any of these:

* To display only those items that begin with a certain character string, type the character string in

the text field at the top of the content pane, and click *
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To return to the original list, click [ %,

* To filter the list to display only certain types of items, select the appropriate filter in the drop-down
menu above the list.

e To display or hide thumbnails, click LA}

¢ To sort a column, click the column heading. To reverse the sort order, click the heading a second
time.

Tip: To sort by lock owner, click ¥,

To change the columns that appear, see Select the columns that appear in lists, page 20.
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Select the columns that appear in lists

This topic includes several different procedures for selecting the columns that appear in a list.

To select the columns that appear in the current list:

1.

6.

Navigate to the list.

In the column header select ==".

To add a column, do these:

a. Inthe Select object type list, select the type of item that contains the property to display.
b. In the Select attributes to display list, select the property to be displayed in a column.

c. Click the add arrow.

d. Repeat Step a through Step c for as many properties as you want to add.

To change the order in which columns appear, select a property in the Selected attributes to
display as column, and click the up or down arrow.

To remove a property that is displayed as a column, select the property in the Selected attributes
to display as column, and click the remove arrow.

When you are done adding, and removing properties, click OK.

To select the columns that appear in a particular location:

LN

7.

Select Tools > Preferences.

Select the Columns tab.

Scroll to the appropriate view, and click Edit.

To add a column, do these:

a. In the Select object type list, select the type of item that contains the property to display.
b. In the Select attributes to display list, select the property.

c. Click the add arrow.

d. Repeat Step a through Step c for each property to add.

To change the order in which columns appear, select a property in the Selected attributes to
display as column list, and click the up or down arrow.

To remove a property from display, select the property in the Selected attributes to display
as column list, and click the remove arrow.

Click OK twice.

To remove a column from a list:

1.
2.

20

Navigate to the list from which to remove a column.

Right-click the column header, and select Remove Column.
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Navigate categories

Categories provide alternate ways to organize files from the way they are organized in cabinets.
Categories are available if Webtop is integrated with EMC Documentum CI Server, and if the
repository has been enabled for category navigation. Ask your administrator if, and how your
organization uses categories.

To navigate categories, click Categories, and use the standard procedures for navigating through
the hierarchy structure.

If your organization uses categories, then:

* You might be able to submit files for categorization.

* When you create a new document from a template, the template might specify that the new
document is linked to one or more categories.

To submit a file for categorization:

1. Navigate to, and select the file to be submitted.

Tip: You can perform this procedure on multiple files by selecting multiple files.
2. Select Tools > Submit for Categorization.

3. At the confirmation prompt, do one of these:
e If submitting one file, click OK.

¢ If submitting multiple files, confirm submission for each file separately by clicking Next. For
the last file, click Finish.

Tip: To confirm submission for all remaining files at once, click Finish.

Locate an item in a selection dialog box

To locate an item in a selection dialog box, use any of these actions:

* To open a directory location, click the location.

¢ To return to a previous location, click the location in the navigation path above the list.

¢ Tolook in a different repository, select the repository in the Repository drop-down list, if available.

¢ To display only those items that begin with a certain character string, type the character string in
the text box above the list, and press Enter.

* To narrow the types of items displayed, select a different filter in the drop-down menu above
the list.

To select an item, click it. If the selection dialog box includes two list boxes, as shown in Figure 1,
page 22, then you must also click the arrow to move your choice to the second list box. You can move
multiple items to the second list box.
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Figure 1. Selection dialog box with two list boxes
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Set your preferences

Preferences determine your choices for how Webtop displays repositories, and performs certain
actions.

Most preference settings are stored in the repository so that if you log in from a different machine,

those settings still apply.

Some preference settings, such as login settings, are stored in a cookie on your local machine. Those
settings are used only on that machine.

This topic describes general preferences. To set preferences for a specific functionality within Webtop,
see the topic that covers that functionality.

To set your general preferences:

1.

Select Tools > Preferences.

2. Select the General tab, and complete the fields in Table 1, page 22.

22

Table 1. General preferences

Field

Description

Section to Start In

Checkout Location

Saved Credentials

Theme

Drag and Drop

The page that opens when you log in.

The location of your checkout directory. Your checkout
directory is the location on your computer where Webtop
copies files when you check them out from the repository.

Your user names, and passwords for logging in automatically
to certain repositories.

The set of colors, patterns, and fonts used in your display.

This enables you to drag-and-drop items with your mouse.
This option requires that you restart your browser for the
change to take affect.
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3. To save your changes, click OK.

Field

Description

Autocomplete

Hidden Objects

Document Links

Accessibility Options

If the autocomplete option is enabled, then when you begin
typing text in a field, autocomplete displays suggestions for
completing the field.

To accept a suggestion, click it.

Autocomplete displays suggestions from a record of your
previously entered words, and phrases, and in some case from
your organization’s list of common text that all users might
enter.

To clear the cache of your previously entered words, and
phrases, click Reset.

In file lists, this displays items marked as hidden.

If available, select this option to let Webtop scan each imported
or checked-in document for any linked documents. If linked
documents are found, they are imported or checked in, and the
original document becomes a virtual document. The linked
documents become descendants.

The accessibility mode provides linear navigation, tab
navigation, lists instead of menus, and additional descriptive
text.

To set your formats preferences:

This topic describes formats preferences.

1.
2.
3.

Select Tools > Preferences.

Select the Formats tab, and complete the fields in Table 2, page 23.

Click Add.

You can add custom viewing, and editing applications, and set your formats preferences for

viewing, and editing.

Table 2. Formats preferences

Field

Description

Choose object type
Primary format

Format for viewing

Select the object type from the dropdown list.
Select the primary format of the object you have selected.

Select the format for viewing. By default, it may appear based
on your primary format

Would you like this content to  Select the option.

appear in the web browser
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Field Description

Application for viewing Select the application for viewing the object from the
dropdown list or use the Select Application link to browse,
and select the application for viewing.

Application for editing Select the application for editing the object from the dropdown
list or use the Select Application link to browse, and select the
application for editing.

4. To save your changes, click OK.

Open an additional repository window

To open an additional window that displays the repository, select Tools > New Window.

Drag-and-drop

Users can select multiple files and perform a drag and drop. The multi-select drag and drop
functionality is available for all areas where single file drag and drop was previously available. For
example, users can multi-select files and drag and drop them to another folder in the repository or
to the desktop. Multi-select drag and drop also works when exporting and importing multiple
files to and from the local file system.

Note: To perform drag-and-drop operations in the Microsoft Windows 7 and the Microsoft Windows
Vista environment, you must be a Microsoft Windows Administrator user.

To use drag-and-drop, you must first enable the drag-and-drop option in your general preferences,
as described in Set your preferences, page 22.

To perform an action with drag-and-drop:

1. Navigate to, and select the items to drag-and-drop.

2. Click the items to drag, and continue to hold down the mouse button. While continuing to hold
down the mouse button, drag the items to the drop target, and then release the mouse button.

Tip: If you are dragging the items to a target that is not currently displayed, you must first
navigate to the target by doing one of these:

* Navigate to the target using the other Webtop pane.

e Navigate to the target by opening a new window. You can open a new window by selecting
Tools > New Window.

Right-click

To perform an action on an item you can right-click the item, and select the action from the shortcut
menu.
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View messages

Success, and error messages are displayed in the status bar at the bottom of the page. If a message is
longer than the status bar’s display area, you can view the full message by selecting Tools > View
Messages.

View the status of background operations

To display the status of background operations, select Tools > Job Status.

A background operation is an operation that can perform while allowing you to do other work. For
example, if you check in a file, and are given the option to first store the content on your local network
before storing it globally, then the global operation will occur in the background.

Refresh page

Webtop improves performance by reducing the amount of refreshes and by making better utilization
of the AJAX framework. The following are a few examples:

e User chooses a folder in the browser tree to view a list of content contained in the folder. Before
Documentum ECM 6.5, there was first a refresh of the browser tree applet and then there was a
refresh of the content list. Since Documentum ECM 6.5, there is no refresh of the browser tree.

¢ In the content list pane, the user double-clicks on a subfolder to see contained content. Before
Documentum ECM 6.5, the browser tree applet refreshed and then the content pane refreshed
to show the content. The browser tree refreshes in order to show a selection of the folder in the
browser tree and to expand that folder if needed. Since Documentum ECM 6.5 the selection and
expansion is accomplished without a refresh.

* User has a checked out document. The user decides no changes are needed and wants to cancel
the checkout. The user selects the content and chooses the menu option to cancel checkout. Before
Documentum ECM 6.5, the screen went blank before bringing up a dialog to choose OK on the
cancel. After choosing OK, the user saw another blank screen and a progress bar to show the user
progress of the action. The application then returned to the content pane. While returning to the
content pane, the browser tree applet and content pane refreshed. The removal of refreshes, the
enhanced transfer progress bar, the use of modal dialogs, as well as the improved performance,
significantly enhances the user experience in this case.

The reduction of screen refreshes are found throughout the product. These are just a few examples.

Select HTTP or UCF content transfer

Documentum Webtop 6.5 and later versions enable administrators to specify HTTP or UCF content
transfer for different users within the same Webtop installation. Before Documentum ECM 6.5, all
users within the same Webtop installation had to use either HTTP or UCF content transfer.
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UCF content transfer is more usable and performs better. The following lists the UCF enhancements
since Documentum ECM 6.5:

* Reduction in the number of round trips between the UCF client and server. This feature is
especially effective for improving transfer performance for smaller files over a high latency WAN.

¢ The following UCF client initialization/startup improvements:
— Sharing a JVM instance across multiple web sessions

— Starting JVM upon login
e Support for PDF byte streaming through a native viewer.

e Use of parallel streams to increase content transfer rate. This feature is especially effective for
improving content transfer performance of large files over a high latency WAN (outbound and
inbound).

¢ Freeing up stuck threads to optimize resources and increase concurrency.
* Reduction in unnecessary WDK UCEF client calls.

An improved content transfer dialog shows the action that is running (in the header of the dialog),
the file which is transferring at the time, and progress of that transfer. The new dialog is easier to
understand and is similar to other applications with which a user may be familiar.

Use modal dialogs

This feature provides modal popup dialogs for action screens involving dialogs. A modal dialog

is a child window which requires the user to interact with it before they can return to the parent
application. This feature enhances performance and allows the user to see the context from where the
action was launched. Previously, the user choose an action, the screen refreshed and took the user to a
new screen. With modal dialogs, a new window pops up on top of the previous screen. The previous
screen is viewable, but no actions may be taken on that screen while the modal dialog is active.

Work with repository documents offline
through My Documentum

My Documentum is a client application that lets you work on your documents in the offline mode
when you are not logged into Webtop. My Documentum must be installed on you local machine in
order to be used. If you are not certain whether it is installed, ask your system administrator.

My Documentum keeps selected repository files available on your machine so that you can still work
with the files even if you are disconnected from Webtop. When you again log in, My Documentum
synchronizes the documents on your machine with those in the repository. You can perform
synchronization manually or can set synchronization to occur automatically at a prescribed time or
event.

If installed on your machine, you access My Documentum through Windows Explorer or through
Microsoft Office applications. The folder hierarchy within the My Documentum folder matches the
folder hierarchy used in the repository.

26 EMC Documentum Webtop Version 6.8 User Guide



Repositories

You can search, edit, save, and create documents in the My Documentum folder. When you next
log in, and synchronize, your changes are uploaded to the repository. For more information on My
Documentum, see the My Documentum help system or the EMC Documentum My Documentum
User Guide.

View product information

To view the version number, and other product information, select File > About Webtop.

The product information includes version of Web Development Kit (WDK), upon which Webtop is
built. WDK is the EMC Documentum framework used to build applications that access repositories
by using web browsers.
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Chapter 2

Files and Folders

Create a file

To create a new file:

1.
2.
3.

Navigate to the folder in which to create the new file.
Select File > New > Document.

If a selection dialog box appears, select a template for the new file, and click OK. For detailed
steps see Locate an item in a selection dialog box, page 21.

If the repository’s Templates cabinet does not contain a template for a custom type, then you
cannot create a file of that type now. Instead, you can create a file on your local computer, import
it into the repository, and then assign it the custom type.

In the Create tab, do these:
a. Type the name of the new file.

b. To apply a lifecycle to the file, click Apply Lifecycle, then select the lifecycle. Then, if the
option is available, select the lifecycle state.

c. Enter additional information in the Create tab as needed.
In the Info tab, set properties as described in Table 3, page 31 in the topic Set properties, page 30.

If other tabs appear, enter information in those tabs as appropriate. For information on the
functionality affected by those tabs, see the topic that covers that functionality.

Click Finish.

Create a folder

To create a new folder:

1.
2.
3.
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Navigate to the location in which to create the new folder.
Select File > New > Folder.

In the Create tab, enter the name, and the type of the new folder. Enter additional information
as needed.

In the Info tab, set properties as described in Table 3, page 31 in the topic Set properties, page 30.

In the Permissions tab, specify the access that specific users, and groups have to the folder. For
instructions, see Edit permissions, page 213.

If other tabs appear, set information in those tabs as appropriate. For information on the
functionality affected by those tabs, see the topic that covers that functionality.
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7.

Click Finish.

Create a cabinet

Cabinets display the highest level of organization in a repository. Cabinets contain folders, and files.

To create a new cabinet:

1.

2
3.
4

o

Navigate to the repository in which to create the new cabinet.
Select the Cabinets node.
Select File > New > Cabinet.

In the Create tab, type the name of the new cabinet, and type of cabinet. Enter additional
information as needed.

In the Info tab, set properties as described in Table 3, page 31 in the topic Set properties, page 30.

In the Permissions tab, specify the access that users, and groups have to the cabinet. For
instructions, see Edit permissions, page 213.

If other tabs appear, set information as appropriate. For information on the functionality affected
by those tabs, see the topic that covers that functionality.

Click Finish.

Set properties

To set properties for an item:

1.

30

Navigate to, and select an item.
Tip: To select multiple items at once, click each item while holding down Ctrl.
Select View > Properties > Info.

Tip: If the @ icon appears next to an item, you can click the icon to display the item’s properties.

In each tab, set properties as described in Table 3, page 31. If your product includes tabs not
covered in this table, search this documentation for the topics that describe the functions
governed by those tabs.

If you are setting properties for multiple items at once, then the properties dialog box displays
only those properties that are common to all the items you selected.

To save changes, click OK.
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Table 3. Common tabs in the Properties dialog box

Tab Description

Info tab To edit a property, do any of these that apply:
¢ Type a new value.
¢ (Click Edit or Select, and select the value.
* Select the property’s checkbox.
® Click the property’s icon, and select the value.
e If available, click See CIS Values to view suggested property values.

To display additional properties, select Show More. To display all the
properties, select Show All Properties.

Permissions tab Displays the access that different users have to the item. To change
permissions, see Edit permissions, page 213.

History tab Displays a list of events that have occurred to the item, such as checkout,
checkin, and promote.

Check out and edit files

This section includes these:

¢ Overview of check out and edit, page 31
¢ Check out a file, page 32

* Check in a file, page 33

¢ Cancel checkout of a file, page 36

¢ View currently and recently checked-out files, page 36

Overview of check out and edit

To edit files, you check them out to your local computer. When you check out a file, Webtop locks
the file in the repository so that no one else can edit it except you. Other users can view the file, but
they cannot make changes to it. If you check out a file that is linked to multiple locations in the
repository, the file is locked in all those locations.

When you check out a file, Webtop either copies or streams the file to your computer, depending on
the file’s editing application.

If the file uses an external editing application, Webtop downloads the file to your checkout directory.
You can open, and close the file directly from your checkout directory. Your modifications are not
saved into the repository until you check in the file.
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By default, the checkout directory is these, depending on the operating system:
¢ Windows

//Documentum/Checkout
e Macintosh

Root:Users:user_name:Documentum:Checkout

If the file uses an internal editing application, then when you check out the file, Webtop streams the
file directly to the appropriate editing application. The file is not copied to your computer. When you
save the file in the editing application, the file is saved directly to the repository. However, the file
remains checked out. To unlock the file, you must check the file back in.

To check out a file, use either the Edit command or the Check Out command. The Edit command
immediately opens the file upon checkout.

Webtop displays a key icon next to the files that you currently have checked out. Webtop displays a
lock icon next to the files that other users currently have checked out.

To view a list of the files that you currently have checked out, click My Files, and then click the key
icon in the column headings.

You can open, edit, and close the file directly from your checkout directory, whether or not you are
connected to the repository.

When a file is downloaded to your checkout directory, the file has the same name as it has in the
repository, unless a naming conflict arises. A conflict arises if another file with that name already
exists in checkout directory. In that case, Webtop appends a number to the name of the newly
downloaded file. When the file is checked back in, it keeps its original filename, and the appended
number is dropped.

Check out a file

To check out a file:

1. Navigate to the file in the repository, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.

2. Do one of these:

e To check out a file without opening it, select File > Check Out.
* To check out a file, and automatically open it, select File > Edit.
Tip: You can also check out, and open the file by double-clicking it.

3. If prompted to enter additional information, enter the information, and then do one of these:
e If checking out one file, click OK.

e If checking out multiple files, enter information for each file separately by clicking Next. For
the last file, click Finish.

Tip: To apply entries for all remaining files at once, click Finish.

When checkout completes, the file is locked in the repository, and copied to your local checkout
directory. You can open the file directly from your checkout directory.
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Check in a file

When a file is versioned upon checkin, its renditions, including any thumbnail renditions, are not
maintained with the new version of the file. The renditions remain with the previous version.
However, depending on your setup, a PDF rendition request is automatically submitted if you check
in your file as the same version, and a PDF rendition already exists.

When a file is versioned upon checkin, its relationship to any parent document is not maintained,
unless the parent document is checked in as a new version as well.

To check in a file:

1.

Navigate to the file in the repository, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.

Select File > Check In.

to locate the file on your computer.

If Webtop cannot locate the file on your computer, and prompts you for the location, browse

If prompted for checkin information, enter the appropriate information. Checkin information

varies depending on your organization’s setup. For an explanation of common checkin fields,

see Checkin information, page 33.

Do one of these:
e If checking in one file, click OK.

¢ If checking in multiple files, enter information for each file separately by clicking Next. After

the last file, click Finish.

Tip: To apply information to all remaining files at once, click Finish.

Checkin information

See Table 4, page 33 for an explanation of common checkin fields. Some of the fields may not appear.

Table 4. Checkin information

Field

Description

Save as

Version label
Description
Format

Lifecycle ID
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Sets the version number. Selecting the same
version number overwrites the original file with
the updated one. For more information, see
Versions, page 35.

Lets you label the updated version.

Lets you write an optional description of the file.
Defines the type of file.

Assigns a lifecycle to the file.
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Field

Description

Check for links to other Microsoft documents,
and check in linked documents

Upload options

Show Options Retain Lock

Make this the current
version

Keep a local copy after
checkin

Subscribe to this file
Check in from file

If available, select this option to have Webtop
scan the document for linked documents. If
linked documents are found, they are checked
in as descendants of the original document.

Determines how quickly the new content is
available to other users, and whether you can
use Webtop while the checkin occurs.

Note: If you used drag-and-drop you are not
given this option.

Select one of these:

¢ Send for immediate global access: Updates
the repository immediately for all your
organization’s users. While this occurs, you
cannot perform other actions in Webtop.

* Send first for local access: Updates the
repository immediately for the users in your
geographic area, but Webtop takes more time
to update the repository for all users. This
allows you to continue using Webtop while
the update occurs.

Note: If checking in multiple files using the Next
button, this option appears only for the first file.
The choice you make automatically applies to
all remaining files.

Saves the updated file to the repository but
keeps the file checked out in your name.

Makes the updated file the current version. For
more information, see Versions, page 35.

Retains a copy of the file on your local computer.
But you no longer have the file checked out, and
any changes you make to the local copy have no
effect on the file in the repository.

The file is linked to your Subscriptions.

Replaces the repository file with a file you
choose.

34
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Versions

A version is a copy of a file at a particular time the file was checked into the repository. A new version
can be created each time the file is checked in. Versions lets you keep track of changes to a file.

When you create or import a new file into the repository, it receives a version number of 1.0.

When you check in a file, you can decide whether to create a new version of the file or overwrite the
existing version (You must have adequate permissions on the file to be given these choices).

* Creating a new version gives the file a higher version number than it had when you checked it
out, and also leaves a copy of the previous version in the repository.

¢ Overwriting the existing version keeps the same version number on the file as the previous
version, and does not save a copy of the previous version.

Depending on your configuration, you might be able to select whether to increase the version number
by a whole number or by just a decimal point (that is, by a tenth). Increasing the version number by a
whole number is considered a major revision; increasing by a decimal point is a minor revision. For
example, if you check out version 1.0 of a file, and check it in as a minor revision, the file is stored as
version 1.1. If you repeat this process, the file is next stored as version 1.2. If you then decide to check
out the file, and then check it in as a major revision, the file’s version number jumps from 1.2 to 2.0.

The most recently checked-in file is marked CURRENT. File lists always display the current versions
of files, unless you select to display all versions.

To display all the versions of a file:
1. Navigate to the file, and select it.

2. Select View > Versions.

To display all the versions of all the files in a list, select Show All Objects and Versions in the
drop-down filter above the list.

You can work with an older version of a file using the same procedures you would use for working
with any file in the repository.

If you edit an earlier version of the file, then when you check in the edited file, you are given these
options:

* You can check in the older version of the file as the new, current version. If you select this option,
Webtop assigns the file a version number higher than the file’s previous current version.

*  You can check in the older version of the file as a branched version. This increments the older file
by a new decimal-appended number. The incremented version becomes the current version in a
new branch of version numbers. For example, if a user checks out version 5.0 of a document, edits
it, and then checks it back in as a major version, the version number becomes 6.0. Version 6.0 is
now the current version of the document. If another user then checks out, and edits version 5.0,
which is no longer the current version, then when the user checks it back in, Webtop creates a
new branch of the document, which starts with version 5.0.1.
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Replace a repository file with a different file

To replace a repository file with a different file:
1. Check out the repository file. For instructions, see Check out a file, page 32.

2. Select the checked-out file in the repository, and select File > Check In.

Tip: Instead of using the File menu, you can drag-and-drop the replacement file from your
local computer to the checked-out file in the repository. If you use drag-and-drop, you are not
given the option to update content locally prior to updating globally. The update immediately
occurs globally.

3. If prompted for checkin information, make sure the Check in from file option is selected. Enter
other information as appropriate. Checkin information varies depending on your organization’s
setup. For an explanation of common checkin fields, see Checkin information, page 33.

4. Click OK.

Cancel checkout of a file

Canceling checkout unlocks the file, and discards the changes you made to the copy of the file on
your computer. The repository retains the last version of the file as the current version.
To cancel checkout of a file:

1. Navigate to the file in the repository, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.
2. Select File > Cancel Checkout.

3. If prompted to confirm cancellation, do one of these:

e If canceling checkout on one file, click OK.

¢ If canceling checkout on multiple files, confirm cancellation for each file separately by clicking
Next. After the last file, click Finish.

Tip: To confirm cancellation for all remaining files at once, click Finish.

View currently and recently checked-out files

To view your list of recently used files, click My Files.

My Files displays both the files that you currently have checked out as well as files that you have
checked back in. The files that you currently have checked out are designated by the key icon.

To view the files you currently have checked out, sort the My Files list according to lock owner by
clicking the key icon in the column headings row.

You can perform all the standard file operations from My Files. Use the same procedures as you
would for any location in the repository.
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If your organization’s setup includes multiple-repository functionality, then My Files also displays
the files you have recently accessed from other repositories, as well as the repository you are currently
viewing. You can perform all the standard operations on files from other repositories, so long as you
have user names, and passwords for those repositories.

View a file in read-only mode

When you view a file, Webtop either streams the file to your computer or downloads a copy of the file
to your view directory. The file is not checked out from the repository. You can make changes to the
file locally, but you cannot save your changes to the repository.

For Windows users, the default view directory is this:
//Documentum/Checkout

If another file with the same name already exists in the view directory, Webtop appends the name
with a number.

You can view a file even if it is checked out by another user.

To view a file without check out:
1. Navigate to, and select the file.
2. Select File > Open (Read Only).

To view links inside an HTML file, you must have virtual link installed.

Change the format associated with a type of file

Every item in the repository has an associated object type. The object type defines what kind of item
an item is, and determines properties, and actions available for the item. By default, an object type is
associated with a file format for editing, and a file format for viewing.

To change the format associated with a type of file:

1. Select Tools > Preferences.

2. Select the Formats tab.

The Formats tab lists types for which the associated applications have been changed from the
default associations.

3. Do one of these:

* To associate an application for a type that is not listed, click Add.
* To associate an application for a type that is listed, select the type, and click Edit.
4. Complete the fields in Table 5, page 38:
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5.
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Table 5. Formats tab

Field

Description

Choose object type
Primary format

Format for viewing

Would you like this content to appear in the
web browser?

Application for viewing

Application for editing

Select the type for which to set the format.
Select the file format to associate with the type.

Select the file format to associate with a
read-only viewing of a file of this type.

If the application can be opened by using a
web browser, you can make that the default
viewing application. To do so, select Yes.

Click Select Application, and select the
application used when viewing items of this
type.

Click Select Application, and select the
application used when editing items of this

type.

To save your changes, click OK.
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Restore associated file formats to the defaults

To restore the associated file formats to the defaults:
1. Select Tools > Preferences.

2. Select the Formats tab.

3. Select the object type.

4. Click Restore Default.

Import files to the repository

If you import a folder, the folder’s contents are also imported.

Depending on your organization’s setup, there might be a limit on the number of items you can
import at one time.

If your setup allows the creation of renditions upon import, there is a delay between the time of
import, and the creation of the renditions.

When you import a document containing linked descendant documents, you can not specify values
for properties of the linked documents while importing the parent document.

To import into the repository:

1. Navigate to the repository location to import.

2. Select File > Import. Then click either Add Files or Add Folders. Select the file or folder, and click
OK. To add multiple files or folders, repeat the sequence. When you have finished, click Next.

Tip: Instead of using the File menu, you can drag-and-drop the file or folder from your local
computer to the location in Webtop. If you use drag-and-drop, you are not given the option to
import locally prior to importing globally. The import immediately occurs globally.

3. If prompted to set properties for imported files, set properties as described in Table 6, page 39.
The table describes common properties. Your installation of Webtop might include different
properties.

Table 6. Properties for imported files

Field Description

Type Do not change this property

Format Do not change this property

Lifecycle ID Assigns a lifecycle to each imported item.
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Field

Description

Check for links to other Microsoft documents,
and import linked documents

Upload options

If this field appears, check this to have Webtop
scan each imported document for linked
documents. If linked documents are found,
they are also imported. The original document
becomes a virtual document, and the linked
documents become descendants.

If this field appears, you can determine how
quickly the imported content is available to
other users, and whether you can use Webtop
while the import occurs. Select one of these:

¢ Send for immediate global access

Updates the repository immediately for
all your organization’s users. While this
occurs, you cannot perform other actions
in Webtop.

¢ Send first for local access

Updates the repository immediately for the
users in your geographic area, but Webtop
takes more time to update the repository
for all users. This allows you to continue
using Webtop while the update occurs.

Do one of these:

e If importing one file, click OK.

e If importing multiple files, set properties for each file separately by clicking Next. After

the last file, click Finish.

Tip: To apply the selected properties to all remaining files at once, click Finish.

Import OLE linked objects

You can import OLE linked objects in Webtop only after enabling the OLE linked objects for import.

To enable the import of OLE linked objects:

1.
2.
3.

Open the app.xml file in the WDK/custom folder of the Webtop application.

Enable the <embedded-links-scan> in <WebApp Root>/wdk/app.xml

Save and close the app.xml file.

To import OLE linked objects into the repository:

1.
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Log in to Webtop and navigate to the repository location to import.
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2. Select File > Import.
The File selection dialog box is displayed.

3. Select the Check for links to other Microsoft documents and import linked documents option.

4. Click Add Files or Add Folders.
The Select Files or Select Folders dialog box is displayed.

5. Select an OLE linked object file, or a folder that contains OLE linked objects, and click OK.
6. Click Next.

7. Set the attributes of the selected OLE linked object files or the attributes of the folder from which
OLE linked object files are imported.

8. Click Finish.
9. If prompted, set properties for imported files.

Tip: You can drag-and-drop OLE linked object file or folder from your computer to the relevant
location in Webtop instead of using the File menu.

Restrict upload of potentially malicious files
into the repository

A Webtop Administrator can restrict the upload of potentially malicious files into the repository,
through Webtop, by configuring the wdk/app . xm1 file.

The Administrator must specify the file formats that are not to be uploaded into the repository, in
the <malicious_file_extensions_list>.<extensions_list> element, of the wdk/app . xml file, using a
comma as a delimiter.

Example 2-1. Listing file formats in the <malicious_file_extensions_list>.<extensions_list> element

<malicious file extensions list>
<extensions_list>exe,bat,msi</extensions_list>
</malicious file extensions list>

This feature is applicable only to files that are imported or checked into the repository, from the 6.7
SP1 release onwards.

Note: By default, no file formats are specified in the <malicious_file_extensions_list>.<extensions_list>
element. Therefore, this feature is turned off by default.

Export files from the repository

You can export a file or all the contents of a folder from the repository. For information about deep
exporting a folder, see Deep export.

When you export a file or folder, you create a copy of the file or folder in a location outside of the
repository. When you export a folder, the folder’s files, and subfolders also are exported.
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While exporting a file or folder from the repository, if Documentum Webtop finds the selected file
or folder on the local machine, Webtop displays a message prompting you to confirm whether you
want the export operation to overwrite existing files and folders, or not overwrite existing files and
folders on the local machine.

To export from the repository:

1. Navigate to one or more files or folders, and select them.

2. Select File > Export.

Tip: If you are using Internet Explorer (IE), you can drag-and-drop the items from the repository
to the appropriate location on your local computer.

3. Specify the location to which to export, select the location, and click OK.

4. If you are prompted to set export options, perform one of the following steps:

¢ If you are exporting one file, set options, and click OK.

e If you are exporting multiple files or folders, set options for each file or folder separately by
clicking Next. After the last file or folder, click Finish.

Tip: To select options for all remaining files or folders once, click Finish.
5. If the file or folder already exists on the local machine, a message is displayed. Do the following;:

a. Click Yes to overwrite or replace a specific file or folder on the local machine. Click Yes to all
to overwrite or replace all existing files or folders.

b. Click No to cancel overwriting a specific file or folder on the local machine. Click No to all to
cancel overwriting all existing files or folders.

Deep export

Webtop provides the ability to export one or many folders and allow the structure of those folders to
remain intact depending on the permission set of the files and folders.

By default, Deep export is disabled, and you have to enable Deep export in app.xml file to make it
work.

When you export files containing special characters (for example, :, ?, <>, ", I, ¥) in their names,
Webtop exports the files after removing the special characters from the file name.

Deep export of a hidden folder is allowed when you export a parent folder. If a folder is not visible in
Webtop, then all the sub-folders including hidden folders get exported during Deep export.

Some rules apply when using Deep export:

* Deep export is supported for UCF content transfer, not HTTP content transfer.
* Only the primary content is exported, no renditions are exported.

* Only the current versions of documents are exported.

* Deep export is trimmed down not to support VDM

* Deep export is automatic when a folder is selected for export.
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Delete an item from the repository

To delete an item from the repository:

1. Navigate to the item, and select it.
Tip: You can perform this procedure on multiple items by selecting multiple items.

2. Select File > Delete.

3. If prompted to select whether to delete related items, make the appropriate selections, and then
do one of these:

¢ If deleting one item, click OK.

¢ If deleting multiple items, make selections for each item individually by clicking Next. After
the last item, click Finish.

Tip: To apply selections to all remaining files at once, click Finish.

Move an item to a new location in the repository

You can move an item to another location within the same repository. By default, Webtop moves
only the selected version of the item. Your administrator might have instead configured Webtop to
move all versions. Ask your administrator which behavior applies.

You cannot move an item that is locked. If an item is locked, the lock owner must first unlock it.

Tip: You can also move items by drag-and-drop.

To move an item to a new location:

1. Navigate to the item, and select it.

Tip: You can select multiple items.

2. Select Edit > Add To Clipboard.

Tip: You can repeat the previous steps to add items from multiple locations to your clipboard.
When you complete this procedure, all the items on your clipboard will be moved to the same
location.

3. Navigate to the location to which to move, and open the location so that the location’s files, and
folders are displayed in the content pane. Select Edit > Move Here.
Tip: Instead of using the Edit menu, you can right-click on the location, and select Move Here.

The items are moved to the new location. The items remain on your clipboard until the next time
you add items to the clipboard. To view your clipboard, select Edit > View Clipboard.

Copy an item to a new location in the repository

You can copy an item from one repository to another, as well as within a repository. When you
copy an item, only the selected version is copied.
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To copy an item to a new location:

1.

Navigate to the item, and select it.

Tip: You can select multiple items.

Select Edit > Add To Clipboard.

Tip: You can repeat the previous steps to add items from multiple locations to your clipboard.
When you complete this procedure, all the items on your clipboard will be copied to the same
location.

If copying to another repository, open that repository in the navigation pane. For more
information, see Log into another repository, page 17.

Navigate to the location to which to copy, and open the location so that the location’s files, and
folders are displayed in the content pane. Select Edit > Copy Here.
Tip: Instead of using the Edit menu, you can right-click the location, and select Copy Here.

If the clipboard appears, select the items to copy, and click Copy.

The items are copied to the new location. The items remain on your clipboard until the next
time you add items to the clipboard.

If you copied an item to a location that already includes that type of item with the same name,
Webtop adds Copy to the name of the copied item.

View your clipboard

Your clipboard holds the files, and other items you are moving, copying, or linking to another location
in the repository. Your clipboard can hold multiple files at once.

To view your clipboard, select Edit > View Clipboard. If an expected item does not appear, make
sure you have set your view filters to display the item.

To remove an item from your clipboard, select the item, and click Remove.

Links

This section includes these:

44

Link an item to another location in the repository, page 45

Link an item to another repository, page 45

View all locations to which an item is linked, page 46

Link a repository item to your computer, page 46

Add a document or folder to your browser’s bookmarks or favorites, page 46
Use email to send a link to a repository item, page 47

Open a link sent by email, page 48

Access the DRL of a document version that is deleted from the repository, page 49
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Link an item to another location in the repository

When you link an item to another location in the repository, the item can be accessed from the new
location in the same way it is accessed from its original location.

You cannot link an item that is locked. If the item is locked, the lock owner must first unlock it.

To link an item to another location in the repository:

1. Navigate to the item, and select it.

Tip: You can select multiple items.

2. Select Edit > Add To Clipboard.

Tip: You can repeat the previous steps to add items from multiple locations to your clipboard.
When you complete this procedure, all the items on your clipboard will be linked to the same
location.

3. Navigate to the location to which to link, and open the location so that the location’s files, and
folders are displayed in the content pane. Select Edit > Link Here.
Tip: Instead of using the Edit menu, you can right-click the location, and select Link Here.

The items are linked to the new location. The items remain on your clipboard until the next time
you add items to the clipboard. To view your clipboard, select Edit > View Clipboard.

Link an item to another repository

You can link an item from one repository to another. This creates a shortcut to the selected item.

You can perform most of the standard file, and folder operations on shortcuts. For example, you can
export, copy, and check out shortcuts. You use the standard procedures to perform such operations.
When you perform an operation, Webtop performs the operation on original item in the original
repository. For example, when you check out the shortcut, Webtop also checks out the original in
the source repository.

Shortcuts are designated by a small, duplicate-icon overlay on the file icon. The overlay looks like a
little copy of either the folder or file icon.

Shortcuts allows users of different repositories to share files over great distances, while making the
shared files local to each office. A shortcut can have both global, and local properties. When you
change a global property value, the value is changed in the source item, and in any other shortcuts.
When you change a local property value, the value is changed only in the current shortcut.

To navigate from the shortcut to the original item, select the shortcut, and then select File > Go
to Target.

To link an item to another repository:

1. Navigate to the item, and select it.

2. Select Edit > Add To Clipboard.

3. In the same Webtop window, open the repository to which to link.

4

Navigate to the location in the new repository.
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5. Select Edit > Link Here.

The Content Server uses automated jobs to synchronize shortcuts, and originals.
Note:

* Replication jobs automatically synchronize the shortcut with the original file. You can manually
synchronize the shortcut without waiting for the automated synchronization to occur by
refreshing.

* Any operations that modify an item are implicitly performed on the source item, and the shortcut
item is updated to reflect the change.

e If your configuration supports translations, then when you create a translation of a shortcut, you
create a new file in the repository. You do not create a shortcut.

*  You can perform lifecycle operations on shortcuts that already have lifecycles applied to them.

View all locations to which an item is linked

To view all locations to which an item is linked:
1. Navigate to the item, and select it.

2. Do one of these:

® Select View > Locations.

e Select View > Memberships.

Link a repository item to your computer

To link a repository item to your computer:
1. Navigate to, and select the item.

2. Select View > Properties > Info.

A shortcut icon appears next to the items name.

3. Drag-and-drop the shortcut icon to the appropriate location. For example, drag-and-drop the
icon to a folder on your computer.

Add a document or folder to your browser’s bookmarks
or favorites

To add a document or folder to your browser’s bookmarks or favorites:
1. Navigate to the document or folder in the repository, and select it.

2. Select File > Add to Favorites.

3. Click OK.
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To open a document or folder from your browser’s bookmarks or favorites:
1. In your browser, select the document or folder from the bookmark or favorite menu.

2. If prompted to log in, enter your login information, and click Login.

To bookmark a document or folder from the Properties dialog box:
1. Navigate to the document or folder in the repository, and select it.

2. Select View > Properties > Info.

The Properties dialog box is displayed with the Info tab selected.

3. Click <insert the attached icon> and select Add to Favorites to bookmark the document or folder.

The Add Favorite dialog box is displayed.
4. Click OK.

Use email to send a link to a repository item

To send a link in an email message:

1. Locate the repository item, and select it.

Tip: You can perform this procedure on multiple items by selecting multiple items.

2. Select File > Email as Link.

Your email application opens a new email message, and inserts the link to the repository item.

3. Type the email address, and any message as appropriate, and send the email.

Convert Desktop DRLs to Webtop URLs

The Documentum Desktop client has been phased out. As a result, Desktop users will no longer

be able to access desktop DRLs (links to repository documents) embedded in e-mail messages.
Documentum Webtop 6.5 SP2 and later versions provide existing Documentum Desktop client users
with the DRLinvoker application (DRLinvoker.exe) that converts desktop DRLs to Webtop URLs
and open linked documents in a browser window, seamlessly. After installing the DRLinvoker
application, users must associate the Desktop DRL converter utility with the OS as a one time
configuration.

Note: The .NET 2.0 platform is required to ensure that the conversion of Desktop URLs to Webtop
URLs functions properly.

To download the DRLinvoker application:

1. Download the DTC-DRL-To-Webtop-URL.zip file from the FTP site.

2. Extract the contents of the zip file to a local folder.

3. Ensure that the config file "DRLinvoker.exe.config" is extracted successfully, and placed under
the same folder where the application resides.

4. Edit the config file and make the following changes using a text editor:
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a. Modify host entry to point the location where the application server that hosts Documentum
Webtop is installed.

b. Modify the port entry to point to the application server listening port of Documentum
Webtop.

c. Modify the contextURI entry to the appropriate context name with which Documentum
Webtop is registered on the application server (For example, if the URL used to access Webtop
is http://mypictet.com:8080/webtopdev, then the contextURI entry must be "webtopdev".)

d. Save the config changes and close the text editor.

To associate the Desktop DRL converter utility with the OS (one time only):

1.

2
3.
4

Open the e-mail message containing the DRL.
Right-click the DRL and save the linked document on the local machine.
Locate the .drl file on your local machine.

Based on your operating system, perform the relevant steps:
On Windows XP/XP Home:
1. Right-click the file and select the option Open With.

2. Select Choose Program. The Open With dialog box is displayed.

3. Locate the DRLinvoker.exe as the program to open files of this type.

4. Select the checkbox Always use the selected program to open this kind of file.
5. Click OK.

On other versions of Windows:
Select the file.

Hold down the Shift key and right-click the file.
Select the option Open With. The Open With dialog box is displayed.

1.

2.

3

4. Locate the DRLinvoker.exe as the program to open files of this type.

5. Select the checkbox Always use this program to open files of this type.
6

Click OK.

Subsequently, you can double-click .drl files to open linked documents.

Open a link sent by email

To open a link sent by email:

1.
2.
3.

48

Click the link.
If prompted to log in, enter your login information, and click Login.

If prompted to select how to open the file, make selections as appropriate.
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Access the DRL of a document version that is deleted
from the repository

When you click a DRL to access a document version that is deleted from the repository, a warning
message is displayed indicating that the version is no longer available. When you click OK, Webtop
accesses the current version of the document and prompts you to choose to view or edit the document
before opening the document. For example, if you click the DRL of version 1.2 of a document, and

if that version has been deleted from the repository, a warning message is displayed indicating

that version 1.2 is no longer available. When you click OK, Webtop prompts you to view or edit

the Current Version of the document.

Configure Webtop to enable access to the current version of a document when you use the DRL of
the deleted version of the document. The EMC Documentum Web Development Kit Development Guide
contains more information.

Subscriptions

The items you subscribe to appear in your Subscriptions node. When you access an item through this
node, the item is retrieved from its original repository location.

When you subscribe to a repository item, you are subscribed only to the current version, which is
the latest version of the item. For example, if you select a repository item that has multiple versions,
and the latest version is 1.3, and you subscribe to version 1.2, you are subscribed to version 1.3 of the
repository item, and not to version 1.2 of the same item.

To subscribe yourself to a repository item:

1. Navigate to the item, and select it.

2. Select Tools > Subscribe.

Tip: Instead of using the Tools menu, you can drag-and-drop the items to the Subscriptions
node in the navigation pane.

To subscribe another user to a repository item:

1. Navigate to the item, and select it.

2. Select Tools > Subscribe Others.

3. In the selection dialog box, select one or more users, and click OK. For detailed steps see Locate
an item in a selection dialog box, page 21.

To cancel your subscription to an item:

1. Navigate to the item, and select it.

2. Select Tools > Unsubscribe.
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Receive notification when a file is read or
changed

To have a notification sent to you when a file is read or changed:
1. Select the file.

Tip: You can perform this procedure on multiple files by selecting multiple files.

2. Do one of these:

¢ To have notification sent any time a file’s content is viewed, whether by opening, checking
out, or exporting, select Tools > Turn on read notification.

* To have notification sent any time a file is changed, select Tools > Turn on change notification.

Notifications are sent to both your Webtop inbox, and your email inbox.

Tip: You can later turn notification off by selecting the file, and selecting either Tools > Turn off
read notification or Tools > Turn off change notification.

Export the information displayed in a list

When you export the property values of the items in a particular list, the information is saved as a
.csv file, which opens in your default application for .csv files.

Before performing this procedure, make sure your browser’s security settings allow file downloads.

To export information displayed in a list:
Navigate to list.

Select Tools > Export to CSV.

Select the columns to export as metadata.
Click OK.

Select whether to view or save the .csv file.

If you chose to save, select the location to which to save.

N o gk D=

Do one of these:

e If using a browser other than Internet Explorer (IE), click OK.
e If using IE, press, and hold down Ctrl, and click OK.

If have exported columns that contain special characters, and if you open the .csv file in Microsoft
Excel but Excel does not display them correctly, then save the file to your computer, and close it, and
then use the Data > Import External Data > Import Data menu option to import the .csv file.
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Export specific search results as a CSV file

You can export selected items in a list from the repository to a comma-separated values (.csv) file.
When you choose specific items from a search result list and export the items, the data is exported to
a .csv file.

To export selected rows:

1.
2.
3.

Navigate to a list.
Select the items to export as comma separated values.

Right-click and select Export To CSV or select Tools > Export to CSV.
The Export Contents To CSV dialog box is displayed.

Move the columns you want to export from the Select columns list to the Selected columns list.

Click OK. You are prompted to open or save the .csv file.

EMC Documentum Webtop Version 6.8 User Guide 51



Files and Folders

52

EMC Documentum Webtop Version 6.8 User Guide



Chapter 3

Email Messages

Email message import support

From Webtop 6.8, Webtop imports email messages as dm_document type or its subtypes and in
Outlook Message Format (.msg) to the repository. By default, importing of .msg messages is enabled.
Import to dm_message_archive is not supported.

Email message functions

Following are the list of changed functions from Webtop 6.8:

e Import: When you import email messages, the email messages are imported as dm_document
type and in the .msg format. Import email messages to the repository, page 53 contains detailed
information.

* Export: When you export an email message, Webtop creates a copy of the email as a .msg file in
the location you choose. Export email messages from the repository, page 54 contains detailed
information.

* View: Email messages in the .msg format can be viewed using the Microsoft Outlook client only.
View email messages, page 55 contains detailed information.

* Transform: Email messages in the .msg format can be transformed to PDF and other formats.
Transform email messages, page 55 contains detailed information.

* Search: Advanced search is enhanced to allow searching of email messages in .msg or EMCMEF or
both the formats. Search email messages, page 55 contains detailed information.

e Conversion utility: A conversion utility is available that converts EMCMF messages to .msg and
store them into the repository. The EMC Documentum Webtop Email Migration Guide contains
detailed information.

Note: DRL view, drag and drop, export, and other operations on the EMCMF messages are not
supported.

Import email messages to the repository

You can import the .msg messages to the repository as dm_document type or its subtypes. The
imported .msg messages cannot be edited.
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To import email messages to the repository:

1. In Microsoft Outlook, do one of these:

* Drag and drop one or more email messages to a location in Webtop. Skip to Step 4
* Save one or more email messages to a location on your computer.
2. In Webtop, navigate to the repository location to which you must import the email messages.

3. Select File > Import, click Add Files, select an email message, and click OK. To add multiple
email messages, repeat the sequence. Click Next.

4. Set properties as described in Table 7, page 54. If you are importing more than one email message,
click Next, and set properties for each message individually.

Table 7. Properties for imported email messages

Field Description
File You cannot change this property.
Name You cannot change this property. By default, the name is the

subject of the email. To change the name, set the value of
override-object-name to true in app . xml.

Type By default, the type for email messages is dm_document. You
can also import as subtypes of dm_document type.

Format You cannot change this property.

Lifecycle ID To assign a lifecycle to the email message, click Select, and

assign the lifecycle.

5. Click Finish.

Note: If Webtop is configured to separate the email attachments, you can view the attachments
in the original import location. To view the attachments, select Tools > Preferences > Show
Hidden Files.

Export email messages from the repository

A message can be exported from the repository with its attachments, and saved locally as a single
file, with the attachments embedded within.

To export email messages from the repository:
1. Navigate to one or more email messages, and select them.

2. Select File > Export.

Tip: Instead of using the File menu, you can drag and drop the email messages from the
repository to the appropriate location on your local computer.
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3. 1If prompted to set export options, do one of these:

* To export one message, set options, and click OK.

¢ To export multiple messages, set options for each separately by clicking Next. After the
last message, click Finish.
Tip: To select options for all remaining messages at once, click Finish.

4. If prompted for the location to which you must export, select the location, and click OK.

View email messages

To view .msg messages:
1. Navigate to the email message, and select it.

2. Select File > View.

The email message opens in Microsoft Outlook.

To view EMCMF messages:
1. Navigate to the email message, and select it.

2. Select File > View.

The email message opens in HTML Viewer. From HTML Viewer, click View as Outlook to
view in Microsoft Outlook.

Note: Email messages in the EMCMEF format can only be viewed.

Transform email messages

To transform email messages:
1. Navigate to the email message, and select it.

2. Select Tools > Transform > More Formats.

You can transform to the available rendition options in More Formats depending on the
deployment.

Search email messages

In the enhanced advanced search screen (Figure 2, page 56), select Switch to Search Emails. It opens
a form to search for email messages based on criteria.
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Figure 2. Advanced search
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* To search for .msg only: Ensure Search EMCMEF also is not selected, type the search string,
and click Search.

* To search for both .msg and EMCME: Select the object type as dm_document, select Search
EMCMEF also, type the search string, and click Search.

¢ To search for EMCMF only: Select the object type as dm_message_archive, type the search
string in the subsequent form, and click Search.

Locate and open an email attachment

The attachments are embedded but can also be separately stored based on the email configuration for
the application. You can view the embedded attachments similar to viewing of the email message,

as described in View email messages, page 55. If the attachments are separately stored, it can be
located in the location where the email is stored. By default, attachments are hidden. To view the
attachments, select Tools > Preferences > Show Hidden Files.

Tip: You can also perform the search operation to locate an attachment. To do so, type all or part of
the attachment’s name into the search box. Chapter 4, Search contains detailed information.

Note: All operations available on a document can also be performed on attachments.
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Locate the email to which an attachment
belongs

To locate the email to which an attachment belongs:

1. Type all or part of the attachment’s name into the search box. Chapter 4, Search contains more
information.

2. Right-click the attachment, and select View > Location.
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Chapter 4

Search

Run a simple search

When you enter a search term (a word or phrase) in the simple search box, the term is matched to
documents or other objects that have the search term within the document itself or within the object’s
properties. This kind of search is called a “full-text” search.

It searches the files in your default search location. Your default search location is specified in your
search preferences. Set search preferences, page 77, describes how to add a search location. You can
search several repositories at the same time but you also have the possibility to search external
sources such as external databases, web sources or your desktop.

If your repository has been indexed for parts of speech, Webtop displays files that include variations
of the words you typed. For example, if you type scanning then Webtop also looks for files that
contain the words scan, or scanned.

To run a simple search:

1. In the box above the navigation pane, type the words for which to search.
To further define your search, see Further define search terms, page 59.
2. Click *.
If your search includes several terms, and if the index server is Fast, the results displayed first

will contain all search terms, then Webtop will display the results that contain only some of
the search terms.

If your search includes several terms, and if the index server is xPlore, all the results displayed
will contain all search terms.

Tip: To stop the search, click Stop .

3. See View search results, page 66.

Further define search terms

You can use the syntax in Table 8, page 60 to further define search terms within a simple search or
within the Contains field in an advanced search.
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Table 8. Further define search terms

Syntax

Description

Quotation marks
around a word or
phrase: " "

The AND and OR
operators

The NOT operator

60

To search for an exact word or phrase, type quotation marks around the
word or phrase.

For a simple search (including the Contains field in an advanced search),
if you do not use quotation marks, Webtop displays files that contain
both the exact words you typed as well as variations of the words, such
as scanning for the word scanner.

This option is disabled when searching for more than one word or if your
repository has not been indexed for variations.

Quotation marks cannot be used to match the exact case of a word.

To get results that contain two search terms, type AND between the
terms. A term can be a word or quoted phrase.

To get results that contain at least one term, type OR between the words
or the quoted phrases.

You can string together multiple terms with the AND and OR operators.
The AND operator has precedence over the OR operator. For example,
if you type:

knowledge or management and discovery
then your results must contain either knowledge or they must contain
management, and discovery.

To get results that do not contain a term, type NOT before this term. The
term can be a word or a quoted phrase. Only the term that follows the
operator is taken into account.

The NOT operator can be used after the AND or OR operator, separated
by a space.

Valid syntaxes would be: Documentum NOT adapter or Documentum AND
NOT adapter, both queries will return results that contain Documentum
but do not contain adapter.

If you type Documentum OR NOT adapter, you get results that either
contain Documentum (and possibly contain adapter) or that do not
contain adapter. Use this syntax cautiously. It can generate a very large
number of results.

The NOT operator can be used alone at the beginning of the query. For
example, if you type NOT adapter, you get results that do not contain
adapter. Use this syntax cautiously. It can generate a very large number
of results.

The NOT operator is not supported for queries on external sources when
it is alone at the beginning of the query or if used with the OR operator.
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Syntax Description

The NOT operator cannot be used with parentheses. This is invalid:
A NOT ( B OR C ). However, the NOT operator can be used inside
parentheses. This is valid: (A NOT B) OR (A NOT C).

ANDNOT (in one word) is not an operator, if you enter ANDNOT in a
query, it will be considered as a search term.

Parentheses around To specify that certain terms must be processed together, use parentheses.
terms: () When using parenthesis, you must type a space before, and after each
parenthesis mark, as shown here: ( management or discovery )

As an example, if you type knowledge and management or discovery, then
your results will contain both knowledge, and management or they will
contain discovery. But if you type knowledge and ( management or discovery
), then your results will contain knowledge, and either management or
discovery.

The multiple-character If the repository is indexed with Fast index server, you can use the
wildcard: * multiple-character wildcard to indicate additional characters anywhere
in a word. It matches zero or more characters.

If the repository is indexed with xPlore index server, the multiple-character
wildcard works only on whole words, not parts of words, but results

can include variations of the words you typed. For example, a query for
computer* matches computer store or computer parts but not computerize.

By default, xPlore does not support search for word fragments because
searching for whole words is much faster. To change this default behavior
to work like the Fast index server, the xPlore administrator can turn on
the option to search for word fragments.

The multiple-character wildcard is only available for a simple search
(including the Contains field in an advanced search).

The multiple-character wildcard is not available for searches on
non-indexed repositories, for searches of property values, or for searches
on external sources. For those, you should use truncation operators, such
the Begin with operator.

If you use wildcards, then Webtop will not display results that include
variations of the words you typed. For example, if you type d*ment
then your results must contain: document, development, deployment,
department, etc. but not documented or documentation.
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Syntax Description
The single-character If the repository is indexed with Fast index server, you can use the
wildcard: ? single-character wildcard to indicate a single, unknown character

anywhere in a word.

The single-character wildcard is only available for a simple search
(including the Contains field in an advanced search).

The single-character wildcard is not available for searches on non-indexed
repositories, for searches of property values, or for searches of external
sources. It is not available with xPlore index server.

The NEAR(n) operator To get results where the occurrences of two or more query terms are
within a specified distance, use the NEAR(n) operator where 7 is the
number of intermediate words. Query terms can match in any order.
Type the query terms in parenthesis. You can use the NEAR operator
with the AND and NOT operators. For example: a search on (EMC AND
president) NEAR(3) returns results where the terms EMC and president
are only separated by three words.

Note:

* The operators AND, OR, and NOT are reserved words. To search a term that includes an operator,
use quotation marks. For example, if you search for "hardware and software", Webtop returns
documents with that string of three words. If you type hardware, and software without quotation
marks, Webtop returns all of the documents that contain both words.

* The operators AND, OR, and NOT are not case-sensitive. For example, for your convenience, you
can type: AND, and, And.

Run an advanced search

To search for a document by one of its properties, use advanced search. An advanced search enables
you to define more precisely your query on the properties of the document. For example, you can
search the current version of the documents whose author is John Smith, and modified between
November 1, 2006 and December 31, 2006.

To run an advanced search:

1. On the Webtop main page, click the arrow next to the magnifying glass icon, and then click
Advanced.

2. Enter values for the search. See Enter values for an advanced search, page 63.

3. Click Search.
Tip: To stop the search, in the result page, click Stop 2.

4. See View search results, page 66.

Note: In dm _message archive specific Advanced Search page, use the Reset link to navigate to
generic Advanced Search page. This link is available only on the dm message archive specific
Advanced Search page.
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Enter values for an advanced search

This procedure assumes you have already opened the Advanced Search page. If you have not,
see Run an advanced search, page 62.

Tip: In the Advanced Search page, you can clear any existing values, and start with empty fields
by clicking Clear.

To enter values for an advanced search:

1. In the Contains field, type the text for which to search.

This field is similar to the simple search. To further define your search, see Further define search
terms, page 59.

2. In Locations, select the locations to search.

To add locations, do these:

a.

b.

f.

g.

Make sure that Current location only is not selected, then click Edit.

In Available Repositories or Available Sources, navigate to, and select the location. The
location in Available Repositories can be a repository, a cabinet or a folder. Available
Sources is displayed only if Webtop is configured to search external sources.

If you select repositories or sources for which your credentials are not saved, a login window
may appear.

Click the arrow to add it to the Included in Search list.

Repeat Step b and Step ¢ for as many locations as needed.

To remove a location, select it, and click the remove arrow.

To set the locations as your default locations for every new search, select Set as default.

Click OK.

3. In the Object Type list, select the type of files to search for.

4. Enter remaining properties as appropriate. Table 9, page 63 describes common properties. The
properties available depend on the type of file you search for, as selected in the Object Type list
in Step 3.

Table 9. Common properties in an advanced search

Field Description

Properties list Enter one or more property values to search for by doing these:

1. If no fields appear, click Select a property.

2. On agiven line: In the first drop-down list, select a property. In
the second drop-down list, select a property-to-value relationship.
For a description of possible relationships, see Table 10, page 65. In
the remaining fields, select or type values.
If you type multiple words, they are searched for as a phrase.
For example, if you type "knowledge management" then
Webtop searches for values that contain the phrase "knowledge
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Field

Description

Date

Size

management” but not for values that contain "knowledge" and
"management" separated from each other by other words such as
“knowledge and process management”. If you want your results
to include both terms either as a phrase or separately, you must
create two subqueries, and use the AND operator.

3. To add additional properties, click Add another property, and
then select one of these operators:
* And: Selecting this means that the search results must match
both the property value on this line, and the property value on
the previous line.

¢ Or: Selecting this means that the results can match either
the property value on this line or the property value on the
previous line. If you search external sources, do not use the OR
operator between different types of properties. This query is
valid: "Author contains Lewis OR Author contains Twain," but
this query is not valid: "Author contains Lewis OR Name contains
Knowledge management."

If you add three or more lines of properties, the order of operations
follows the order of definition. Each time you add And or Or,
the previous operators are grouped together. For example, if

you define the query "Name contains Knowledge Management AND
Author contains Lewis OR Author contains Twain," then the results
either must contain the documents whose name is Knowledge
Management, and whose author is Lewis or they must contain all
the documents whose author is Twain. To find all the documents
whose name is Knowledge management, and whose author is
either Lewis or Twain, you must define the following query:
Author contains Lewis OR Author contains Twain AND Name contains
Knowledge management.

4. To remove a property from the search criteria, click Remove for
that property.

Select the type of date to search for. Specify a date range, either a fixed
date range using today’s date or by typing the From and/or To dates.
Months can be written in figures or in full. Years can be written with
two or four figures.

When specifying a date From, the date is not included in the date
range. Conversely, when specifying a date To, the date is included in
the date range.

Select a size range.
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Field Description
Properties when Subject
searching for email To
messages
From
Sent
Received

Type the words for which to search. To further
define your search, see Further define search
terms, page 59.

Select the date the email message was sent.

Select the date the email message was received.

Find hidden objects = Choose to include hidden items in the search. The search displays only
those hidden items that you have permission to view.

Find all versions
version.

Choose to search for past versions of the file, as well as the current

The relationship between a property, and its corresponding value is defined by operators. Table 10,
page 65 describes the operators available in the Advanced Search page.

Table 10. Select a property-to-value relationship

Operator

Description

Relational operators:
Less than <

Less than or equal to <=
Greater than >

Greater than or equal to >=

Equal to =

Not equal <

Truncation operators:

Begins with

Ends with

Contains

Does not contain
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You can use these operators with numerical
values or strings.

Returns results in which the property value
contains only the exact value you typed.

Returns results in which the property value
never matches the value you typed.

The truncation operators can be used in place of
the multiple-character wildcard.

Returns results in which the property value
begins with the value you typed. Same as using
an ending wildcard.

Returns results in which the property value ends
with the value you typed. Same as using an
starting wildcard.

Returns results in which the property value
contains the value you typed anywhere within
it. Same as using starting, and ending wildcards.

Returns results in which the property value
does not contain the value you typed anywhere
within it.
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Operator Description

Other operators:

In

Returns results in which the property value
matches one of the values you typed. Potential
values are typed as a comma-separated list.

Not in Returns results in which the property value does

not match any of the values you typed.

Is null Returns results in which the property value

is not defined. If you know that a property
contains no value, you can use this operator to
narrow a search.

Is not null Returns results in which the property value is

defined, but with no specific value. You can
use this operator to find only documents whose
properties are defined. For example, if you
select keywords is not null then your results
must contain only documents with keywords.

View search results

In search results, you can do these:

66

Highlight the results.
Click .~ to turn highlighting on.
Click -~ to turn highlighting off.

The results appear in the navigation pane as well as the content pane. The results in the navigation
pane are arranged according to property.

To view results that include a certain property, click the property. For more information, see
Smart navigation, page 67.

To view a different page in a multi-page results list, click the arrows above the list. If you click
Goto last page before the search completes or when a + symbol appears in the paging control, it
goes to the last page shown in the paging control instead of the last page of the total search results.

L
To get additional information about the search, click Status . This displays search statistics
according to search location. If your organization includes the search monitoring feature, this also
displays the statistics in real time, as described in Monitor search results in real time, page 67.

To revise the search, and run it again, click Edit E', and set values as described in Enter values for
an advanced search, page 63, and click Search.

To run the search again without revising it, click Restart [sg

To save the search so that it can be run again to receive updated results, see Save a search to run
again later, page 72.
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¢ To save the search as a search template so that it can be run again with different parameters, see
Create a search template, page 75.

¢ To save results from an external source into a repository, see Save search results from external
sources, page 68.

Smart navigation

When you run a search, your results are not only displayed in the content pane, but they are also
grouped into clusters of related results in the navigation pane.

To collapse or expand the Smart Navigation list, click the minus/plus sign at the top of the list.
To expand a cluster or sub cluster, click the plus sign next to the cluster.

To display a sub cluster’s results in the content pane, click the sub cluster.

To refresh the Smart Navigation list with new results, click @. The icon appears only if new
results are available.

Webtop computes sub clusters using the strategy defined in your user preferences. To set your
preferences, click %, and then follow the appropriate steps in Set search preferences, page 77.

Monitor search results in real time

Search monitoring displays the status of your search in real-time. The real-time status appears in both
an animated display, and in a table, as shown in Figure 3, page 68. Search monitoring allows you to
see which search sources return results the fastest.

L3
To display search monitoring, click Status ™ as soon as the search has started.
T
To replay the animation after the search has completed, click the Refresh icon, . When you

replay the animation, you see a replay of how the search occurred. Replaying the animation does
not rerun the query.

EMC Documentum Webtop Version 6.8 User Guide 67



Search

Figure 3. Real-time results in the search monitor screen
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In the animation, each search source is represented by a pie slice. The number of layers in a slice
corresponds to the number of results: one layer indicates no results; two layers indicate 1 to 50 results;
and three layers indicate 51 or more results. Modified configurations might vary.

The color of a slice indicates the source status: blue when searching, green when the search is
completed, and orange if the search has failed.

Click a source’s slice to highlight its corresponding row in the table.

Click Show native query to view the native query that indicates how the query was translated for
the source.

The animation displays the sources sixteen by sixteen, so the first view of the animation only displays
the first sixteen sources. If you are running the search against more than sixteen sources, you can see
the next sixteen sources by clicking Next below the animation.

If a search fails for a given source, a detailed error message is displayed in the Note column of the
table. To get additional information about the error, select Tools > View messages.

Note: If you launch the monitoring when viewing the results of saved searches or the last search
results, the query is not rerun, and the animation does not replay entirely. The source status is first
waiting with zero result then it is immediately updated to show the final status of the sources, and
the number of valid results returned by each of them.

Save search results from external sources

This procedure enables to save results from an external source into a repository.
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To save a search result of an external source into the repository:

Select the result(s).

Select File > Save to repository.

In the Folder selection window, select the target folder from the list of available repositories.
Click Next to check the object definition or Finish to complete the procedure.

In the Object Definition window, modify the object properties as needed.

Click Next to check the object definition for these result(s) or Finish to complete the procedure.

N o gk »h=

Repeat Step 5, and Step 6 as many times as needed.
Saved results are available in the selected folder but they are also displayed in My files.

View your most recent results but do not
relaunch the search

This procedure applies only to your current Webtop session.

To view your most recent search results:

1. At the top of the Webtop page, click the arrow next to the magnifying glass icon.
2. Click Last Results.

Improve your search experience

Your search experience can be restricted or improved by your understanding of the search syntax,
and of the various parameters that define the search environment. The search syntax is the way you
write the query, which implies the use of operators, and special characters such as parentheses,
quotation marks or wildcards. The search syntax is documented at the beginning of this chapter

in Run a simple search, page 59, and Run an advanced search, page 62. The search environment
corresponds to the circumstances when the query is run; that is: the repository configuration, external
sources configuration, the configuration of your WDK application. All these parameters are not
visible nor accessible to users; however, they should be taken into consideration when running
queries in order to get the most relevant results.

This section describes these aspects that influence your search experience:

¢ How configuration can impact your search experience, page 70
¢ Index a repository, page 71
¢ Searchable items, page 71
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How configuration can impact your search experience

The search functionality description given in this manual refers to the default configuration.
However, your system administrator can configure this functionality in many ways. This list details
possible configurations that may affect your search experience:

70

Indexing

Whether a repository is indexed is not of your interest, and usually, you don’t need to know it.
However, in some cases, indexing capabilities can be used to define more precise queries. For
example, wildcards can only be used if the repository is indexed, if not, they are skipped. In
Documentum version 6.7, two index servers are supported: Fast and xPlore. The behavior of
search operators may be slightly different between the two. For example, when searching for
several terms separated with spaces, the spaces are interpreted as an OR operator with Fast index
server, while they are interpreted as an AND operator with xPlore index server. If you want to run
complex queries, consult the system administrator for details on the indexing configuration of the
repository. The section Index a repository, page 71, provides more information about indexing.

Relevancy ranking

The system administrator can specify a bonus ranking for specific sources, add weight for a
specific property value or improve the score for a specific format.

Presets

The system administrator can define a preset to restrict the list of available types in the Advanced
search page. Presets can be different from one repository to another. If you select only external
sources, the preset of the current repository applies.

Customization of the Advanced search page

The Advanced search page can be fully customized to guide you in running queries. For this
reason, all the options described in this guide may not be available, and other may appear to
narrow and/or condition your queries.

Maximum number of results

The maximum number of results is defined at two levels. By default, the maximum number of
results, taking all sources together, is 1000 and 350 results per source. However, your system
administrator can modify these parameters. When querying an external source, the maximum
number of results also depends on the configuration set for this source. Results are selected
according to their ranking. This way, you always get results with the best ranking; other results
are skipped.

Case-sensitivity

If the repository is indexed, queries are case-insensitive by default, even using quotation marks.
If the repository is not indexed, then queries are case-sensitive. However, for non-indexed
repositories, case-sensitivity can be turned on, and off by the system administrator.

Grammatical normalization (lemmatization)

When you do not use quotation marks, Webtop displays files that include variations of the
words you typed in addition to the exact words. These variations are based on the word'’s root.
This behavior depends on the configuration of the full-text engine, and is called grammatical
normalization. The variations are based on the grammatical context of the word. For example, a
search for the verb "run" also finds "ran" but does not find the noun "running."
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e External sources

When querying an external source, the results displayed in Webtop depend partly on the
configuration of this source. For example, if the source does not return information on dates,
then dates cannot be filtered.

e Multiple repositories

As for external sources, the results depend on the configuration of each repository. For example,
the indexing may be set differently on various repositories.

Index a repository

Indexing a repository is the administrator’s job, and you could think you don’t need to know what is
indexing, and whether the repository you are using is indexed or not. However, indexing can have
an impact on the search experience. When a repository is indexed, a data structure, the index, is
created to store information. The information can either be on the files” properties only or on the
properties, and the content of the files. Searching an indexed repository facilitates a rapid retrieval of
documents because it does not require scanning all files but only searching the index. In this guide,
when referring to an indexed repository, we mean a repository for which both content, and properties
are indexed, and not only properties. When the repository is indexed, you run full-text queries
when using the simple search box or the Contains field of the advanced search window. When the
repository is not indexed, the query is converted into a query on the most relevant properties: name,
title, and subject. This mechanism is transparent, and enables you to retrieve the most relevant results.

Searchable items

Only the documents that are indexable can be searched. For example, pictures or binary content
cannot be searched because they are not indexable.

Moreover, not all characters are searchable. Searchable characters are alphabetic, numeric, extender,
and custom characters. Custom characters enclose Chinese, Japanese, Korean letters, and months.

Other characters, including punctuation, accent, and diacritical marks, and characters such as | and
#, are not indexed or searched. Such nonsearchable characters are removed from the indexed text,
and treated as if they are blank spaces. The index server treats these characters as white space:
1@#$%"_,.&;:()+=<

When these characters appear in indexable content, they are replaced by white space. For example,
when the email address MyName@company.com is indexed, it appears as “MyName company
com” in the index. The text is treated as three words. Documents returned by a search for
MyName@company.com are treated as if they contain the words “MyName company com”.

If a special character is included in a query, it is removed. For example, querying on Richard+Dodd
would return a document containing the text Richard=Dodd because the + and = signs are both
replaced by a blank space. If a search term includes an accent or diacritical mark, the search returns
all matching words with or without the accent or diacritical mark.
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Note:

¢ Unlike web browser search, you cannot use the plus, and minus signs as operators. You must
use the AND operator, and the OR instead.

¢ The asterisk, and the question mark can be used as wildcards.

Saved searches

Searches can be saved so that you can launch them regularly without redefining them, share them
between users, or to quickly retrieve the corresponding results. In the Saved Searches node, public,
and private searches are distinguished by one of the following icons:

o @ means this saved search is public, and accessible to any user.
e % means you are the only one that can access this saved search.

Saved searches are displayed outside of the Saved Searches node with a general icon: Q.
This section includes these:

* Save a search to run again later, page 72

* Run a saved search, page 73

¢ View the results of a saved search but do not relaunch the search, page 73

* Edit a saved search, page 73

¢ Copy a saved search, page 74

Save a search to run again later

You can save a search so that it can be run again later to retrieve updated results.

To save a search to run again later:
1. From the search results page, click Save =]
2. Type a name for the saved search.

3. To display the results of this search in the Saved Searches node without having to run the search
again, select Include Results.

4. To allow other users to access this search, select Make Public.

5. Click OK.
The saved search is stored in the repository’s Saved Searches node.

Though the saved search is stored in one repository, you can use the saved search to search
across multiple repositories.
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Run a saved search

When you run a saved search, the search uses the same parameters but returns updated results.

To run a saved search:
1. In the navigation pane, click Saved Searches.
2. If necessary, click the Saved Searches link in the content pane. Otherwise, skip this step.

3. Select the saved search, and select File > View.
Webtop runs the search.
Tip: To stop the search, in the result page, click Stop .

4. See View search results, page 66.

View the results of a saved search but do not relaunch
the search

To view the results of a saved search:
1. In the navigation pane, click Saved Searches.
2. If necessary, click the Saved Searches link in the content pane. Otherwise, skip this step.

3. Double-click any saved search for which the Results column indicates that the search turned
up one or more items.

Note: If the results were not saved with the search then the search will be relaunched when you
double-click it. If you don’t want to possibly relaunch the search, use the context menu. To do so,
right-click the saved search, and select View saved results. This command is only available when
results were saved with the search.

Edit a saved search

To edit a saved search:

1. In the navigation pane, click Saved Searches.

2. If necessary, click the Saved Searches link in the content pane. Otherwise, skip this step.

3. Select the search, and select File > Edit.

4. Set values as described in Enter values for an advanced search, page 63, and then click Search.
5

Click Save Search to apply the changes. You should also save your search if you modified the
results display.

Click OK.

o

7. Click Overwrite.
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Copy a saved search

To copy a saved search:
In the navigation pane, click Saved Searches.
If necessary, click the Saved Searches link in the content pane. Otherwise, skip this step.
Select the search, and select File > Edit.

1
2
3
4. Set values as described in Enter values for an advanced search, page 63, and then click Search.
5. From the results page, click Save Search.

6

To save the search as a copy with a different name, type a new name for the search. Otherwise the
search is saved as a copy with the same name.

N

Edit additional information as needed.
8. Click OK.
9. C(lick Save as New.

Search templates

Like saved searches, search templates are designed to be easily reused. A search template is a
predefined search for which some search values are fixed, and other search value can be defined by
the current user. Search templates can be private or public. In the Saved Searches node, public, and
private search templates are distinguished by one of the following icons:

o [ means this search template is public, and accessible to any user.

o & means you are the only one that can access this search template .

Search templates are displayed outside of the Saved Searches node with a general icon: &4,
This section includes these:

* Run a search from a search template, page 75

* Create a search template, page 75

e Edit a search template, page 76

* Modify a search template definition, page 76

¢ Copy a search template, page 77
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Run a search from a search template

You can run a search from a search template created by you or by another user.

To run a search based on search template:

1.

2
3
4.
5

In the navigation pane, click Saved Searches.

If necessary, click the Search templates link in the content pane. Otherwise, skip this step.
Select the search template, and select File > View.

If prompted for search values, enter values as appropriate.

Click Search.
Tip: To stop the search, in the result page, click Stop 2.

See View search results, page 66.

Create a search template

A search template is a predefined search in which you can change certain search values each time you
run it. For example, a search template could search for invoices dated this month for the customer
you choose. You could run the search template to retrieve invoices for numerous different customers.

A search template cannot include the OR operator.

To create a search template:

1.

S

Run an advanced search (see Run an advanced search, page 62), and select the properties,
and values to include in the search template. You must select at least one property, and value
combination.

To include a property for which the user will set the search value, set a temporary value for that
property. You can make that property editable later in this procedure.

From the search results page, click Save template B
Type a name for the search template.
To allow other users to access this search, select Make this search available to others.

To allow users to change values for a property, use the arrow to move that property to the Input
fields box.

To keep a user from changing the value of a property, leave the property in the Fixed values box.

Click Save.
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Edit a search template

To edit a search template:

1. In the navigation pane, click Saved Searches.

2. If necessary, click the Search templates link in the content pane. Otherwise, skip this step.
3. Select the search template, and select File > Edit.

4. To allow other users to access this search, select Make this search available to others.

5

To allow users to change values for a property, use the arrow to move that property to the Input
fields box.

To keep a user from changing the value of a property, leave the property in the Fixed values box.

6. Click Save.

Modify a search template definition

To modify the search template definition:

1. In the navigation pane, click Saved Searches.

2. If necessary, click the Search templates link in the content pane. Otherwise, skip this step.
3. Right-click the search template, and select Edit Definition.

4. Modify the search values. See Enter values for an advanced search, page 63.

5

Click Search.
Tip: To stop the search, , in the result page, click Stop .

From the search results page, click Save template B
Type a name for the search template.

To allow other users to access this search, select Make this search available to others

. ® N

To allow users to change values for a property, use the arrow to move that property to the Input
fields box.

To keep a user from changing the value of a property, leave the property in the Fixed values box.
10. Click Save.
11. In the navigation pane, click Saved Searches.
12. Select the search template, and select File > Edit.
13. In the Name field, type a new name for the search template.

14. Edit the description of the template. By default, this field is updated with the search terms but
you can modify it. The description is visible as a column in the Saved Searches node.

15. Click Save.

Note: Unlike saved searches, when you save a template after a modification, the old version is not
overwritten: a new template is created.
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Copy a search template

To copy a search template:

1.

2
3
4.
5

In the navigation pane, click Saved Searches.

If necessary, click the Search templates link in the content pane. Otherwise, skip this step.
Select the search template, and select File > Edit.

In the Name field, type a new name for the search template.

Edit the description of the template. By default, this field is updated with the search terms but
you can modify it. The description is visible as a column in the Saved Searches node.

Click Save.

Set search preferences

To set your search preferences:

1.
2.
3.

Select Tools > Preferences.
Select the Search tab.

In the Default Search Locations area, do one of these:

¢ To set your default search locations to the repositories in your default repositories list, select
My Favorite Repositories.

¢ To set your default search location to the repository you are currently viewing, select Current
repository only.

¢ To set your default search locations to other locations, select Others, and then Select. In
Available Repositories or Available Sources, navigate to, and select a specific location, and
then click the appropriate arrow to add the location. Add as many locations as appropriate.
The location can be a repository, a cabinet or a folder. Available Sources is displayed only if
Webtop is configured to search external sources.

In the Smart Navigation area, select whether to enable the grouping of search results in clusters
according to a specific properties.

If you select Enabled, select the properties used for smart navigation by clicking Edit, and then
selecting properties in the drop-down lists. To add or remove properties, use the appropriate
buttons.

To save your changes, click OK.
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To select the columns displayed in the result pages, set your column preferences as described in
Select the columns that appear in lists, page 20.

To retrieve the default configuration of the search locations, and of smart navigation, click Restore
defaults.
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InboXx

Inbox overview

Your Inbox contains tasks, and notifications. Tasks are electronic assignments. Notifications are
messages that an event has occurred.

A task can be assigned to you manually by another user or automatically by a business process known
as a workflow. A workflow is a series of tasks assigned sequentially from user to user. When you
complete a workflow task, the workflow automatically sends a task to the next user in the workflow.

In some cases, a task that appears in your Inbox might be assigned not only to you but also to other
users. In such a case, the first user to accept the task becomes the one who performs it. The task is
automatically removed from the other users” inboxes.

If your organization uses work queues, you can request task assignments, as described in Work
queue tasks, page 84.

A task can include attached files that you are asked to edit or review. Attached files continue to the
next user in the workflow.

Open a task or notification

To open a task or notification:
1. Click Inbox.
2. Click the name of the task or notification.

3. Do one of these:

e To close the task or notification, click Close.
* To perform an action, see the appropriate procedure:
— Perform a task, page 80
— Complete a task, page 81
— Accept a task that has been assigned to multiple users, page 81
— Reject a task, page 82
— Delegate a task, page 82
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— Repeat a task, page 83

— Select a task from the queue, page 85

Perform a task

To perform a task:

1.
2.

80

In your Inbox, open the task by clicking its name.

On the Info tab, do these:

a.

d.

The Info tab might display a form customized to a particular task in your organization. If so,
enter the appropriate information. Ask your administrator for details.

If the Info tab includes a link for creating a new form for the next user in the task, click the
link, and follow the instructions on the screen.

To perform operations on attached files, use the standard procedures for those operations.

To attach additional files, click Add Attachments, select the files, and click OK. For detailed
steps see Locate an item in a selection dialog box, page 21.

If the Time, and Cost fields appear, record your time, and cost to perform the task.

In the Comments tab, add comments as follows:

d.

e.

Click Add or Edit.
In the Comment field, type a comment.

If these options appear, select one:

e For subsequent recipients

Sends the comment to all users performing all future tasks in the workflow.
¢ For next recipients only

Sends the comment only to the users performing the next task in the workflow.
Click OK.

Repeat these steps for as many comments as needed. To remove a comment, click Remove.

Select the Progress tab to view task’s history.

Do one of these:

To mark the task as finished, see Complete a task, page 81.
To close the task without marking it as finished, click Close.

The task closes. You can reopen it to mark it as finished at a later time. When you are ready
to mark the task as finished, see Complete a task, page 81.
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Complete a task

Completing a task sends it to the next user or activity in the workflow. Any changes you make to
attached files travel with the task if the version of the attached files, and the checked in files are
the same version.

To complete a task:

1. Open the task by selecting it in your Inbox.

2. Click Finish.The task is deleted from the Inbox and the Finish page is displayed.

3. Select the Do not show this confirmation again checkbox if you do not want to see the Finish
page after completing a task, and click OK.

Note: You can also configure webcomponent/app.xml to disable the appearance of the Finish
page for all users of the Webtop instance. Set the <suppress_task_confirmation> element to true
in webcomponent/app.xml:

<suppress_task confirmation>true</suppress task confirmation>
4. If prompted for a password, type your password.
5. Click OK.
6. If prompted to select the next performers, do these:

a. Click Click To Assign next to the task for which to select performers.

b. In the selection dialog box, select one or more performers, and click OK. For detailed steps
see Locate an item in a selection dialog box, page 21.

c. Click OK.
7. 1f prompted, select the next task to forward from the Select Next Forward Tasks list.
8. Click OK.

Accept a task that has been assigned to
multiple users

When a task has been sent to a group, the first user to accept the task is the one who performs it. If
you accept such a task, it is automatically deleted from the other users” inboxes.

To accept a task that has been assigned to multiple users:
1. Click Inbox.

2. Select the task to accept.

3. Click Accept.
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4. Do one of these:
e To close the task, click Close.

¢ To perform an action, see the appropriate procedure:
— Perform a task, page 80
— Complete a task, page 81
— Reject a task, page 82
— Delegate a task, page 82
— Repeat a task, page 83

Reject a task

If the workflow allows, you can reject a task. When you do, the task goes to another step as defined in
the template. If the task is directed to a group of users, it is deleted from your Inbox. Depending on
the template definition, the task may or may not remain in the Inboxes of the other users in the group.
To reject a task:

In your Inbox, open the task by clicking its name.

Click Reject.

If required, type a message explaining the reason for the rejection.

Click Next.

To select other tasks to reject, do so from the Select Next Reject Tasks list.

If required, type your password in the Sign Off Required field to electronically sign off the task.
Click OK.
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Delegate a task

If the workflow allows, you can give another user the responsibility of performing a task that
originally had been assigned to you.
To delegate a task:
1. In your Inbox, open the task by clicking it.
2. Click Delegate.
3. 1If prompted to specify the user to whom to delegate the task, do these:
a. On the task’s line item, click click to assign.

b. In the selection dialog box, select the user to whom to delegate, and click OK. For detailed
steps see Locate an item in a selection dialog box, page 21.

4. Click OK.
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Repeat a task

If the workflow allows, you have the option of asking another user or group to repeat a task that you
have just completed.

To repeat a task:

1. In your Inbox, open the task by clicking it.

2. Click Repeat.

3. On the task’s line item, click click to assign.

4

In the selection dialog box, select the user to whom to delegate, and click OK. For detailed steps
see Locate an item in a selection dialog box, page 21.

5. Click OK.

Change your availability for tasks

The top of your Inbox displays your availability to receive tasks. You can either set the status as I am
available or I am currently set to unavailable. To delegate tasks to another person, when your status
is set to unavailable, ensure to select the checkbox Delegate the activity’s work to someone else in
the Performer tab of the Activity Inspector dialog in Process Builder.

Note: When you select this option, you must also specify where the task is sent if the delegation to the
user to whom the performer selects also fails. The task can be forwarded to the workflow supervisor
or returned to the original performer if auto-delegation fails.

To set your status to Unavailable:

1. Click Inbox.

2. Click I am available.
The Workflow Availability dialog box is displayed.

Select the I am currently unavailable option.

Click edit.

Select the user or a group to whom the tasks will be assigned.
Click OK.

Click OK to close the Workflow Availability dialog box.

N o ok ®

Note: When you make yourself unavailable, this only affects future tasks that have been marked
as delegable. This option does not affect tasks that are currently in your Inbox or any future tasks
that do not allow delegation.

To set your status to Available:
1. Click Inbox.

2. Click I am currently set to unavailable.
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The Workflow Availability dialog box is displayed.
3. Clear the selection of the I am currently unavailable option.

4. Click OK.

Work queue tasks

Work queues hold tasks that are to be performed by available processors who are assigned to the
queue. When a task enters the system, the server assigns it to a work queue based upon the task,
and the work queue properties. Processors assigned to work on that queue receive tasks in their
Inboxes in priority order. Users with the "advance queue processor" role can selectively pull items
from their queue regardless of their priority, and without waiting for the item to be assigned to
the processor’s Inbox.

Manage tasks in your queue Inbox

Work queue processors have different options available to help manage tasks, and the workload
in their work queue Inbox.
To suspend a task in your queue:

If you are working on task, and need to wait for some other supporting document or task to take
place, you can suspend the task. As a reminder, you assign a date for the task to be unsuspended, and
active back in your queue. The system runs a job that unsuspends the task based on this date. You
can also manually unsuspend a task.

1. Select the task to suspend

2. Select Tools > Work Queue Management > Suspend

3. Select the date, and time that the task will no longer be suspended.
4

Click OK.
The status of the task appears as paused.

To unsuspend a task in your queue:
1. Select the task to unsuspend

2. Select Tools > Work Queue Management > Unsuspend.

The status of the task appears as acquired.

To unassign and reassign a task in your queue:
1. Select the task to unassign.

2. Select Tools > Work Queue Management > Unassign.

The system returns the task to the work queue, and the status of the task appears as dormant
until you reassign the task to another user.

3. Select Tools > Work Queue Management > Reassign.
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4. Select a user to assign to the task.

5. Click OK.

Get the next available task in a work queue

If your organization has implemented work queues, you can acquire the next task in the queue
without having to wait for a supervisor or the system to assign it to you. Your next task is the task of
the highest priority from among your assigned work queues. You can select your next task manually
from an option in the Inbox menu or you can choose to have your next task appear in your Inbox
automatically when you reject or complete your current task.

Items that are automatically sent to your Inbox by the system appear as not assigned in the assigned
column of the worklist. Items that have been manually assigned by the queue manager show yes

in the assigned column. Use the label in this column to distinguish how the task has been sent to
your Inbox.

To manually retrieve your next work queue task:

1. In your Inbox, select Tools > Work Queue Management > Get Next Task.
The next task appears at the top of the task list in your Inbox.

To turn on automatic receipt of work queue tasks:

1. In your Inbox, select Get next task automatically.

To turn off automatic receipt of work queue tasks:
1. Close any open work queue tasks.
2. Inyour Inbox, clear Get next task automatically.

3. Re-open your currently assigned task, and finish it, so that you do not have an unfinished task
in your Inbox .

Select a task from the queue

Processors with the queue_advance_processor role have the ability to view the work queue tasks that
they are eligible to work on, and acquire them regardless of their priority. They also have access to the
Work Queue node in the main directory tree that shows all of their assigned work queues displayed
as separate Inboxes. From these Work Queue Inboxes, they can select any unassigned tasks that they
are eligible to work on based on their skill set or any unassigned tasks that do not require any skills.

Processors with the queue_advance_processor role have the option to filter the Work Queue Inbox
view. Selecting All Eligible Tasks shows all unassigned tasks that the processor is qualified or
eligible to work on. All Tasks shows the tasks that the processor is eligible to work on, as well as any
tasks that the processor has already acquired or that have been assigned by the queue supervisor.

Users with the queue_advance_processor role cannot assign tasks to other queue processors or pull a
task that is already assigned to or has been pulled by another queue processor.
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To acquire an unassigned task:

1. Navigate to the Work Queues node in the directory tree, and click the work queue to open.
2. Select the filter to show All Eligible Tasks or All Tasks in the Work Queue Inbox.

3. Select one or more tasks to acquire.
4

Select Tools > Work Queue Management > Get Task.

The system assigns the tasks to you, and sends them to your Inbox. If you select only one task,
the system opens the task in Task Manager so that you can work on it immediately.

Tip: This action is also available through the Task Manager using the Get Task button that

is available to advance queue processors. This option enables advance queue processors to
examine the task before deciding to pull it. Using the Get Task button from within the task in
Task Manager assigns the task to you, and refreshes the page, enabling you to work on the
task immediately.
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Workflows and Quickflows

Start a workflow

A workflow is an automated process that passes files, and instructions between individuals in
sequence, to accomplish specific tasks. When a user is assigned a workflow task, the task appears in
the user’s Inbox.

Workflows can include automatic tasks that the system performs, such as the execution of scripts.
Automatic tasks allow the integration of workflows, and lifecycles for example allowing promotion of
files to new lifecycle states.

When you start a workflow, you select the workflow template that includes the sequence of tasks to
be performed. Multiple workflows can start simultaneously from the same template. A workflow
template might allow you to direct a task to a group of users, in which case the first user who accepts
the task performs it, and the task is removed from the other users’ Inboxes.

When you start a workflow, you can attach files. File are available for attaching if they are already
attached elsewhere, locked by another user, or in an advanced lifecycle state. Remember that when
you attach files in multiple languages, a task recipient’s filters might show only the files that match
that user’s language.

To start a workflow:

1. Do one of these:

e To start a workflow by first selecting the type of workflow, select Tools > Workflow > Start.

e If your workflow is designed to include multiple packages, select Tools > Workflow > Start
Attachments and choose one document for each package.

2. Select the workflow template, and click OK. For detailed steps see Locate an item in a selection
dialog box, page 21.

3. Click OK.
4. On the Info tab, in the Workflow Description field, type a name for the workflow.
5. To attach a file to the workflow, do these:

a. On the Info tab, click Add.

b. To locate the files to attach, click the appropriate tab, then navigate to the files within that tab.
Tabs that correspond to repository nodes are navigated in the same way as the repository
nodes.

c. Click Add at the bottom of the page.

d. If you attached a file that has links to other files, you can add the linked files by selecting
Automatically Add Linked Objects.

e. Toremove an attached file, click either Delete or Remove.
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10.

To create, and attach a new form based on an existing form template, do these:
a. On the Info tab, click the name of the form or package, depending on what appears.

b. Select the form template upon which to base the new form, and click OK.

The form’s fields appear in the Info tab.

c. To remove a form, click Remove.

If you remove a newly created form or cancel the workflow, the form is deleted automatically.
If the workflow includes the Performers tab, you can specify users for one or more tasks. Do these:
a. Click Select next to a task that must be performed.

b. In the selection dialog box, select the user or group to perform the task, and click OK. For
detailed steps see Locate an item in a selection dialog box, page 21.

In the Comments tab, do these:
a. Click Add.
b. Type your comments.

c. Select the users to receive the comment:

* For subsequent recipients
The comment is sent to all remaining users in the workflow.
¢ For next recipients only

The comment is sent only to the users who receive the next task assignment in the
workflow.

Click OK.
Click Finish.

Send a quickflow

A quickflow is a single task you send to one or more users. If you send a quickflow to multiple users,
you can select whether each user receives the task simultaneously or sequentially.

To send a quickflow:

1.

88

Navigate to the file, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.
Select Tools > Workflow > Quickflow.

To select the users or groups to whom to send the quickflow, click Select user/group, then select
the users or groups, and then click OK. For detailed steps see Locate an item in a selection
dialog box, page 21.

In the Priority drop-down list, select the priority.
In the Instructions field, type any messages for the users.

Select the Return to Me option to receive a task when a user completes the review.
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7. To require each user to enter an electronic signoff when completing the review, select the Require
signoff checkbox.

8. Click OK.

View workflows

You can view workflows through either Workflow Reporting or through My Workflows. This topic
describes both.
To view workflows through Workflow Reporting

1. Select Tools > Workflow > Workflow Reporting.

The list of workflows appears. To reformat the list, click Edit Workflow Report, and choose
from the available options.

2. To view more information about a workflow, select the workflow, and then select any of these:

¢ To view the workflow template, select Tools > Workflow > View Details > Map.

* To view the progress of the workflow, select Tools > Workflow > View Details > Summary. To
narrow or broaden the list, select the appropriate filter at the top of the page.

e To view a record of events for the workflow, select Tools > Workflow > View Details > Audit.

To view the workflows you own via My Workflows
1. Select Tools > Workflow > My Workflows.

My Workflows displays the workflows you own but does not display the workflows owned
by groups you belong to. To view workflows owned by a group, use the procedure To view
workflows through Workflow Reporting, page 89.

2. To view a specific workflow, select the workflow, then select File > View.

Pause a workflow

When you pause a workflow, you temporarily stop it but expect to reinstate it at a later time. For
example, you can pause a workflow to modify the workflow template. Once your changes are
complete, you can resume the workflow to continue from the point at which it was paused.

To pause a workflow:

1. Select Tools > Workflow > Workflow Reporting
Tip: Alternately, you can select Tools > Workflow > My Workflows.

2. Select one or more workflows.
3. Select Tools > Workflow > Pause Workflow.

4. If prompted to confirm the pause, click OK.
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Resume a paused workflow

When you resume a paused workflow, the workflow starts where it was paused. You can resume a
paused workflow, but you cannot resume a stopped workflow.
To resume a paused workflow:

1. Select Tools > Workflow > Workflow Reporting
Tip: Alternately, you can select Tools > Workflow > My Workflows.

2. Select one or more workflows.
3. Select Tools > Workflow > Resume Workflow.

4. If prompted to confirm, click OK.

Stop a workflow

You can stop a workflow at any point in its progress. A stopped workflow cannot be restarted.

To stop a workflow:

1. Select Tools > Workflow > Workflow Reporting
Tip: Alternately, you can select Tools > Workflow > My Workflows.

2. Select one or more workflows.
3. Select Tools > Workflow > Stop Workflow.

4. To ensure that the workflow is automatically deleted from your workflows list, select the Aborted
workflow will be deleted option.

5. If prompted to confirm, click OK.

Email the workflow supervisor or a workflow
performer

To email the workflow supervisor or a workflow performer:

1. Select Tools > Workflow > Workflow Reporting
Tip: Alternately, you can select Tools > Workflow > My Workflows.

2. Select the workflow.

3. Select one of these:

¢ Tools > Workflow > Email Supervisor
¢ Tools > Workflow > Email Performers
Your email application opens a new email message with the email addresses filled in.

4. Type your message, and send the email.
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Process a failed task in a workflow

If you are workflow supervisor, and receive notice that an automatic task has failed, you can perform
one of the procedures here.

To retry a failed automatic task:

1. From your Inbox, open the failed automatic task.
2. Click Rerun.

3. Click OK.

To complete a failed automatic task:

1. From your Inbox, open the failed automatic task.
2. Click Complete.
3. Click OK.

Change the workflow supervisor

Each workflow has a workflow supervisor who can modify, pause, or stop an active workflow.

To change the workflow supervisor:

1. Select Tools > Workflow > Workflow Reporting.
Select the workflow.
Select Change Supervisor.

2
3
4. Select either All Users or the group to which the new supervisor belongs.
5. Select the user who will be the new supervisor for the workflow.

6

Click OK.

Save workflow information as a Microsoft Excel
spreadsheet

The availability of this procedure depends on your organization’s configuration of Webtop.

To save workflow information as a Microsoft Excel spreadsheet:
1. Select Tools > Workflow > Workflow Reporting.

2. Click Save Report.

3. Type a name for the information you are saving.

4

Select a location to which to save.
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5. Click OK.

View aggregated report for workflow
performance

To view reports, you must have the process_report_admin role.

To view historical reports:

1. Select one of these:

¢ Tools > Workflow > Historical Report > Process

¢ Tools > Workflow > Historical Report > User

In the General tab, select the duration, and other parameters for which to run the report.
Click Run.

Click the Results tab, to view the report.

To view additional information, click a process, instance, or user.

AU S

To save the report so it can be rerun, click Save.

Create a workflow template

To create a new workflow template, select File > New > Workflow Template to open Workflow
Manager. Use that application’s Help for instructions on creating the new workflow template.
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Work Queues

Work queue roles

Work queues hold tasks that are to be performed by available users who are assigned to the queue.
Work queue users receive tasks in their Inboxes. Work queue users are assigned tasks either
automatically by the server or manually by another user. Users with the queue_advance_processor
role can choose to pull items from their queue regardless of their priority, and without waiting for
the item to be assigned to their Inbox.

Work queue users are also referred to as processors.

Work queue managers monitor work queues to see which queues have overdue tasks that need to be
addressed or which queues have too many tasks in the queue. They can also add, edit, and assign
skill profiles to individual work queue users.

Work queue administrators create work queues, assign users to work on queue tasks, define the skill
profiles that enable the application to assign tasks to the appropriate processor, and can add, edit, or
assign skill profiles to the individual work queue users.

Additionally, the administrator or manager can use the Work Queue Monitor to view the tasks in
the queue, the name of the processor assigned to the task, the status of the task, when the task was
received, and the current priority of the task.

To access work queues, you must belong to one of the roles described in Table 11, page 93.

Table 11. User roles for work queues

Role What this role can do

Queue_processor Works on items that are assigned by the system
from one or more work queue inboxes. Queue
processors can request work, suspend, and
unsuspend work, complete work, and reassign
their work to others.

Users with the queue_processor role do not
select the tasks that they work on.

Queue_advance_processor Works on items that are assigned by the
system from one or more work queue inboxes.
Additionally, selects tasks to work on from one
or more work queue inboxes.
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Role What this role can do

Queue_manager Monitors work queues, assigns roles to queues,
and assigns users to work on queue items.
Queue managers can reassign, and suspend
tasks.

Queue managers who have CREATE_GROUP
privileges can create work queues.

Queue_admin Creates work queues, and queue policies.
Members of the queue_admin role do not by
default have the administrator role.

Queue administrators who have
CREATE_GROUP privileges can create
work queues.

Process_report_admin Runs historical workflow reports from the
Workflow menu.

Setting up queue management

The system administrator must configure the global registry, repository, and application server
correctly to use queue management.

Queue management requires the following environment:

¢ Content Server 6.0 or later, and a repository designated as a global registry.
* Content Server 6.0 or later, and a repository that is designated to run queue management.

e DFC 6.0 or later on the application server host where Webtop is deployed with connection
information for the global registry repository.

*  Webtop 6.0 or later.
¢ BPM.dar and Form.dar 6.0/6.0 SP1 or Process Engine 6.5 or later.

A single repository can run queue management and be designated as a global registry. However,
this configuration is not mandatory. Alternatively, two separate repositories can also run queue
management and be designated as global registries. Ensure that Process Engine is installed in the
repository running queue management and in the repository designated as a global registry.

To install queue management:

1. Designate a repository as a business objects framework global registry.

Note: Ensure that the repository is designated while creating a repository or upgrading an
existing repository. For instructions about configuring the repository, see the Content Server
Installation Guide.

2. Record the repository login credentials for the global registry user.

3. When DEC is installed as part of the Webtop deployment process, provide the login credentials
for the global registry user in the dfc.properties file.
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4. Install BPM.dar and Form.dar 6.0/6.0 SP1 or Process Engine 6.5 or later in the global registry
repository.

The SBOs and TBOs required for queue management are installed.

Set up a new work queue

To set up your first work queue, you perform these procedures in the order listed here:
* Create the users, and groups that you will be using to process the work queues.

The chapter on user management provides more details on setting up users, and groups.
¢ Set up work assignment matching.

Set up work assignment matching, page 95 provides detailed information on work assignment
matching.

* Create the queue policies you will need for the queue.
Work queue policies, page 98 provides more specifics on queue policies.
* Create the queue categories.
Define a queue category, page 101 explains how to create queue categories.
* Create the work queue.
Define a work queue, page 101 provides more specifics on defining work queues.
¢ Create override policies.

Define work queue override policies, page 103 explains the optional step of defining override
policies for work queue policies.

* Create the process templates used for the work queue in Process Builder.

When a work queue is the performer for a task, the check box to delegate the activity’s work to
someone else must be selected in the activity definition.

Procedures to define process templates are found in the Documentum Process Builder User Guide.

Set up work assignment matching

When you are creating a work queue, your first task is to configure the work assignment matching
filters by defining the skills or properties that are necessary to process tasks in the work queue. The
work assignment matching filter lists the abilities, properties, or expertise necessary to perform tasks
in a work queue. The processor profile lists which of these filters has been assigned to a work queue
processor. When the processor pulls the next task or when a manager assigns a task, the system then
uses the skills defined in the work assignment matching filter to qualify a processor based upon the
skills or properties required to work on a task.

If a work assignment matching filter is not set up for a work queue, than any queue processor in the
work queue can work on the tasks regardless of qualifications.
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When a workflow process runs, and the system creates a new item for a work queue, it checks the
work queue skills that are defined in the task based on the activity mapping rules set up in the activity
template in Process Builder. (Once that task is created, there is no way to change the associated
required skills.) The system compares the skills required by the task against the skills listed for users
in the work queue, and uses this comparison for both the Get Next Task and Assign Task functions.

For example, the work queue loan_underwriter_queue has three required skills defined for it:
auto loans, commercial loans, and home loans. When an auto loan application comes through the
workflow, the system evaluates the skill association stored in the activity template, and resolves
the skill value for an auto loan. It then sends the loan application to the loan_underwriter_queue.
When a supervisor assigns a task or when a processor tries to pull the task, the server ensures that
this processor has auto loans listed as a skill before allowing the processor to acquire the task. A
particular task associated with a queue can require one or more skills to complete. A processor
may have several skills related to a work queue.

Set up skill profiles in the process template

When you create an activity that is performed by a specific work queue, you select the work queue
name, and set the required skills for the activity on the Performer tab in the Activity Inspector. You
can use process data to map to the values of the required skill. When you map a skill, it is added to
the task, and at runtime the system uses it to qualify a processor for the task.

See Documentum Process Builder User Guide: Working with Activities.

Define work assignment matching filters

Each work assignment matching filter contains the skill definitions that enable the system to match a
processor with a task based on the skills required by the task, and the abilities or expertise of the
processor. When you create the filter, you define the possible skill values, display labels, data types,
and operators used by the system to compare the list of processor skills against the required job skills,
and assign the task to an appropriate processor.

The process template in Process Builder must have these skills defined for the task, as well.

Users with the queue_admin role can create, delete, or modify queue matching filters. Users with the
queue_manager role can view the settings of the matching filters only.

To define work assignment matching filters:

1. Navigate to Administration > Work Queue Management > Work Assignment Matching >
Matching Filters.

2. Do one of these:

e To create a new filter, select File > New > Work Queue Skill Info.

¢ To edit an existing filter, select the filter, and from the right-click menu, select Properties or
select the filter, and then select View > Properties > Info

3. Type a name for the filter.
4. Type a description for the filter.
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5. Select the data type of the available skill values from the Data Type list box.
Valid values are Integer, String, and Double.

The value you select here determines the type of comparator that is available in the Comparison
Operator list box.

6. Select a comparison operator from the list box.

7. Typein a Value to be used in the comparison, and a display label based on the data type you
selected.

For example, to match work based on processing a conventional loan, type conv in the string
column to represent a conventional loan, and type conventional loan as the display label.

8. Click Insert to add more rows to the table, as necessary to define the varying types of work
matching comparison values.

9. Select Processors can have more than one skill for this filter to allow a processor to have more
than one skill associated with this filter.

For example, a processor could have skills for processing both real estate loans, and automobile
loans.

10. Click OK.

Add work assignment matching filters to a work queue

Add work assignment matching filters to a work queue to define the skill set for the queue, and for its
users. All users in the work queue must have their skills updated each time a new filter is added to
the queue. After you add the work assignment matching filter, the system prompts you to define the
related skills for each processor in the queue.

When a skill is removed from the work queue, the system checks for the skill in existing tasks for this
work queue, and removes them immediately.
To assign work assignment matching filters to a work queue:

1. Navigate to Administration > Work Queue Management > Work Queues , and select a work
queue.

2. Right-click the queue, and select Properties or select View > Properties > Info to display the
Work Queue Properties page.

Under Work Assignment Matching Filters, click Add.
Select the skills you are adding to work queue.
Click the add arrow to move the skills to the content selection area of the page.

Click OK.

The system prompts you to select the skills for each individual user in the queue.

SRR S

7. Select the skills for each user, and click Next.

Note that skill profiles are not available for groups.

8.  When you have selected the skills for each user, click Finish.

EMC Documentum Webtop Version 6.8 User Guide 97



Work Queues

To remove work assignment matching filters from a work queue:
1. Navigate to the work queue, and select it.
2. Select View > Properties > Info.

3. In the Work Assignment Matching Filters table, select the filter that is related to the skills to be
changed.

4. Click Remove.
5. Click OK.

When the system removes the matching filter from work queue, the corresponding skill values set up
for users in the work queue are not automatically removed. The skill properties for the user remain
until you remove them from the Processor Profile page for each processor.

Work queue policies

A work queue policy contains the logic that the system uses to track, and manage tasks in the work
queue. This logic enables the system to assign an initial priority, and age the priority of the task
based on different values you set up in the policy.

The queue policy contains settings for priorities, management settings, thresholds, and other
management functions. When new item comes in for workflow, the server identifies the activity as

a work queue item, checks the priority value in the policy, and assigns initial priority to the item.
After the task is in the queue, the aging job increases the priority incrementally based upon the policy
until the task is worked on.

You also set up threshold values to trigger notifications to the queue manager when high priority
items are not being processed or when a specific number of tasks are waiting in a work queue.

With a work queue policy, you can define settings that move an unworked task to a higher priority
level when the priority aging job runs.

You can also flag a percentage of tasks to be routed for quality checks.

Priorities of tasks

For most work queue users, work items appear in the Inbox based on their priority —the highest
priority items are assigned to be worked on before lower priority work items. Priority, and aging
settings are essential elements in the processing of work queue tasks. When the system creates a
new work item, the server identifies the task as a work queue item, and checks for logic to enable

it to assign an initial priority to the item. After the task is in the queue, an aging job increases the
priority of the task based upon other logic, which moves the task higher in the Inbox until the task is
worked on. Priority escalation may trigger the queue administrator to redistribute tasks or reallocate
resources between work queues.

The priority level at which a task first appears, and the speed at which it increases in priority can be
set either in the work queue policy or in the activity template for the task. For example, you set the
initial priority for new tasks in a queue to 1, which means that all new tasks begin with a priority of
1. If you have set the Increment Priority to 10, then whenever the dm_QmPriorityAging job runs,
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the priority increases by a factor of ten, if the task has not been worked on. In this example, the task
has remained in the queue, and the dm_QmPriorityAging job has run three times, increasing the
priority to 31. The maximum priority field is set to 30, so the system sends a notification to the queue
managers group, warning that the task has surpassed its maximum priority, and needs attending to.

Using a work queue policy, the queue administrator or queue manager can specify the initial priority
of the task, and the frequency, and percentage at which it increments based on different values you
set up in the policy. For more complex initialization, and aging scenarios, you use Documentum
Application Builder to create a priority module that contains logic to dynamically calculate, and update
the priority based on process data or other properties belonging to the process. A priority module can
be associated with a work queue policy or a Process Builder activity template.

Set dynamic priority and aging logic for tasks

There may be situations where both the initial priority, and the amount that priority increments need
to be calculated dynamically. In these cases, you create a priority module that the system uses instead
of the work queue policy to set priority, and aging logic. A priority module can be selected when
creating the work queue policy. The Documentum Process Builder User Guide provides information on
creating a priority module.

Process data can be used to set the initial priority, and increase the priority based on values in the
workflow. For example, if a loan application belonging to a preferred customer comes through a
work queue, it can be immediately placed at a higher priority value than a loan application from other
customers. In addition, if the loan request is for a greater amount or comes from a preferred loan
broker, then the priority can be increased at a higher rate, ensuring that the queue supervisor is alerted
if the task is not completed within a specified period of time. This kind of logic can be especially useful
to increase the priority of a task as it nears a deadline or some other time restriction—the priority is
increased more rapidly as the deadline approaches, pushing the task up the queue at a higher rate.

Create or modify a queue policy

Each work queue can have one policy. If you associated an override policy with a document being
routed in the workflow, the system uses the override policy rather than the work queue policy for
that item.

Users with the queue_admin role can create or modify queue policies.

To create or modify a work queue policy:
1. Navigate to Administration > Work Queue Management > Policies > Work Queue Policies.
2. Navigate to the category where you want to either locate a new policy or edit an existing one.

3. Do one of these:

e To create a new policy, select File > New > Work Queue Policy.

¢ To edit an existing policy, select the policy, and then select View > Properties > Info.
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You may edit the properties of a policy, but the policy name remains a read-only field. To
rename the policy, you must delete the existing policy, and recreate the same policy with
the new name.

Type a name for the policy.

Define these settings:

Threshold

The number of unfinished tasks in the queue at which notifications are sent to the queue
manager warning that the number of tasks in the queue is high. Notifications are triggered
when the server runs the dm_QmThresholdNotification job.

The queue managers group is specified in the queue definition, and defines who receives
the notifications.

Max Priority

When a task in the work queue reaches this level, notifications are sent to the queue managers
group warning that there is an important task not being processed. Notifications are triggered
when the server runs the dm_QmPriorityNotification job.

Initial Priority

The level of importance that is assigned to a newly created task when the work queue uses
this policy. When a task remains in the queue without being worked on, the system adds
the number specified in the Increment Priority field to this initial number each time the
dm_QmPriorityAging job runs.

Increment Priority

The value by which the system increments the priority level of tasks that are still in the queue
each time the system runs the dm_QmPriorityAging job. It is added to the initial priority
each time that the aging job runs.

Calculate priorities dynamically

To use a priority module to set the initial priority, and increase its priority when the aging
job runs, select the checkbox, and choose a priority module from the list-box. Set dynamic
priority and aging logic for tasks, page 99 provides more information on priority modules.

Percent Quality Check

The percent used to randomly decide if the work item must be routed to another processor
for a quality assurance check. The Queue Task Rework Decision in Process Builder uses the
percent quality check setting to determine if the work item is routed for quality check.

Click OK.

To delete a work queue policy:

1.
2.

100

Select the queue policy to delete.

Select File > Delete.

If the policy is in use, and is referenced by other work queues or work items, the system will
not delete the work queue policy.

Click OK.
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Define a queue category

Queue categories are like folders in which you organize your work queues. Categories can be
designed to resemble your business model’s hierarchy enabling you to drill though different
categories to locate your work queue in a logical representation of your organization. Work queue
categories must be created before creating the related work queues.

Users with the queue_admin or queue_manager role can create, and edit categories.

To create a queue category:
Navigate to Administration > Work Queue Management > Work Queues.
To nest the new category within an existing category, navigate to that existing category.
Select File > New > Work Queue Category.

1

2

3

4. Type the name of the new category.

5. If appropriate, type a description of the new category.
6

Click OK.

To delete a queue category:

1. Navigate to Administration > Work Queue Management > Work Queues.
2. Select the queue category to delete.

3. Select File > Delete.

The system warns you that this operation cannot be undone.

If the category is in use, and is referenced by other work queues, the system will not delete
the work queue category.

4. Click OK.

Define a work queue

Work queues are organized, and listed under work queue categories. Before creating a work queue,
you should first create a queue category, and queue policy. Define a queue category, page 101, and
Work queue policies, page 98 provide more specifics on these topics.

Users with the queue_manager role, and with CREATE_GROUP privileges can create work queues.

To create a work queue:
1. Navigate to Administration > Work Queue Management > Work Queues.

2. Navigate to the work queue category where you want the new work queue to be located.

3. Select File > New > Work Queue.
The system displays the Work Queue Properties page.

4. Type the name of the new work queue using lowercase letters. Do not use quotation marks
in the work queue name.
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5. Type a description of the new work queue, if necessary.

6. By default, you are assigned as the queue manager. To change the queue manager, click Edit
next to Queue manager, select a different user, and click OK.

7. Select a policy name to apply to the queue.

The settings for the queue policy appear as read-only fields on the page, except for the policy
manager name.

8. To change the name of the policy manager, click Edit.
The name of the policy manager appears by default.

9. In the Work Assignment Matching Filters area, click Add to select skills that are required for the
work queue. The system uses these skills to filter, and assign tasks to the queue.

The system displays a page where you can select specific skills to apply to the work queue.

10. Select the skills you are adding to work queue. Click the add arrow to move the skills to the
content selection area of the page.

11. Click OK.
12. Assign users to the queue by clicking Add in the Assigned Processors table.

13. Select the users you are adding to work queue. Click the add arrow to move the users
to the content selection area of the page. Only users with roles queue_processor, and
queue_advance_processor appear in the list of available users. The chapter on user management
provides more details on setting up users, and groups.

14. Click OK.

The system prompts you to select the skills that it uses in matching work assignments to the
individual users.

15. Select the appropriate skills for each user, clicking Next after you have set up each user’s
matching skills

16. When you have selected the skills for each user, click Finish.

The system will not allow you to save the page until all assigned users have their skills selected.

By default, the new work queue is placed in the current category.

To move a work queue to another category:

1. Select the work queue.

2. Select Edit > Add to Clipboard.

3. Navigate to the category you want the work queue to move to.
4

Select Edit > Move

To delete a work queue:

1. Navigate to Administration > Work Queue Management > Work Queues.
2. Navigate through the categories to select the work queue to delete.

3. Select the work queue.

4. Select File > Delete.
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The system warns you that this operation cannot be undone.

If the work queue is in use, and is referenced by other work items, the system will not delete
the work queue.

5. Click OK to delete the work queue.

Deleting a work queue does not delete the category it was related to.

Define work queue override policies

A work queue override policy allows the priority, and aging of a task to be controlled based on the
document properties, and lifecycle. Override policies can be used when different document types
with different processing needs are routed through the workflow. For example, applications for
different types of loan products might have different priorities, and different aging requirements.

To use override policies, when you apply a lifecycle to the document, you define the alias set
%wq_doc_profile to the override policy that you want the system to apply to the document. If there is
no override policy associated with the document, the system uses the policy associated with the work
queue to set the properties of the work item.

Users with the queue_admin role can create or modify queue override policies.

To create or modify a work queue override policy:
1. Navigate to Administration > Work Queue Management > Policies > Override Policies.

2. Do one of these:

* To create a new override policy, select File > New > Work Queue Override Policy.

¢ To edit an existing override policy, select the override policy, and then select View > Properties
> Info.

3. If creating a new policy, type a name for the override policy.

Once the override policy has been saved, the name field becomes read-only.

4. Click Add to view the Work Queue Policy Assignment page, where you can select a work queue,
and policy.

Select the queue, and policy names to use as your override policies.
Click OK.
To remove a work queue override policy, select it, and click Remove.

Click OK.

® N o @

Manage work queue users

Work queue users can be managed from within the work queue itself or from Work Queue Monitor.
When you view the list of work queues within a category, clicking on the number of active users
shows you the list of users, and groups that are members of the queue. You can also view the
availability of the member, and if there is a delegated user for that member.
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Add a user or group to a work queue

If a work queue is acquiring too many tasks, and the processing rate is too slow to meet your business
needs, you can add more users to a queue.

Users with the queue_admin or queue_manager role can assign users, and groups to queues.

To add a user or group to a work queue:

1. Click the Work Queue Monitor node or select Work Queue Management > Work Queues.
2. Navigate to the active work queue.

3. Click the queue’s number users link in the Active Users column.

4. Select File > Add Member.
5

Select the user or group, and click the arrow. Users must be assigned to the role queue_processor
or queue_advance_processor to appear in this list.

Click OK

*

7. Select skills for the processor that are used in work assignment matching.

8. Click OK.

Remove a user or group from a work queue

Users with the queue_admin or queue_manager can remove a user or group from a work queue.

To delete a user or group from a work queue:

Click Work Queue Monitor or select to Work Queue Management > Work Queues.
Navigate to the active work queue.

Click the queue’s number users link in the Active Users column.

Select the user or group to delete from the work queue.

Select File > Remove Member.

Click Continue.

Click OK.

If you delete a user from the queue after they have acquired a task, it remains in the user’s Inbox
until they have completed the task.

N S @k D=

Add skills to work assignment processor profiles

A processor profile can include many different skills based upon the abilities, properties, or expertise
of the processor. The system uses these skill profiles to match a processor to a task based on the
skills or properties required to work on the task.
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The queue manager, and the queue administrator assign, edit, or remove skill profiles related to work
queue users, and can add or remove work queues for a processor using the processor profile.

Skills can also be added to a processor profile when a work assignment matching filter is added to
an existing queue. After adding the filter, and related skills to the work queue, the system displays
each processor profile, enabling you to make the updates to the skill set. Skill profiles are not defined
for groups.

If a work queue does not have any associated skill requirements, the system will not prompt you to
assign skills to a processor.

To add skills to a processor profile:

1. You can add skills to a processor profile using any of these methods:
e Navigate to Administration > Work Queue Management > Work Assignment Matching
> Processor Profile.

* Or navigate to Administration > Work Queue Management > Work Queues, select a work
queue, and click the queue’s number users link in the Active Users column.

* Or from Work Queue Monitor, select a work queue, and click the queue’s number users link in
the Active Users column. Select the user’s profile by selecting Properties from the right-click
menu or by selecting View > Properties > Info

The Processor Profile search screen appears enabling you to see a list of all users or to search for a
specific user by name or by group.

2. Access the processor to whom you are adding skills in one of two ways:

Select Search in the list box, and type the user name, group, or user operating system name
to find the processor.

Or select Show All Users from the list box, and navigate to the processor name.

3. Select the user, and select eitherView > Properties > Info or select Properties from the right-click
menu.

The Processor Profile page appears.
4. Under Skills for Work Assignment Matching, click Add.

5. Select a filter from the list box.
Webtop displays the skills related to that filter.

6. Select the appropriate values for the processor.

7. Click OK.

To change skills for a processor:

1. Navigate to Administration > Work Queue Management > Work Assignment Matching >
Processor Profile.

The Processor Profile search screen appears enabling you to see a list of all users or to search for a
specific user by name or by group.

2. Select the user, and select View > Properties > Info.

3. In the Skills for Work Assignment Matching table, select the filter that is related to the skills
you want to change.
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5.

Click Edit.

You can add or change skills for the processor.

Click OK.

To delete skills for a processor:

1.

4.
5.

Navigate to Administration > Work Queue Management > Work Assignment Matching >
Processor Profile.

The Processor Profile search screen appears enabling you to see a list of all users or to search for a
specific user by name or by group.

Select the user, and select View > Properties > Info.

In the Skills for Work Assignment Matching table, select the filter that is related to the skills
you want to delete.

Click Delete.
Click OK.

If a work queue that a processor is assigned to requires a particular skill set, the system will not
delete the associated filter.

Update the processor profile in a work queue

The system uses the user profile to assign tasks to a processor based on skill levels necessary for the
task. You can update, add, or remove a skill for a user. You can also change work queue assignments
for the user by adding or removing a work queue from the list of assigned queues.

Users with the queue_admin or queue_manager can update a user profile.

To update a processor profile:

1.

2
3
4.
5

106

Click Work Queue Monitor or navigate to Work Queue Management > Work Queues.
Navigate to the active work queue.

Click the queue’s number users link in the Active Users column.

Select a user or group.

Select View > Properties > Info or select Properties from the right-click menu.

The Processor Profiles page shows a list of skills that the user has as well as a list of work queues
that the processor is assigned to.

To change the processor’s skill set, click Add in the Skills for Work Assignment Matching table.

The Processor Skill page appears with the user name, and a list box of filters associated with
the assigned work queues.

Select a work assignment matching filter from the list box.
Select the skills to associate with the processor.

Click OK.
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Monitor work queues

Although most functions of work queues can be managed from within their individual components,
you can use Work Queue Monitor as a dashboard to manage work queues from one location. Use
Work Queue Monitor to view the assignment status of each task, the actual task count, and the
policy task count, the priority of a task, and the highest priority of the policy, as well as how many
active users are assigned to each queue. If a task count or a task priority exceeds the level specified
in the policy, the system displays a caution icon in the row for that queue, and displays the item in
the column that exceeds the policy in bold font.

Using the controls at the top of the page, you can select different views in the monitor, depending on
your access, and privileges. You can also select which columns appear on the page, and in what order
they appear by clicking the column setting icon, and making your selections.

You can view all work queues in the system that you have access to by selecting All Work Queues
from the drop down list on the page. You can also filter to show only the work queues that you
manage by selecting My Work Queues. The Show Descendents option enables you to see all work
queues that are nested inside of the categories.

Use the My Categories link to configure which categories appear in drop-down box of the monitor
screen. Only categories that you manage are available for selection.

To select a work queue category to monitor:

1. Navigate to Work Queue Monitor.

2. Click My Categories.

3. Select the categories to monitor. Click the add arrow to move the categories to the content
selection area of the page.

4. Click OK.

To view the work queue task a single user or a group is working on:

Work queue managers, and administrators can view the inboxes of users or groups associated with
their work queues.

Users with the queue_admin or queue_manager role can perform this procedure.

1. Open Work Queue Monitor.

You can also navigate to Administration > Work Queue Management , and select a work queue.
2. Click the queue’s number users link in the Active Users column.
3. Select the user or group.

4. Select Tools > Work Queue Management > Workload.

The system displays that user’s Inbox, and the tasks it contains.

To monitor and update active work queues:

1. Do one of these:

® In the tree pane, click the Work Queue Monitor node.

e Select Tools > Work Queue Management > Work Queue Monitor.
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To view the tasks in the active queue, click either the queue name.

To view the users in the active queue, click the number users link (where number is the number
of users).

To update queues, see the appropriate procedure:

® Assign or reassign a work queue task to a specific user, page 108
® Unassign a work queue task from a user, page 109

* Move a work queue task to another work queue, page 109

* Suspend a work queue task, page 109

¢ Unsuspend a work queue task, page 110

® Add a user or group to a work queue, page 104

* Remove a user or group from a work queue, page 104

¢ Add skills to work assignment processor profiles , page 104

* Update the processor profile in a work queue, page 106

Assign or reassign a work queue task to a specific user

When a work queue task is assigned or reassigned, the system matches the new performer skill to
the task skill. If the new performer does not have the skills required by the task, the system will not
allow the reassignment to take place.

Users with the queue_admin or queue_manager role can assign a task in a work queue to a specific
user.

To assign a work queue task to a specific user:

1.

2
3.
4

108

Click Work Queue Monitor.
Navigate to the active work queue, and click its name.
Select one or more tasks.

Select one of these:

e If the selected tasks are not already assigned to a user, select Tools > Work Queue
Management > Assign

o If the selected tasks are already assigned to a user, select Tools > Work Queue Management >
Reassign

Tip: This action is also available through the Task Manager.
Select the user to whom to assign the tasks.

Click OK.
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Unassign a work queue task from a user

You can reassign a task that is already assigned to one processor, and reassign it to another processor
by unassigning the task from the user. Unassigning the task moves the task back to the queue where
you can assign the task to another work queue processor.

Users with the queue_admin or queue_manager role can unassign a work queue task from a user.

To unassign a work queue task from a user:

1. Click Work Queue Monitor.

2. Navigate to the active work queue, and click its name.

3. Select one or more tasks that have already been assigned to users.
4

Select Tools > Work Queue Management > Unassign.

Move a work queue task to another work queue

To balance the workload between work queues, you may want to move tasks from one queue

to another. When you move a task to another queue, the system compares the skills in the target
work queue to the skills required by the task. Tasks can move to another queue only if the target
work queue contains all of the required skills for that task. For example, if the task requires the
skill attributes of western region, and jumbo loan, it can be moved to a queue with western region,
southern region, and jumbo loan. It cannot be moved to a queue with only jumbo loan.

Users with the queue_admin or queue_manager role can move a task from one work queue to
another work queue.

If the task is already assigned to a user, you must first unassign the task, as described in Unassign a
work queue task from a user, page 109.

To move a task from one queue to another queue:

Click Work Queue Monitor.

Navigate to the active work queue, and click its name.

Select one or more tasks.

Select Tools > Work Queue Management > Move to Queue.

Select the work queue to which to reassign the tasks.

Click OK.

SN o A

Suspend a work queue task

Users with the queue_admin or queue_manager role can suspend a task, and specify how it should
remain suspended. the application will automatically resume the task when the amount of time you
specified is reached.
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To suspend a task in a work queue:

1. Click Work Queue Monitor.

2. Navigate to the active work queue, and click its name.
3. Select one or more tasks.
4

Select Tools > Work Queue Management > Suspend.

Tip: This action is also available through the Task Manager.

5. Type the time, and date when you want the application to automatically resume the task.

Unsuspend a work queue task

Users with the queue_admin or queue_manager role can unsuspend a suspended work queue task.

To unsuspend a task:

1. Click Work Queue Monitor.

2. Navigate to the active work queue, and click its name.
3. Select one or more suspended tasks.
4

Select Tools > Work Queue Management > Unsuspend.

Tip: This action is also available through the Task Manager.

Enable users to select tasks from the queue

Users who are assigned the queue_advance_processor role have the ability to view the work queue
tasks that they are eligible to work on, and acquire them regardless of their priority. Users with the
queue_advance_processor role have the additional Work Queue node in the directory tree that shows
all of their assigned work queues displayed as separate Inboxes. From these Work Queue Inboxes,
they can select any unassigned tasks that they are eligible to work on based on their skill set.

If a processor pulls only one task from the queue, the task automatically opens in Task
Manager enabling them to begin working on the task immediately. To keep the system

from automatically opening the task after the processor pulls it, you must change the tag
<openTaskManager>true</openTaskManager> in the pullqueuedtask_component.xml file to false.
The processor can still get the task, but must open it from the Work Queue Inbox.

Create business calendars

Users from various regions or business units of your organization may adhere to different work
hours, and schedules. To enable workflow timers to use actual working hours, and holidays, you can
create custom business calendars that reflect these different work schedules. All the timers using
business days, and business hours will use the business calendar associated with the process template.

110 EMC Documentum Webtop Version 6.8 User Guide



Work Queues

Users with the required permission sets can create calendars based on regional work schedules,
country-specific holidays, or other unique time constraints. A process designer can then use the
Process Builder application to select a specific calendar for an entire process or for a specific activity.
In this way, timers for a process are calculated based on actual work hours.

When you create a new calendar, you can select an existing calendar, and use it as a basis for creating
another calendar, making the necessary modifications to the new calendar.

You can also create different time periods within a calendar for ease of administration. For example,
you can create a calendar for the Western Region for the years 2008 through 2009. The calendar
can have two different periods of time on the Periods tab—a time period within 2008, and a time
period in 2009. Each period of time can be edited separately, and can have its own starting, and
ending times, work days, and non-working days.

Note: If you edit a calendar that is being used in a running or paused workflow, the timer expiration
dates are recalculated based on the modified calendar.
To create a new calendar:

1. Select Tools > Workflow > Calendar.

The Calendars page appears with a list of calendars that exist within the repository.
2. Select File > New > Business Calendar.

3. To base the new calendar on an existing calendar, select the calendar name from the Base
calendar list.

The default is None.

If the calendar is being used in a process, the system displays the process name in the Process list.
Type a name, and a description for the calendar.

Click Next to display the Periods page where you create separate periods of time.

Type a name for the group.

Select a Start date, and End date for this event.

® N o Uk

Select a Start time, and an End time for the days that fall within the category of working days.
Select Use same time for all checked days to set a time for one of the working days, and use it
for the selected days.

9. Toidentify a day as a Non-working day, select it from the pop-up calendar control, and click Add.
The date appears in the list of non-working days. To Edit or Delete the date, select it from the list,
and click the link to edit or delete.

10. Click Next to display the Details tab, and the list of events that are associated with the calendar.

On the Details tab, you can add, edit, and delete events.

11. Click Next to display the Permissions tab.

Superuser or users with the bpmuser role can create or delete a business calendar. Any user
can edit the calendar.

12. Click Finish.
The system saves the calendar to the /System/Workflow/Calendar folder.
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To delete a calendar:
1. Select Tools > Workflow > Calendar.

The Calendars page appears with a list of calendars that exist within the repository.
2. Right-click the calendar, and select Delete.

Note: The system will not delete a calendar that is referenced in any process definition.

To edit a calendar:

1. Select Tools > Workflow > Calendar.

The Calendars page appears with a list of calendars that exist within the repository.
2. Right-click the calendar, and select Properties.

3. The calendar definition opens, enabling you to edit the calendar details.
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Lifecycles

View lifecycles

Each file in the repository has a lifecycle. A lifecycle defines a sequence of states a file experiences
as it passes from creation to review to approval. For example, an employee might create a new
human resources form, another employee might review it, and a third employee might give the
approval necessary to make the file available to all employees. The lifecycle defines the file’s state
at each point in the process.

To view a file’s lifecycle, and current lifecycle state, open the file’s properties. If the file has no
assigned lifecycle, then you can assign the lifecycle through the properties.

You also can assign a lifecycle to a file when creating, importing, or checking in the file, or by selecting
the file in a file list, and using the Apply Lifecycle menu option. When applying a lifecycle, you
can specify the initial lifecycle state for the file.

You can advance a file through its lifecycle manually by selecting the file and using the Promote menu
option, or Records Manager (RM) Administrator can advance a file through its lifecycle automatically
based on conditions specified in the lifecycle definition, if a retention policy is associated with the
lifecycle. You can also demote a file to a previous lifecycle state.

See Table 12, page 113 for descriptions of common lifecycle states.

Table 12. Common lifecycle states

State Description
WIP (Work In Progress) The file is in draft or review.
Staging The file is complete, and ready for testing. By

default, you cannot edit a file that is in this state.

Assign a lifecycle to a file

To assign a lifecycle to a file:

1. Navigate to the file, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.
2. Select Tools > Lifecycle > Apply.
3. In the selection dialog box, do these:

a. Locate, and select the lifecycle, and click OK. For detailed steps see Locate an item in a
selection dialog box, page 21.
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b. If the lifecycle’s line item includes an option to select the lifecycle state, then select the
lifecycle state in which to place the file.

c. If the lifecycle’s line item includes an option to select an alias set, then select an alias set to
use with the lifecycle. The alias set determines which users have access to a file as it moves
through its lifecycle.

d. Click OK.

If you perform this procedure on a template, the lifecycle is assigned to all future files created
from the template. The lifecycle is not assigned to files that have already been created from the
template.

Remove a lifecycle from a file

To remove a lifecycle from a file:

1. Navigate to the file, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.

2. Select Tools > Lifecycle > Detach.

Promote a file to the next lifecycle state

To promote a file to the next lifecycle state:

1. Navigate to the file, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.
2. Select Tools > Lifecycle > Promote.

3. If prompted, select whether to promote related files.

Demote a file to its previous lifecycle state

To demote a file to its previous lifecycle state:

1. Navigate to the file, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.
2. Select Tools > Lifecycle > Demote.

3. Click Demote.

Suspend a file from its current lifecycle state

Suspending a file halts the lifecycle’s progress temporarily.
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To suspend a file from its current lifecycle state:

1. Navigate to the file, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.
2. Select Tools > Lifecycle > Suspend.
3. Click Suspend.

Resume a suspended file

To resume a suspended file:

1. Navigate to the file, and select it.

Tip: You can perform this procedure on multiple files by selecting multiple files.
2. Select Tools > Lifecycle > Resume.
3. If prompted to select which state to resume to, select the state.

4. Click Resume.
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Chapter 9
Collaborate with Other Users

Create and edit formatted text

When you write notes, comments, replies, and other text, you often use the Rich Text Editor (RTE).
You can type text directly into the RTE or add content by pasting or dragging-and-dropping from
another application.

The following table describes the tools available in the RTE.

Table 13. Formatted text editing tools

Tool Description

Gives access to comment editing options, such as undo, redo, delete, and
select all. With Microsoft Internet Explorer, additional choices are also
available: cut, copy, paste, and remove styles.

@ Adds graphics. The Insert Image dialog box opens, and provides controls
for choosing, and uploading one .bmp, .gif, .jpeg, or .png image at a time,
which is then shown inline in the editing area.

& Creates hyperlinks. The Insert Link dialog box opens. Set the title, and
URL of the hyperlink, and choose whether to have the link open in a
new window.

=
=
~

Checks spelling. (You will be prompted to download a plug-in.) When
the spell-checker finds a possible misspelling, the word is selected,
scrolled into view, and the Check Spelling dialog box opens. The word in
question appears in the Change box with a suggested alternative in the
To box. You can edit the text in the To box, or select a word from the list.
Spelling commands are as follows:

* Change. Changes the selected word to the one in the To box.

Change All. Changes all occurrences of the selected word in the text.

Ignore. Leaves the selected word unchanged.

Ignore All. Ignores all occurrences of the selected word in the text.

Add to Dictionary. Adds the selected word to the dictionary used to
check spelling.

Note: In general, the RTE can display any HTML content that the web browser can display. However,
if you paste into the RTE content that was created outside of the RTE, you might be unable to edit
some elements of that content. For example, if you paste an HTML table into the RTE, it displays
appropriately, and you can edit text in the table’s cells, but you cannot edit the table itself.
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Discussions

Discussions are online comment threads that facilitate collaboration around particular items. A web
site production team, for example, can use discussions to sharing feedback about content before
publishing it. Development teams can use discussions to brainstorm, debate, and reach consensus
about product design, and specifications.

Most items (such as documents or rich media files) have an attached discussion page. Folder, and
note pages have embedded discussions shown below the list of child items in a folder or the body
of a note. You can add, edit, delete, and reply to comments in a discussion, but you cannot select
or edit a discussion apart from its parent item.

Each new version of an item shares the same discussion as the immediately preceding version. A
WDK setting can change this default behavior so that discussions are only shared for each new minor
or branch version (while major versions have new discussions), or that no versions of an object share
a discussion (every version has its own). In this manner, an object’s versions can provide a sort of
timeline for an object, along with the comments in each discussion. When a discussion is shared by
versions, version markers for each checkin appear among the comments.

View discussions

In the optional Discussion status column of a list (indicated by the Q icon), objects that have
discussion comments are distinguished by one of these discussion icons:

. means you have read all comments in the discussion.

o 'l means there are some comments in the discussion you have not read.

To see a discussion, with or without comments (for example, to add a comment), either click on a
discussion icon, or select a single object, and pick View > Discussion.

To sort a list of objects according to their discussion comments (read, unread, or none), click Q at
the top of the Discussion status column. You can turn off the Discussion status column by using
Display Setting preferences for columns.

You can mark discussions as having all read or unread comments. For example, if you want a visual
reminder when only new comments are added to a particular discussion, select or open the object it is
associated with, and pick File > Mark Discussion Read. Conversely, you can make all comments
appear to be unread with File > Mark Discussion Unread. Selecting multiple objects applies these
commands to each object in the selection.

Add and edit comments

Users with at least Write permission to an object can go to the Properties: Info tab for the object, and
select or clear the Show discussion checkbox. Once a discussion is shown, users with at least RELATE
permission on the discussion’s primary parent can add a comment or a reply in that discussion.
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To add a comment to a discussion:

1. Display the discussion by doing one of these actions:
e Click the " or @ll,
® Select a single object, and pick View > Discussion.

2. In the discussion, below the last comment, click add a comment. (If there is no add a comment
button for an object, your permission for the parent object is less than RELATE.)

3. Enter the (required) title, and (optional) body of your comment.
4. Click OK.

Your comment appears below the last comment, set even with the left margin of the one above it.

To reply to a particular comment:
1. Next to the title of the comment to which to respond, click &

2. In the rich-text editing window, fill in the title, and body of your comment.

Your remarks appear below the comment to which you are responding.
If there is no & icon for replying to a comment, your permission for the parent object might be
insufficient. For adding or replying to comments you need at least RELATE permission.
To edit a comment:
1. Next to the title of a comment you added, click Q.
2. In the rich-text editing window, edit the title and/or body of your comment.

3. Click OK to put your changes into effect.

Unless you have administrative privileges, you can edit your comments only.

Delete comments

You can delete a comment as long as you have DELETE permission on it, and RELATE permission on
the discussion. These are your permissions when you author a comment.

When you delete a comment, any replies to it (and replies to them) are also deleted, regardless of your
permissions over them. If you have DELETE permission on an object, you may delete all comments in
its discussion, even if you lack permission to edit those same comments.

While you cannot explicitly delete a discussion, deleting all of its parents effectively deletes the
discussion as well.

Discussions in search results

The repository search index contains the rich-text content of discussions, but not their meta-content
or properties. This means that discussion comments can match a search by full text, but not a search
by properties like object type or creation date. You can, however, search for the names of comment
authors.
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When a discussion matches the search terms, the results show the parent object, not the discussion
itself. You can open the discussion of any search result using the same methods as in other contexts.

Notes

A note is a simple page for composing, editing, and sharing information without using or requiring
other users to have another application to do so. Notes can have built-in discussions, and can contain
rich-text content.

Notes (' ,) appear in Webtop only where documents are shown. They can have embedded
discussions if the Show Discussion option is checked in the note’s properties.

While you can subscribe to notes, they do not have versions or renditions. You can edit, move, copy,
or link a note, but you cannot check notes in or out, or export them.

To search for notes, run an advanced search, and set the type of object field to either Sysobject
(dm_sysobject) or Note (dmc_notepage).

To create a note:

1. Navigate to the location for the new note.

2. Select File > New > Note.
The New Note dialog box opens.

3. In the Create tab, specify the following properties:

e Name (required). The name of the new note must be unique among the names of other
objects in the same container.

* Note. Using the RTE, specify the body of your note (this is optional). You can edit this field
after the note is created.

* To subscribe to the note, check the Subscribe to this notepage option (click [+] Show options
if necessary to view the option).

You can either continue to another tab, or click Finish to create the note.

4. Click Finish to close the dialog box, and create the note.

Or, you can click Cancel to close the dialog box without creating a note.

To edit the body of a note:

1. Select File > Edit.

2. Edit the body of the note.

3. Click OK to put your changes into effect.

To edit the name of a note:

1. Do one of the following:

* Right-click the note, and select Properties from the context menu.

® Select the note, and select View > Properties > Info.
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The Properties: Info tab opens.
2. Edit the note’s Name, and any other properties, as appropriate.

3. Click OK to put your changes into effect.

To delete a note, select it, and then pick File > Delete.

Since notes do not have versions, the Delete dialog box for a note differs from that for typical
documents. Choices in the Delete dialog box are as follows:

* Links. Delete just the link to the location name (not selected, and disabled if the note has only

one location, otherwise selected by default).

* Note. Permanently delete the note (selected by default if note has only one location).

Contextual folders and cabinets

Contextual folders, and cabinets are repository containers with optional rich-text descriptions, and
built-in discussions. These features provide the ability to capture, and express the work-oriented
context of a folder’s hierarchy. Such contextual information might include details about project goals,
tasks, roles, milestones, and so forth. Since full-text search keeps an index of all descriptions, and
discussions in a repository, they are easy to find, along with the items to which they relate.

Rich-text descriptions display at the top of a contextual folder, like a room’s welcome message.
They can provide, for example, document summaries, instructions for using project materials, or
pointers to other locations. Because they can include formatted text, pictures, and hyperlinks, folder
descriptions can be informative, personalized, and appealing in order to draw users’ attention.

Discussions embedded on a contextual folder page encourage team members to focus communication
towards the nexus of their work (such as for document reviews) instead of using email, for example,
for project correspondence. Organized in a tree of comments, these discussions help to capture, and
preserve the work-related flow of information.

In some form or another, all project teams converse about a variety of topics, such as case issues,
scheduling decisions, development plans, product ideas, and customer feedback. Discussions in
contextual folders let teams save, and have ready access to such ad hoc but historically valuable
exchanges.

To create a new contextual folder:

1. Navigate to the location for the new folder.

2. Select File > New > Folder.
The New Folder dialog box opens.

3. In the Create tab, specify the following properties:

e Name (required). The name of the new folder.
e Type. The type of folder.

* Description. In the rich-text editing window, create a description that will appear below the
navigation path on the folder’s page (optional).

¢ To subscribe to the folder, select the Subscribe to this folder checkbox (click [+] Show options
if necessary to view the option).
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You can either continue to another tab, or click Finish to create the folder.

4. Click Finish to close the dialog box, and create the folder.
Or, you can click Cancel to close the dialog box without creating a folder.

To enable a discussion for the folder, you must select the Show Discussion checkbox on the Info tab
of the folder’s properties dialog box.

Calendars

Calendars let you organize, track, and schedule events. Since calendars support the iCalendar (or
iCal) standard format for exchanging calendar data over the Internet, they are well-suited for use
in distributed collaborative groups.

While you can subscribe to calendars, they do not have versions or renditions. You can edit, move,
copy, or link calendars, but you cannot check calendars in or out.

A calendar can be added to the clipboard, and then linked, moved or copied like a folder. A copy of a
calendar includes copies of all the original’s descendants. Calendars can only hold events, and only
events can be copied in calendars. Events, on the other hand, can be copied in any folder location.

Create calendars and events

To create a calendar:
1. Navigate to the location for the calendar.

2. Select File > New > Calendar.
The New Calendar dialog box opens.

3. In the Create tab, specify the following properties:

¢ Name (required). Enter the calendar’s name, which must be unique among the names of
other objects in the same container.

¢ Description. Create a description that will appear below the navigation path on the calendar’s
page (optional).

e To subscribe to the calendar, select the Subscribe to this calendar checkbox (click [+] Show
options if necessary to view the option).

Either continue to another tab, or click Finish to create the calendar.

4. Click Finish to close the dialog box, and create the calendar.
Or, you can click Cancel to close the dialog box without creating a calendar.

To enable a discussion for the calendar, you must select the Show Discussion checkbox on the
Info tab of the calendar’s properties dialog box.

To create a calendar event:
1. Navigate to (or create) the calendar in which to create an event.

2. Select File > New > Event.
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The New Calendar Event dialog box opens.

3. In the Create tab, enter information as appropriate. For field descriptions, see Table 14, page 123.

Table 14. Calendar events

Field

Description

Name (required)

Start Date (required)

Start Time (required
unless All Day Event
is selected

All Day Event
End Date (required)

End Time (required
unless All Day Event
is selected)

Organizer (required)

Attendee List

Location

Notes

Send mail when I
finish

Type the name of the new event. If you select the Send mail when I
finish checkbox, the event name appears in the Subject: field of the
header in the email about the event.

Pick a date when the event starts.

Enter a time when the event starts.

Select this checkbox if the event is a day-long occurrence.
Pick a date when the event ends.

Enter a time when the event ends.

Pick the name of the user organizing the event if different from the
(default) user creating the event. If you select the Send mail when I
finish checkbox, the organizer’s name appears in the CC: field of the
header in the email about the event.

Pick the names of users attending the event. If you select the Send
mail when I finish checkbox, these names appear as recipients in the
To: field of the header in the email about the event.

Specify the location for the event.

Enter information about the event (optional). If you select the Send
mail when I finish checkbox, these notes will appear following the
default text in the body of the email message to recipients. The default
text in that email is as follows:

You are invited to the following meeting: Topic:
meeting name Date: recurrence pattern or start date,
time, duration Location: location To view the event,
point your browser to: event drl Or open this event in

your desktop calendar: ICS inline attachment

Select this checkbox if you want to send email notices about the event.

4. For a recurring event, open the Recurrence tab, and follow the guidelines in the section titled
Specifying recurring event properties later in this chapter.

5. Click Finish to close the dialog box, and create the event.

If the Send email when I finish checkbox is selected when you click Finish, notification email
about the event is sent to the users specified on the Attendee List.

Or, you click Cancel to close the dialog box. In this case, no event is created, and no email is sent.
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Specify recurring event properties

Recurring events repeat according to a specified frequency pattern for a specified duration. You set
these properties in the Recurrence tab of the Calendar Event properties dialog box.

Choose from the following options to specify a recurring event'’s frequency pattern:

* None (default). The event does not repeat, and event duration options are disabled.
* Daily. The event repeats either every day, or (if selected) Every Other Day.

* Weekly. The event repeats every week according to the following options:
— Every Other Week (optional). The event repeats every other week on the selected Days.

— Days (required when Weekly frequency is chosen). Pick one or more days of the week on
which the event occurs. The default setting is the day of the week on which the start date falls.

* Monthly. The event repeats every month according to one of the following options:
— Same Date. The event repeats once per month on the same date. If the date is the 29th of the
month or later, this option includes the text or last day of month. For example:

Day 17.
Day 30, or the last day of the month.

— Same Weekday, On Alternating Weeks (available only if start date falls on the 28th of the
month, or earlier). The event repeats in a pattern similar to these examples:

The first, and third Wednesdays.
The second, and fourth Fridays.

— Same Weekday, Last Of Month (available only if the day on which the event starts is one of
the last seven days of the month). For example:

The last Tuesday of the month.
The last Friday of the month.

Annually. The event repeats once per year on the same date each year.

If the event’s frequency pattern is set to None, duration settings are disabled. Otherwise, choose one
of the following options for a recurring event’s duration:

* Occurrences. Specify the number of times the event occurs.

* End Date. Pick the date of the last time the event occurs. The default setting is the date on which
the last of the specified number of Occurrences falls. If the End Date is the 29th of the month, or
later, and month has no such day, the date is last day of the month.

* Forever. Select this option if the event has no finite number of occurrences, and no end date.

If the Send mail when I finish checkbox is selected when you specify recurring event properties, the
notification email sent to event participants includes a description of the recurrence in the Date field.
Here are some examples of such descriptions:

¢ Daily, for 5 occurrences
¢ Every other day, for 5 occurrences

¢ Weekly on Wednesday, Thursday, until September 20, 2007
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* Monthly on Day 30 or last day of month, forever

e Annually, for 5 occurrences

View calendars and events

Calendars display events in a list that you can modify by changing list view preferences. Default
columns in the calendar list view are as follows:

e Event. The name of the event.

* Attachment icon — The attachment icon is shown if attachments are available on the event.
Attachments cannot be added to an event, however attachments might be added through other
applications. Clicking on the attachment icon takes you to a folder view with the attachments
listed in the view list.

¢ Exception Type icon. Indicates standalone exceptions or recurring events with exceptions.
e Start. The start date, and time for the event.
¢ End. The end date, and time for the event.

e Location. The location of the event.

Edit calendars and events

Properties of calendars, and events are the same when you view or edit them as when you create them.

Just as you can edit several objects at the same time, you can edit multiple events at once. When
editing multiple events, however, only the Info, and Permission tabs are available.

When editing events, the following rules apply:

¢ For a recurring event, the entire series is always edited.
¢ For an exception to a recurring event, only the exception is changed.

Collaborative services cannot create exceptions to recurring events, but can display exceptions that
another application or import creates. Such exceptions can be edited.

If you view or edit a calendar event, and you select the Send email when I finish checkbox,
notification email is sent to event participants when you click Finish.

Delete calendars and events

When you delete a calendar, decide whether to delete the selected calendar only, or the selected
calendar, and all events (this is similar to deleting a folder).

To delete an event, select it, and choose the Delete command. In this case, the following rules apply:

e For a recurring event, you must confirm that all exceptions will be deleted.

* For an exception to a recurring event, only the selected exception is deleted.
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Calendars in search results

All content in a calendar (including any description and discussion comments) is indexed for full-text
search. In the Advanced Search dialog box, Calendar, and Calendar Event are included in the list of
object types for which you can search.

Export and import with calendars

Collaborative services can export events as .ics files, in iCal format. The Export command is available
when one calendar or event is selected, or when a calendar or event is open. You can export an
individual event or an entire calendar.

When an event is imported, its properties are handled in one of these ways:
e Use. If a property is supported, then it is used as follows:
— no change. Keep the original value if it is supported. For example: Duration.

— reformat. Reformat a value with an equivalent. For example, a start time can be expressed in
more than one time zone.

— convert. Convert an overly complex or unsupported value. For example, seconds are removed
from times, and durations.

* Move. If a property is not supported, but a similar property is, the value of the former is moved to
the latter. For example, a comment is moved, and combined with a description.

* Cache. If a property is not supported, but its presence is harmless, the property is retained in case
the event is exported. For example: Free/Busy.

* Discard. If a property conflicts with collaborative services’s object model, it is discarded. For
example: Attachments.

Importing an event that was previously exported updates the original event if the exported event was
changed prior to being re-imported.

Data tables

Use data tables to create, and manage structured collections of similar data such as lists of issues,
tasks, milestones, and contacts. Information in a data table is organized as a series of entries (or
records, or rows) that have a common format, or schema. Each table has just one schema, which
describes the attributes of each field, including its name, and data type.

Data tables also provide an improved summary for data table fields like the traffic light. The data
table entry view provides a visual and user friendly view of table entries. The entry view also
supports attachments for a given entry as well as the ability to discuss the viewed entry.

While you can subscribe to data tables, they do not have versions or renditions. You can edit, move,
copy, or link data tables, but you cannot check them in or out.

You can copy, move, and paste data tables. When you copy a data table with entries, the new entries
have a fresh series of autonumbers, and an empty history.
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Data table entries can be copied, and pasted between tables, and within the same table.

When a data table becomes governed or ungoverned, all its entries are governed or ungoverned as
well. When you copy or move entries between tables with different governing, the governing is
automatically changed on the copied or moved entries.

Create data tables and entries

To create a data table:

1.

Navigate to the location for the new data table. Either paste a data table from the clipboard,
import a data table, or perform the following steps to create one from scratch.

Select File > New > Data Table.

The New Data Table wizard opens.

In the Create tab, enter the following properties:
¢ Name (required). The name of the new data table.

* Description (optional). A description that appears below the navigation path on the data
table’s page. You can edit this field after the data table is created.

To subscribe to the data table, check the Subscribe to this data table option (click [+] Show
options if necessary to view the option).

Click Next to create the data table’s fields (or columns). A data table entry consists of the fields

that make up a row. Each field has a name, and a data type, and one of the fields is the designated

entry name. Three, unnamed, plain-text fields are initially provided for a new table. You can edit,

add, or delete fields as appropriate.

For each field, choose settings as follows:

¢ Field Name (required). The name label for the field. For example, Name, Date, Part Number,
and so on. The name must be between 1 and 128 characters in length, and it must be unique
within the current table. One of the field names is designated as the entry name.

¢ Field Type. The type of data the field contains. Choose a field type, as described in Table 15,
page 128. You cannot change (edit) the data type of a field once the table is created.

¢ Use as entry name. The field identified as the name of the entry. Clicking the entry name
in a data table row opens the entry. The following field types can be entry names: plain
text, number, autonumber, date, or member. You cannot change (edit) or remove the entry
name field once the table is created.

To add a field, click Add; to delete a field, click Remove.

Either continue to another tab, or click Finish to create the data table.

Click Finish to close the wizard, and create the data table.

Or, you can click Cancel to close the wizard without creating a data table.

To enable a discussion for the data table, you must select the Show Discussion checkbox on the Info
tab of the create data table wizard, or the data table’s properties dialog box.
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Table 15. Data table field types

Field type

Description

Plain text

Formatted text

Date

Number

Autonumber

Yes/No
Traffic light

Choice list

Member list

Discussion

Attachments

For fields displaying text with no special formatting.

For fields displaying text with type styles such as bold, and italic, as well
as graphics, and hyperlinks.

For fields displaying calendar dates. When creating a table, and defining
a date field, you can (optionally) select a checkbox that specifies the field
as a due date.

For fields displaying fixed digits, and related characters, such as currency
symbols, commas, and decimal points.

Numeric values created automatically, according to the sequence in which
the entry is created. A data table can have only one autonumber field.

For fields displaying blank, yes, or no values.

For fields displaying blank, red, yellow, or green values, indicating the
overall status of entries.

For fields that display a subset of predefined values. Specify the choice
values in the text box (for example: choice 1, choice 2, and choice
3, without the commas, and each on its own line).

A choice list must have at least one choice, each choice must be unique
in the list, and no line can be blank. The order of lines determines the
order in which the choices appear in the list of choices when users create
or edit an entry.

To allow users to choose more than one value for this field, select the
checkbox labeled Allow multiple choices.

For fields that display the names of members. Members can either be
users or groups. Decide whether multiple users can be selected for this
field or only from a list of specified users.

For including a discussion field in the entry. A data table can have only
one discussion field.

For including an attachments field in the entry. A data table can have
only one attachments field.

To create a data table entry:

1. Navigate to (or create) the data table in which you want to create an entry.

2. In the data table summary view, select File > New > Entry.

The New Table Entry dialog box opens.

3. In the Create tab, enter data for each of the field types.

You can either continue to another tab, or click Finish to create the entry.

4. Click Finish to close the dialog box, and create the entry.

Or, you can click Cancel to close the dialog box without creating an entry.

128
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Table 16. Editing data table field types

Field type

Description

Plain text
Formatted text

Date

Number
Autonumber
Yes/No
Traffic light
Choice list

Member list

Discussion

Attachments

Edit a plain text field using a standard text box.
Edit a formatted text field using the RTE.

Edit a date field using a text box with a date picker provided for choosing
a date. If the date is a due date, you can optionally select the Done?
checkbox to indicate when a task is finished.

Edit a number field using a text box.
The autonumber field is read-only.
Select blank, Yes, or No.

Select Red, Yellow, Green, or blank.

For a choice-list field that allows one choice only, pick the value from a
drop-down list of predefined choices. For a field that allows multiple
choices, select from the set of predefined values.

Use the member picker to select members (either users or groups).
You can select multiple values in the Member list field even if it is
configured as a single-value entry field. When you select more than one

value, there is no data loss or data corruption. If you set multiple values
for the field, some Webtop screens may display more than one value.

You cannot edit a discussion field.

You cannot edit an attachments field.

View data tables

When browsing in a folder, data tables appear as data table icons.

To open a data table, either select it, and pick File > Open, or double-click it.

The data table opens in the summary view. Entries are displayed in rows. Each row is divided into
fields (or columns) of data such as name, address, and phone number, according to the table’s schema.

You can sort columns, and edit column preferences the same as you do in a folder. If you delete a
field, the corresponding column disappears. If you add a field, however, you must edit column
preferences to make it appear in summary view.

View data table entries

To view a data table entry from the data table summary view, either select it, and pick File > Open, or

double-click it.
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If the entry belongs to a data table governed by a room, the room banner graphic (if any) appears
on the page below the entry name.

If the data table schema includes an Attachments field, a list view appears embedded in the entry
page like a folder list. The attachments area supports Webtop drag-and-drop functionality. (To use
drag-and-drop, you must first enable the drag-and-drop option in your general preferences.)
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Folders, and folder subtypes are not permitted in the attachments area. Attachments, if they are not
already governed by a room, are governed automatically when a data table becomes governed
by a room.

If the data table schema includes a Discussion field, the discussion appears embedded in the entry
page as it does on a folder or a note page.

Edit data tables

To edit the properties of a data table, do one of the following;:

¢ Select it, and pick File > Edit.

* Select it, and pick View > Properties.

¢ Right-click the data table icon, and select Properties from the pop-up menu.
e In summary view, click the Edit button at the top of the page.

When you edit a data table, the standard Info, Permissions, and History tabs are available, in
addition to a Fields tab, which allows you to edit table fields.

When editing a data table’s fields, you can add, rename, and delete fields, and modify certain field
options. Once the data table is created, however, you cannot

¢ change the data type of a field
e change or remove the entry name field
* reorder fields

You can change the choices in a Choice list, and members in a Member list. However, you cannot
change a Date to a Due date, nor a member field that allows multiple choices back to one that permits
a single choice only.

If you delete a Discussion field, all comments in all of the data table’s entries are removed.

If you delete an Attachments field, all attachments are removed from every entry in the data table.
This action cannot be undone. Attachments that are linked elsewhere in the repository are unlinked. If
any attachment cannot be deleted, no attachments are deleted. Until the delete operation concludes,
no one can delete the data table, add or remove entries, edit the data table’s properties, nor edit

the data table’s entries.

Edit data table entries

To edit field values in a data table entry (row), do one of the following;:
* Select the entry, and pick File > Edit.

* Right-click the entry name, and pick Edit from the pop-up menu.

* On an entry page, click the Edit button.
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The edit entry page opens, and fields appear in the same order, and with the same names, as they
have in the table’s schema. The name, and value of each field appear side-by-side. You edit field
values the same as when you create an entry.

To edit the properties of a data table entry, do one of the following:

* Select it, and pick View > Properties.

* Right-click the data table entry name, and select Properties from the pop-up menu.
* On the entry page, click the Edit button at the top of the page.

When you edit the properties of a data table entry, these tabs are available:
¢ Info: standard Info tab

e Permissions: standard Permissions tab

* History: standard History tab for a data table entry

Delete data tables

In order to delete one or more data tables, you must have permissions to delete the data tables, the
data table entries, and any/all attachments in the data tables. If you have delete permissions for the
data table(s) but not for one or more attachments in the data table(s), the table will not be deleted.

Import and export with data tables

You can add entries to a table by importing entries from a file. To do so, open the table, and choose
the File > Import command, which opens the Import dialog box. When importing entries, values
are unmodified even if they conflict.

Entries in a table may be exported in .csv format via the Export command. Data is exported according
to the same rules as when importing.

Rooms

Rooms are virtual workplaces where group interactions take place. Rooms have members, and
membership is associated with both the processes, and the content in a room. Items in a room are
governed by that room (that is, their permission sets are determined by the room), and non-members
cannot access them.

Repository users with the appropriate permissions can create, and administer a room in Webtop,
instead of relying on a system administrator. Room creators/owners, and user managers determine
a room’s member list.

Note: Creation, and administration of rooms are available only to WDK-based applications such
as Webtop.
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Visit a room

Rooms are like folders in the Webtop navigation tree.

To open the home page of a room of which you are a member:

1. In alist of items, click the room icon (T:i).

The first time you visit a room’s home page, you have the option to subscribe to it (unless you are
its creator, and have already done so).

2. Choose Yes or No, and then click Continue.
If you choose Yes, the room’s home page is added to your subscriptions.

The home page of a room is like the top level of a folder, with these unique aspects:
* The title is the room’s, plus the words "home page".

* A banner graphic (if any) appears above the room’s welcome message. (A room’s banner graphic
also appears on the pages of governed folders, notes, and standalone discussions in that room.)

¢ Alink to the Membership tab of the room properties appears at the top.
* The welcome message (if any) is like a folder’s rich-text description.

e The built-in discussion is named Announcements.

Link to a room

You can add a link to a room’s home page anywhere in the repository that permits links.

Objects governed by rooms

When an object is governed by a room, its permission set is ruled by the room, and only the room’s
members can access it. While a governed object may be linked to other locations in a repository, only
members of the room that governs the object can access it. A room governs anything created within
or imported into it, except for another room.

When an object becomes governed (is either created in or copied to the room or a governed folder),
the room’s default permissions are applied to the object. If the room’s permission set is changed, all
permission sets for governed objects are changed accordingly.

In the Room column of a list (indicated by the 9 icon), objects that belong to rooms are distinguished
by one of the following icons, which are their governing indicators:

o ¥ means the item belongs to (or is governed by) the same room as the current folder.
o W means the object belongs to a different room.

Clicking a governing indicator opens the room’s home page. Click the [ header icon to sort a list of
objects according to whether they belong to the same room, a different room, or no room.
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If you show all versions in a folder, each version of an object that is visible to you has its own
governing indicator since different versions may belong to different rooms.

You can turn off the Room column by using Display Setting preferences for columns.

Ungovern objects from a room

A user must have Write, and Change permissions on an object in order to ungovern it. Also, a room
option may limit ungoverning to owners.

When an object is ungoverned, it gets the default permission set for the repository, unless it is
ungoverned from a governed folder, and the default permission set is FOLDER, in which case it gets
the default permission set for the user.

The governing relationship of an object to a room can be removed in these ways:

* Moving links from inside the objects’ room to anywhere outside it can lead to ungoverning
those objects.

¢ Using the File > Remove From Room command.
* Copying a governed object into an ungoverned folder.

* Moving a link for a governed object out of its room via a workflow, as long as the workflow is
authorized to ungovern in that room.

If you copy entries between different governed data tables, the governing on the copies is
automatically changed to match the governing room’s permission set.

Create a room

You can create a room anywhere in a repository that allows folders. However, it is recommended that
you restrict the number of rooms in a repository to less than 250.

To create a room, users must not only have permission to create objects in the intended location, but
must also belong to the Create Room role in the repository.

When you create a room, you become its owner.

To create a room:
1. Navigate to the location for the new room.

2. Do one of the following:
* (lick New Room.

e Select File > New > Room.

The New Room dialog box opens.
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3. In the Create tab, specify these properties:

¢ Name (required). The name of the new room. The name must be unique among the names of
other objects in the same cabinet.

* Welcome message. Optional rich text that will appear below the navigation path on the
room’s home page.

* To subscribe to the room, select the Subscribe to this room checkbox (click [+] Show options
if necessary to view the option).

You can either continue to another tab, or click Finish to create the room.

4. Choose the room’s members either now, or after the room is created.

¢ The Choose Owners tab provides the usual Webtop controls for selecting users, groups,
or roles. You can add or remove members in this role later. As the room’s creator, you
automatically become an Owner.

* On the Choose Contributors tab, pick the repository users, groups, or roles that you want in
the room’s Contributors role. You can add or remove members in this role later.

5. Select the room’s options either now, or after the room is created.

* Rights to remove governing. Decide who can remove the governing relationship that the
room has over objects belonging to the room, either room Owners only, or any room member
(Contributors as well as Owners).

* Room Banner. Decide whether your room displays a graphic at the top of all pages in the
room. To specify a custom banner, select the Use Custom Banner checkbox. Pick the graphic
file (.gif, .jpg, .jpeg, or .png format, no more than 36 pixels tall) that will upload to the room
when you click Finish.

You can remove a room’s graphic by editing the room’s properties, clearing the Use Custom
Banner checkbox, and clicking OK to put your change into effect.

* Accessors for newly added objects. Set up the permissions to add to an object when it
becomes governed by the room. A chart lists which permissions will be granted each local
group. Each row in the chart shows the name, and current settings of one group, with an
Edit button leading to an editing dialog. The chart initially shows the two built-in groups,
Contributors, and Owners, with the following default settings:

— Contributors: RELATE, Run Procedure, Change Location.

— Owners: DELETE, Run Procedure, Change Location.

If additional room-level groups are created after the room is created, the chart also lists these
groups, with initial permission of NONE, and no extended permissions.

The room creator can change the setting for any group by clicking Edit in its row to open the
Set Access Permissions: For new objects added to the room dialog box, which contains
the usual controls for setting permissions.

6. Click Finish to close the dialog box, and create the room.

Or, you can click Cancel to close the dialog box without creating a room.
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Edit the properties of a room

Room owners can edit the complete set of room properties. Room members who have WRITE
permission on the room can edit a subset of properties inherited from the folder type. However, only
room owners can change the name of the room.

To edit the properties of a room:

1. Navigate to the location that contains the room.

2. Do one of the following:

® Select the room, and pick View > Properties > Info.
* Open the room, and click the Properties link on the room’s home page.
The Properties: Info tab opens.

3. Change properties, as appropriate, and click OK to put them into effect for the room.

Changes you make to the Properties: Membership tab take effect immediately (you do not
need to click OK first).

About room membership

Room members are a set of repository users, groups, and roles that are on the room’s member list.

Each room member has either a Contributor or Owner role in the room.

¢ Contributor role usually grants RELATE permission over room objects. Most room members
are contributors.

* Owner role permits member list management, and usually grants DELETE permission over room
objects. Room creators are room owners by default.

Local roles are in effect only for room objects, and locations; they have no meaning outside of a room.

If a member directly assigned to the Contributor role is also in the Owner role indirectly (for
example, via a group), then the Owner role takes precedence for that member.

Room members can belong to private, local groups within a room. Such local groups support custom
roles within the room (Spec Approvers, for example). The name of a local group must be unique
within the room.
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Figure 4. Repository members in relation to room members, groups, and roles

repository members
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room members
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Note: If a repository contains more than 250 roomes, it is recommended that only users who are
members of less than 250 repository groups access such repositories.

All members of a room can see the room’s member list, but only room owners, and user managers can
manage room membership.
To open the room member list:

1. Do one of the following:

® On the room’s home page, click the Members link.
* Open the Membership tab of room properties (Properties: Membership).
Columns in the room member list are as follows:
¢ Name. The name of the group or member.
* Role. Distinguishes owners versus contributors.
¢ State. Shows whether members have working accounts in the repository.
* Description. Email addresses for users, descriptions for groups.

* Group. Visible when the Show Groups checkbox is selected. If a member is not explicitly added
to room, this column shows the group that grants membership to the member. (There might be
multiple groups, but only the first in alphabetical order is shown.)

To see the members of a group, click the group’s name. To go back up, use the navigation path
above the group member list.

If you are a user manager, a button for creating a new user also appears in this dialog box.
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Copy a room

You can copy a room to anywhere in a repository that a folder can be copied.

When you copy a room, the new room contains copies of everything accessible from the original.
A copy of a room has the properties of the original. The local roles, and groups of the copy are
duplicates of those in the original room, except that the member creating the copy is in the Owner
role (not the owner of the original room, if different).

Move or link to a room

You can move a room anywhere in a repository that a folder can be moved.

A link to a room home page may be added anywhere in the repository that permits links.

Delete a room

Superusers, and room owners can delete a room, but any users who are not room members cannot
delete a room, even if they have DELETE permission.

Choose one of the following options:
* Delete just the link to [room name] (default choice).

* Delete the room, including its member list and local groups, and all links to it. In this case, you
must pick between deleting just the current version or all versions.

If you delete the last remaining link to a room, you are deleting the room, and must decide whether to:

* Delete the room, its member list, and its local groups (default choice). This action succeeds only
if the home page has no links, not even hidden links to old versions, which also implies the
room no longer governs anything.

* Delete the room, its member list, its local groups, and all sub-folders and objects. In this case,
decide whether to:

— Delete current versions of linked objects (default choice)

This option begins by deleting the current version of every linked object. The deletion stops,
however, if the home page, and sub-folders still contain links to other versions of any of those
objects, even hidden links to old versions. To be entirely deleted, the room must not have any
links (not even hidden ones) to non-current versions of objects.

— Delete all versions of linked objects

If you are deleting multiple objects, the deletion dialog box has multiple pages with the above choices
for any room that needs it.
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Manage room membership

Room owners, and user managers determine a room’s membership. You can add members when you
create or modify a room. User managers can also create new users in a room.

Once the room’s members are specified, you can invite them to the room by sending an invitation.
This personalizes the introduction to a room, and provides a convenient means of getting there
(by clicking the link in the invitation).

To add repository users as room members:

1. On the room’s Membership tab, click Add.

2. In the first dialog box, use the member picker to locate, and select the repository members,
groups, and roles to add to the room’s member list.

3. Click OK to go to the next step of assigning a role to the selected members. (Clicking Cancel
returns to the Membership tab.)

4. In the second dialog box, pick the new members’ role (Contributor or Owner).

5. Click OK to assign the role, and return to the Membership tab. (Clicking Cancel returns to the
member-picking dialog box.)

To invite members to a room:

1. On the room’s Membership tab, click Invite.

2. In the email dialog box that opens, click to and/or cc to select the room members you want
to invite.

3. In the body of the invite, enter your message. The message initially includes a link to the rooms
location.

4. Click Send to send the message to the specified members.

Or, click Cancel to close the dialog box without sending the email.

To remove members from a room:

1. On the room’s Membership tab, click Remove to open the Choose Members: Room Members
tab, which lists room members, including local groups, only.

2. In the left pane, locate, and select the room members, groups, and roles to remove from the
room’s member list.

3.  With the members selected, click EJ

4. Click OK to remove the members from the room’s member list.

The Membership tab opens. Members removed from a room are also removed from all local
groups in the room. These members remain repository members, however, even if they are
removed from a room.
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To change local members’ roles:

1.
2.

On the room’s Membership tab, click Change Role.

In the first dialog box, use the standard member picker to locate, and select the room members,
and groups for whom to change roles.

Click OK to go to the next step of assigning a new role to the selected members. (Clicking Cancel
returns to the Membership tab.)

In the second dialog box, pick the members’ role (Contributor or Owner).

Click OK to assign the role, and return to the Membership tab. (Clicking Cancel returns to
the member-selection dialog box.)

To create a new local group:

1.
2.

3.
4.

On the room’s Membership tab, click New Group to open the Create New Room Group tab.

Type a name for the group (required). The name must be unique among local group names in
the room.

Optionally, type a plain text description for the group.

Click OK to create the group, and return to the room’s member list.

A local group is owned by the room’s Owners group (even if removed from the room). Therefore, it
can be used in permission sets of governed objects only.

To edit the properties of a local group:

1.
2.

Open the room’s Membership tab.

Modify group properties as appropriate, and then click OK to implement your changes.

To add room members to a local group:

1.

On the room’s Membership tab, click the name of the group whose membership you want
to modify.

The group’s member list opens.

On the group member list page, click Add.

A page for locating room members opens.
In the left pane, locate, and select the room members, groups, and roles to add to the group.
With the members selected, click EJ

Click OK to add the members, and return to the group’s member list.

To remove a local group from a room:

1.

140

On the room’s Membership tab, click Remove to open the Choose Members: Room Members
tab, which lists room members, including local groups, only.

In the left pane, locate, and select the groups to remove from the room’s member list.

With the groups selected, click ),

Click OK to remove the groups from the room’s member list.
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You return to the Membership tab.

Members removed from a room are removed from all local groups in the room, but they remain
repository members. Local groups removed from a room, on the other hand, are effectively deleted
from the repository.

When a local group is removed from a room, its own member list is emptied, and it no longer appears
in member lists, and member pickers. It also ceases to appear on the list for setting accessors on the
Room Properties: Options tab, under Accessors for newly added objects. The group remains listed
on any permission sets it is already on, but its name shows that it has been "deleted." It continues

to be owned by the room Owners group, keeping it secure. The built-in local groups (Owners and
Contributors) cannot be removed, and therefore do not appear on the Remove dialog box.

Manage users as a non-administrator

Collaborative projects sometimes involve repository users working with external users such as clients,
auditors, or suppliers. External users typically do not have user accounts administered centrally in
the repository, like LDAP users do, for instance. Such mixed groups might perform confidential or
proprietary work, and can benefit from membership in the same room.

To address these cases, system administrators can delegate some user-management tasks to
non-administrators by assigning them to the role of user Manager (dce_user_manager). User
managers can perform a variety of user management tasks without being a system administrator.
Specifically, user managers can:

* Browse users and groups. User managers can access a node in the repository tree called
Administration, which contains a link to User Management, which links to pages for Users, Groups,
and Roles.

¢ Create new users. In the Administration area, and on room member pages, user managers have
access to a dialog box for creating new users.

* Modify users. User managers can unlist certain users, or prevent their names from appearing in
the repository user list in a user picker. They can also restrict certain users” access to content.

Create new users

User managers can create new users at the repository level in the Administration area, or in a room
for which they are an owner.
To create a new user:

1. Open the New User dialog box in one of these ways:

¢ Navigate to Administration > User Management > Users. Select File > New > User.

¢ Navigate to the room to which to add a new user. Open the room’s Properties: Membership
tab by either clicking the Members link on the room’s home page, or accessing the room’s
properties. Click the New User button.

Controls in the New User dialog box are disabled for user managers, except as noted in this
procedure.
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10.

11.

12.

13.

14.
15.

In the Name field, type the user’s name.

The User Source property is set to Inline Password, and user managers cannot change it. This
setting means that the user must provide a password that is stored only in the repository. There
is no external authentication.

In the Password field, type the user’s password. The password is encrypted, and stored in the
repository.

In the Password Verify field, type the user’s password again.
Type a Description for the new user (optional).

Type the user’s E-Mail Address.

This is the address to which notifications for workflow tasks, and registered events are sent.

In the User OS Name field, type the user’s operating system user name.

This is the user’s repository user name.
Select a Home Repository for the user.

To prevent the user’s name from being included in repository member lists, select the Is Unlisted
checkbox. Otherwise, the user’s name appears in repository member lists, as usual. For more
information on this setting, see Unlisting users, later in this chapter.

To restrict the user’s access to specific folders, cabinets, or rooms, click Select Folder to locate,
and select them in the repository. For more information on this setting, see Restricted folders,
later in this chapter.

Note: To remove some containers from the restricted folder list, open it, select the folders, and
click Remove. To remove all containers from the list, click Clear.

Select one of the following choices for the user’s default folder:

* Choose existing folder. Click Select Folder to pick a folder, cabinet or room other than
the default folder /Temp.

e Choose/Create folder with the user name. This is the default choice.

The Privileges, and Extended Privileges settings are set to None. User managers cannot change
these settings.

The user’s client capability is set to Consumer, and user managers cannot change it.

Click OK to create the new user.

Modify users

An administrator can modify any user. A user manager can modify only those users created by
someone who was, at the time, a user manager but not also an administrator. (When a user manager
who is also an administrator creates a user, that user is considered to have been created by an
administrator rather than a user manager.)

The user manager role (dce_user_manager) must be present in the repository’s list of roles so that
collaborative services can detect which users can be modified by user managers.
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Members can be modified via the User Properties dialog, accessed in the usual manner, either at the
repository level or at the room level. All controls that user managers can edit in the New User dialog,
they can also edit in the User Properties dialog, with these provisions:

* Modifying a user’s name does not take effect until a job is run on the server.

¢ To change a user’s password, replace the masked-input characters (usually bullets or asterisks)
with a new value in both the Password, and Verify Password fields.

* The list of folders in the Restrict Folder Access To list might include folders for which a user
manager lacks BROWSE permission. These folders are indicated in the list by a message stating
that a folder cannot be listed. To eliminate such folders from the list, a user manager can click
Clear. Such folders do not appear in the folder picker.

Unlist users (conceal members)

An unlisted user’s name does not appear to regular users in the repository user list. While a user is
unlisted, the only places their names appear are:

e User lists in the Administration area.

e User list for adding people to a room (in the New Room dialog box or Add Member dialog)
when viewed by a user manager.

e Member lists of rooms in which user is a member.

* Contexts where the user is already picked for some purpose, such as an permission set entry for
an object, the Owner attribute of an object, a member field in a table, or a performer assignment
in a Quickflow.

* Applications outside of WDK, such as the Workflow Manager.
Unlisted users appear in user lists with "[unlisted]" after their names, except in room lists.

A group for unlisted users, called dce_hidden_users, is created at the root of the repository user

list. This group is visible to administrators, and to user managers in the Administration area, and
administrators should avoid renaming or deleting it. The group’s description states that it is managed
by collaborative services, and its child list should not be modified directly. If a group with the same
name already exists, that group is used instead of a new one. If a group with the correct name cannot
be found, it is created. Administrators, and user managers can open the group to view its children,
but they cannot manually add users to or remove users from this group.

Note: Unlisting affects lists, not objects. Content created by an unlisted user is unaffected. Unlisting
takes effect as soon as the user manager saves the dialog box.

Restricted folders

When users have anything on their restricted folder list, their access to repository content is limited
to objects that are descendants of the listed item. If the restricted folder list is empty, the user has
access to all folders, and cabinets in the repository, subject to the permissions on those cabinets,
and folders subject to folder security.
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Folder restriction never applies to:

e Rooms in which the user is a member

e System cabinets required for participation in the repository, such as /System, /Templates, and

/Resources
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Forms

Enter data in a form

A form provides fields for you to enter, and retrieve data. You open a form from a file list or from a
task. When a form is attached to a task, it appears either as an attached file or as fields within the task.
When you enter data in a form, the data is saved as content, properties, or both. If data is saved as
properties only, the form will have a file size of zero.
To enter data in a form:

If the form opens automatically in a task, go to Step 3.

Navigate to the form, select it, and then select File > Edit.

Enter information as needed. For additional instructions, see Format text in a form, page 145.

1

2

3

4. To clear your changes, click Reset.

5. When you are done entering information, click either Save or Submit.
6

If prompted to confirm, click Yes.

Format text in a form

To format text in a form, use the buttons described in Table 17, page 145. Some of the buttons may
not appear.

Table 17. Icons used to format text in a form

Button Description

r!) Moves the selected text to your clipboard, and
deletes it from the current location.

In certain browsers, the browser security setting
might disable this button. To move text to your
clipboard, press Ctrl-X.

Copies the selected text to your clipboard.

In certain browsers, the browser security setting
might disable this button. To copy text, press
Ctrl-C.

EMC Documentum Webtop Version 6.8 User Guide 145



Forms

Button Description

AQ Pastes the text from your clipboard to the
: selected location.

In certain browsers, the browser security setting
might disable this button. To paste text, press
Ctrl-V.

Bolds the selected text.

Italicizes the selected text.

= ~ =

Underlines the selected text.

Aligns the current block of text to the left margin.

Centers the current block of text.

Aligns the current block of text to the right
margin.

Aligns the current block of text to both the left,
and right margins.

Indents the current block of text.

.I*I.
m

Removes the indent on the current block of text.

.I+I.
i

. Formats the selected text as subscript text.

: Formats the selected text as superscript text.
= Formats the selected text as a numbered list.
— Formats the selected text as a bulleted list.
Ay Changes the color of the selected text.

-

s Changes the background color of the selected
: text.
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Button Description

0 Undoes the previous action.

¢ Undo does not apply to actions taken by
using the right-click menu.

* Undo does not apply to changes made to
tables.

* Some browsers might not let you undo the
modification of background color.

Restores the action that had been undone.
Inserts an image.

Turns the selected text into a hyperlink.

H ® B 2

Inserts a table from your clipboard. The table
can be in HTML, RTF, or Microsoft Word format.

=
=
Ial

Checks spelling.

Displays the HTML source for the text.

LAl

Create a new form

When you create a new form, the form is based on a template that determines the form’s fields.
Developers create form templates by using EMC Documentum Forms Builder. To use form
functionality, you must be assigned the user role of form_user, which is defined by the Forms DocApp.

To create a form:

1
2
3
4.
5
6

Navigate to where the form will be created.

Select File > New > Form.

In the Form Name field, enter a name for the new form.

In the Template field, select the form template used to create the form.
Click Next.

To enter data in the form, see Enter data in a form, page 145.
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Save As functionality

The File > Save As functionality in Webtop is enabled only when you work with Forms. This
functionality allows you to save a new Form instance with the same set of permissions.
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Chapter 11

Records

Declaring electronic or physical documents as
formal records

Instructions in this section are intended to declare formal records. Formal records can be both

DoD formal record types and regular formal records which do not have to be DoD compliant.
Although you can use these instructions to declare any formal record type, the attributes on each

of the respective forms are described separately. The attributes on the regular formal record form
(dmc_rm_formal_record) are described in this section, the subsection that immediately follows the
instructions Entering values on the formal records form, page 154. See the EMC Documentum Records
Client User Guide for more information. All four formal record form types are listed in the appendix.

Note: Formal records when they are being declared can also be related to another formal record using
the Create Record Relationship button at the bottom of the form. It is available for your convenience
to create record relationships as well when you declare a formal record. You do not have to follow

one process to declare a formal record and then follow another process to create a record relationship.

Users must select the appropriate form to declare a formal record, if DoD functionality is available. All
records, except typical records, must be associated to a form and declared to a valid file plan location.

Declaring a document, physical document or electronic document or both as well as email, as a
formal record means you are creating a snapshot of one or more source documents to capture all
information, content and metadata, in a VDM at a particular point in time. To find out more about
physical documents or physical objects in general, refer to the "part" of this document (or, in online
help) that covers Physical Records Manager. Newer versions of the same source documents can be
declared again when needed though the newer version of the original source document will be
associated to the new formal record.

To declare email and electronic or physical documents or both as formal records:

Using these instructions you can declare electronic content, email content (if it is already in a DCTM
repository), and physical content as formal records or as specialized formal records that adhere to
DoD standards.

Note: Emails can be declared using the Records Client according to these instructions or using
Records Activator for Microsoft Outlook if it is available. Emails declared directly from Records
Activator for Microsoft Outlook are saved in the repository in EMCMF format (and are converted
from MSG format automatically during the filing process). Emails manually declared from the EMC
Documentum Records Client or Webtop client, according to these instructions, must be exported
from Microsoft Outlook and then imported into a DCTM repository. The format is converted
automatically during import.

1. Navigate to the location of the document or email to be declared and select it in the content pane.
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Note: Although you can select more than one item and declare them individually or grouped
according a particular record type, you cannot declare them as different record types. You would
have to declare them independently to file each as a different record type.

2. Click Records > Declare Formal Record. One of the two following screens is displayed depending
on whether you have selected one or multiple items.

The screen displayed for multiple documents selected is slightly different from that displayed for
one single record or individual records from the documents selected. It includes an optional field
to make one record or individual records of the documents selected.

Figure 5. Create tab displayed for declaring one item

Declare Formal Record: Create

l. Create

To create a formal recard, pleaze choose a location in the File plan,

*File Plan:  Select

Figure 6. Create tab displayed for declaring more than one item

Declare Formal Record: Create

. Create

To create a formal record, please choose a location in the File plan,

Declare selected documents as:
% |ndividual records

i~ Ore recard

*File Plan:  Select

150 EMC Documentum Webtop Version 6.8 User Guide



Records

Note: Optionally, you can change the default setting for Declare selected documents as from
Individual records to One record if you have multiple documents selected.

3. Click Select next to the File Plan entry and select a valid file plan, a cabinet or a folder, from the
locator screen displayed. The valid choices are managed container objects that have at least one
policy applied to it.

Note: If a Classification Subscription List (CSL) was created, users can select its icon in the
Choose a folder locator screen to select a shortcut to the filing location. This saves users from
having to find the desired location each time a record is declared.

Figure 7. Classification subscription lists

Choose a folder :

DoDw3_TestingRepo/  CL31

M {Starts with

Al File Plan

Hame

E FormalRec

items per page: | 100 v

Valid cabinets and folders are highlighted to differentiate them from those that are not valid
choices. Valid choices could also be buried in a container that is not valid. A valid folder for
example could be buried in a cabinet that is not valid/managed. A folder might not be selectable
for any of the reasons described in the following table:

Table 18. Reasons why a folder cannot be selected

Reason Notes

Container is closed By default, containers are open.
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Reason Notes

No policies are applied to the container. Any one of the following policies is sufficient:

* retention

® security

¢ containment

® naming

* any security marking (security level, shared

marking, restrictive marking)

No retention policy applied and the system By default, a retention policy does not need to
setting requires a retention policy be applied. This setting can be changed on the
RPS configuration object.

Security policy is applied and the RM
extended permission of "Link" is not granted
on the folder.

Note: A dm_folder that a login user owns does not show up in the Mine list of the file plan locator
when its modify date is older than the time interval configured for the Mine list. The Mine list in
the file plan locator contains all the objects of type dm_folder and/or its subtypes that the login
user owns and that were modified by the login user in the last seven days from the current date.
The time interval, seven days by default, is configured in the WDK component, MyObjectLocator.

4. Click OK to accept the location for the selected file plan.

The locator screen closes while the Declare Formal Record screen is refreshed displaying the
selected file plan and some additional attributes. Additional attributes include:

¢ Type, mandatory
¢ Form Template, mandatory
¢ Unlink source documents, optional

¢ Show options, optional
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Figure 8. Declare formal record

Declare Formal Record: Create

1. Create

To create s formal record, please choose alocation in the File plan,

Declare selected documents as: {E} Individual records
21 one record
*File Plan: lect SBADS
T Type: Formal Record(dme_rm_formal_record) <,

Formal Recordidme_rm_formal_record)
Record DoDE015 W3 Standardidme_rm_dodB0 153 _std_rec)
Unlink source documents: [ Record DeDE01 5 V3 Classified{dmc_rm_dod 50153 _class_rec)

*Form Template:

[+] 5how options

5. Select the formal record Type you want to declare.

The value for the Form Template is automatically populated according to the value selected for
the Type.

Note: Only the Email Record and Formal Record forms are displayed in the list box when email

records are declared.

Figure 9. Email record form

*Type: - Record DoD%015 W3 Emalidmc_rm_dodb015v3_email_rec) |

* Form Template: - Emai Record Dol 5015 V3 (W

6. Optionally, you can select the checkbox to Unlink source documents only if you want to allow
anyone with Unlink privileges to remove the source documents from its original location after it
has been declared a formal record.

7. Optionally, you can subscribe to the selected folder in the file plan by clicking Show options and
selecting the checkbox next to Subscribe to this file. A shortcut is added to the Subscriptions
node to facilitate access for frequent access.

8. Click Continue to fill out the form displayed according to the Form Template selected.
Refer to Entering values on the formal records form, page 154 to enter values on the formal
records form.
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It is a clear indication that you are declaring multiple documents as Individual records when
the top of the form indicates 1 of a number.

9. Click Finish when you are done filling out the form. Clicking Cancel backs out the entire process.

Entering values on the formal records form

Refer to this section if you are declaring a document as a formal record according to the
"dmc_rm_formal_record" form type. The table following the sample form, depicted in the figure,
describes each of the attributes on the form.

Next is displayed at the bottom of the form only when you select more than one item to be declared
as Individual records. You do not have to click Next. You can click Finish to apply the same
metadata to the remaining records. You only click Next if you want each individual record to have
different metadata when filing.

Figure 10. Default settings on a form for formal records

Info : AAa{?).doc (File 1 of 2)

* Hame: |.n..na||;21.cr-:|c

Subject: | |

Authors:

Insert| Deete|

Cieate Record Relationship |

Previous

All mandatory fields require entries to proceed with filing. Any field that is incorrectly addressed
prevents the form from being processed. Unaccepted entries are clearly described in red text at the
bottom of the form when processing is prevented. Make sure to provide entries for all the mandatory
fields and that all the entries are valid.
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Table 19. Attributes for formal records

Attribute

(*) indicates mandatory attributes

Description

*Name

Subject

Authors

Keywords

Create Record Relationship

The name of the document is populated in this field
automatically if a single document was selected for the record.
If multiple documents were selected to be filed as a single
record, Please Enter Record Name is displayed for this value.

Any value you type for this field is acceptable. The principal
topic addressed in a document could be used.

The value you type for this field should identify the author of
the document that is being declared a formal record.

You can Insert additional fields to identify more than one
author if necessary, though you are able to select only one
using the radio button. You can also delete additional fields
inserted by selecting the radio button and clicking Delete.

Note: Each field inserted is reorganized, after the form is
saved, so that it appears under the field that had the radio
button selected.

The value you type for this field can be used to facilitate
searching. The metadata on a form associated to a particular
record can be used for keywords.

You can Insert additional fields to identify more than one set of
keywords if necessary, though you are able to select only one
using the radio button. You can also delete additional fields
inserted by selecting the radio button and clicking Delete.

Note: Each field inserted is reorganized, after the form is
saved, so that it appears under the field that had the radio
button selected.

Displays a page that allows you to choose the record
relationship type. On this page there is also a locator that
allows you to connect the record being declared to another as a
child or as a parent using the selected relationship type.

Entering values on the applicable DoD form when
declaring DoD formal records

This section describes the attributes on the forms used to declare DoD formal records. The button at
the end of each form Create Record Relationship is available to create a record relationship with
other objects whenever it is necessary. You can, when necessary, immediately relate the formal record
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being declared to another object, without having to follow a separate process. Select the applicable
section for the DoD record type you are declaring:

* Entering values on the DoD standard records form, page 157, DoD compliant form without
classification attributes

* Entering values on the DoD email records form, page 161, DoD compliant form for email

¢ Entering values on the DoD classified records form, page 164, DoD compliant form with
classification attributes

Though custom forms could be listed among the choices, only those forms available out-of-the-box
are described.

All mandatory and optional fields for each attribute are described in the applicable section depending
on the form you are using to declare a formal record.

Note: Although entries are required in the mandatory fields to process the form, the optional fields
can be addressed later from the Properties of the form.
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Entering values on the DoD standard records form

Refer to this section if you are declaring standard formal records. The table following the sample
form, depicted in the figure, describes each of the attributes on the form.

Figure 11. Default settings on a form for standard formal records

Info : Ada{Z).doc (File 1 of 2)

-~

Rarsord Dol 50015 VF Srandand

* Fecord Hame: a7 oo |
* dubject: | |

* Madia Type: A
T Application e
Format: )
" Diginating | |
O ganization: )

[t Filead: | W, 00 LE 1208 E |
Meceived Date: 4. ]E LM |
* Publication Date: [y, 30, 2008 ;@ FET |

* Upiqua Record |00 T |
hlszntilie -

Fecard Catogory |

Wantilier; |
o Same

Wital Record:
Authors;

] ]

L]

Promary Addiessees:

Inaet| Doicte

|
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It § Finialy | Cancel

Next is displayed at the bottom of the form only when you select more than one item to be declared
as Individual records. You do not have to click Next. You can click Finish to apply the same
metadata to the remaining records. You only click Next if you want each individual record to have
different metadata when filing.

All mandatory fields require entries to proceed with filing. Any field that is incorrectly addressed
prevents the form from being processed. Unaccepted entries are clearly described in red text at the
bottom of the form when processing is prevented. Make sure to provide entries for all the mandatory
fields and that all the entries are valid.

Table 20. Attributes for standard records

Record DoD 5015 V3 Standard (dmc_rm_dod5015v3_std_rec)

Attribute Description

(*) indicates mandatory
attributes

*Record Name The name of the document is populated in this field automatically if
a single document was selected for the record. If multiple documents
were selected for a single record, Please Enter Record Name is
displayed for this value.

*Subject Any value you type for this field is acceptable. The principal topic
addressed in a document could be used.
Confirm with your Records Administrator how this field is defined in
your organization.

*Media Type The value you select identifies the material or environment on which
information is inscribed (microfiche, electronic, and paper for example).

The values are created by your Records Administrator.

Confirm with your Records Administrator how this field is defined in
your organization.
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Record DoD 5015 V3 Standard (dmc_rm_dod5015v3_std_rec)

Attribute

(*) indicates mandatory
attributes

Description

*Application Format

*Originating
Organization

Date Filed

Received Date

*Publication Date

*Unique Record
Identifier

Record Category
Identifier

Vital Record

The value you select identifies the format based on the application used
to create the document being declared a record.

The values are created by your Records Administrator.

Confirm with your Records Administrator how this field is defined in
your organization.

The value you type for this field should identify the official name or
code of the office responsible for the creation of the document being
declared.

Confirm with your Records Administrator how this field is defined in
your organization.

The value for this field is automatically populated when a document is
declared a formal record.

The value you type or select from the date control button could be the
date you received the document. The value you select from the date
control button populates the left field with the date and the right field
with a default time set to 12:00 AM. You can also position the cursor
in either field to change the values manually.

Confirm with your Records Administrator how this field is defined in
your organization.

The value you type or select from the date control button could be the
publication date of the document. The value you select from the date
control button populates the left field with the date and the right field
with a default time set to 12:00 AM. You can also position the cursor
in either field to change the values manually.

Confirm with your Records Administrator how this field is defined in
your organization.

Read-only field, pre-populated (system generated) to identify the
record object.

This field is automatically populated based on the applied naming
policy.

The checkbox is Read Only and indicates if the document being
declared was marked as a Vital record using the retention markup
feature of RPS. This is set when a retention markup with the Vital
designation is applied.
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Record DoD 5015 V3 Standard (dmc_rm_dod5015v3_std_rec)

Attribute

(*) indicates mandatory
attributes

Description

*Authors

Keywords

Primary Addressees

Other Addressees

Locations

Project Name

Supplemental Marking

Create Record

Type in the name of the person(s) who authored the document that is
being declared a formal record.

You can Insert additional fields to identify more than one author

if necessary, though you are able to select only one using the radio
button. You can also delete additional fields inserted by selecting the
radio button and clicking Delete.

Type in text that can be used to facilitate searching. The metadata on a

form associated to a particular record can be used for keywords.

You can Insert additional fields to identify more than one set of
keywords if necessary, though you are able to select only one using the
radio button. You can also delete additional fields inserted by selecting
the radio button and clicking Delete.

Type in the primary name of individual or individuals who authored
the document.

Confirm with your Records Administrator how this field is defined in
your organization.

Type in the names of anyone else responsible who can address
questions if necessary.

Confirm with your Records Administrator how this field is defined in
your organization.

Type in the name of the location to indicate where the record is kept.
Confirm with your Records Administrator how this field is defined in
your organization.

Select the attribute marking(s) from this attribute marking set that
provides the amount of security needed to access the record by those
members in the group tied to a particular attribute marking.

Add supplemental markings to add additional security to the object.
Displays a page that allows you to choose the record relationship type.

Relationship On this page there is also a locator that allows you to connect the record
being declared to another as a child or as a parent using the selected
relationship type.

160 EMC Documentum Webtop Version 6.8 User Guide



Records

Entering values on the DoD email records form

Refer to this section if you are declaring email formal records. The information here is applicable
whether you declare email records directly from Records Activator for Microsoft Outlook or from the
Records Client. The table following the sample form, depicted in the figure, describes each attribute
on the form. Administrators can customize email optional mappings, if necessary.

Figure 12. Default settings on a form for email formal records
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Emails declared from the Records Client must first be exported from Microsoft Outlook and then
imported into a DCTM repository. Emails in their original MSG format when imported into DCTM
are automatically converted to EMCMF during import. Two files must be modified first for the
conversion to work.

Next is displayed at the bottom of the form only when you select more than one item to be declared
as Individual records. You do not have to click Next. You can click Finish to apply the same
metadata to the remaining records. You only click Next if you want each individual record to have
different metadata when filing.

All mandatory fields require entries to proceed with filing. Any field that is incorrectly addressed
prevents the form from being processed. Unaccepted entries are clearly described in red text at the
bottom of the form when processing is prevented. Make sure to provide entries for all the mandatory
fields and that all the entries are valid.

Table 21. Attributes for email records

Record DoD 5015 V3 Email (dmc_rm_dod5015v3_email_rec)

Attribute Description

(*) indicates mandatory

attributes

*Record Name The name of the document is populated in this field automatically if
a single document was selected for the record. If multiple documents
were selected for a single record, Please Enter Record Name is
displayed for this value.

*Subject Any value you type for this field is acceptable. The principal topic

addressed in a document could be used.

Confirm with your Records Administrator how this field is defined in
your organization.
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Record DoD 5015 V3 Email (dmc_rm_dod5015v3_email_rec)

Attribute

(*) indicates mandatory

attributes

Description

*Media Type

*Application Format

*Originating
Organization

Date Filed

Received Date
*Publication Date

*Unique Record
Identifier

Record Category
Identifier

Vital Record

*Authors

EMC Documentum Webtop Version 6.8 User Guide

The value you select identifies the material or environment on which
information is inscribed (microfiche, electronic, and paper for example).

The values are created by your Records Administrator.

Confirm with your Records Administrator how this field is defined in
your organization.

The value you select identifies the format based on the application used
to create the document being declared a record.

The values are created by your Records Administrator.

Confirm with your Records Administrator how this field is defined in
your organization.

The value you type for this field should identify the official name or
code of the office responsible for the creation of the document being
declared.

Confirm with your Records Administrator how this field is defined in
your organization.

The value for this field is automatically populated when an email is
declared a formal record.

The value for this is mapped to the "Received" date of the email.
The value for this is mapped to the "Sent date" of the email.

Read-only field, pre-populated (system generated) to identify the
record object.

This field is automatically populated based on the applied naming
policy.

The checkbox is Read-Only. The checkbox is selected if the folder
to which you are declaring the record has Vital on it, which means
that this record will inherit it. You cannot select or deselect this box,
it only displays if a vital marking (applied directly or indirectly) is
on the object.

Read-Only value that is mapped to the "From" field of the email.
You can Insert additional fields to identify more than one author
if necessary, though you are able to select only one using the radio

button. You can also delete additional fields inserted by selecting the
radio button and clicking Delete.
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Record DoD 5015 V3 Email (dmc_rm_dod5015v3_email_rec)

Attribute

(*) indicates mandatory
attributes

Description

Keywords

Addressee(s)
Other Addressees
Hidden Addressees

Location

Project Name

Supplemental Marking

Create Record
Relationship

Type in text that can be used to facilitate searching. The metadata on a
form associated to a particular record can be used for keywords.

You can Insert additional fields to identify more than one set of
keywords if necessary, though you are able to select only one using the
radio button. You can also delete additional fields inserted by selecting
the radio button and clicking Delete.

Read-Only value that is mapped to the "To" field of the email.
Read-Only value that is mapped to the "CC" field of the email.
Read-Only value that is mapped to the "BCC" field of the email.

Type in the name of the location to indicate where the record is kept.
Confirm with your Records Administrator how this field is defined in
your organization.

Select the attribute marking(s) from this attribute marking set that
provides the amount of security needed to access the record by those
members in the group tied to a particular attribute marking.

Add supplemental markings to add additional security to the object.

Displays a page that allows you to choose the record relationship type.
On this page there is also a locator that allows you to connect the record
being declared to another as a child or as a parent using the selected
relationship type.

Entering values on the DoD classified records form

Refer to this section if you are declaring a document as a classified record. The table following the
sample form, depicted in the figure, describes each attribute on the form.
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Figure 13. Default settings on a form for classified formal records
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Note: Update the classified form template if your system does not use Unclassified as the lowest
security level. Record DoD 5015 V3 Classified (dmc_rm_dod5015v3_classified_rec) out-of-the-box
supports Unclassified as the lowest security level. Instructions to complete the update are provided
in the note at the top of the section for Declaring electronic or physical documents as formal records,
page 149.

Next is displayed at the bottom of the form only when you select more than one item to be declared
as Individual records. You do not have to click Next. You can click Finish to apply the same
metadata to the remaining records. You only click Next if you want each individual record to have
different metadata when filing.
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All mandatory fields require entries to proceed with filing. Any field that is incorrectly addressed
prevents the form from being processed. Unaccepted entries are clearly described in red text at the
bottom of the form when processing is prevented. Make sure to provide entries for all the mandatory
fields and that all the entries are valid.

Classified Records all have a security level, of which the lowest level is Unclassified. A default
security level or ranking of "0" represents a classification of Unclassified for declassified records.
Classified records can be downgraded from Top Secret to Secret for example; the downgrade feature
however does not allow downgrading to Unclassified. A classified record that is downgraded to
Unclassified must be declassified using Declassify On, Declassify On Date, and Declassify On Event.
Classified and unclassified records can also be upgraded when necessary.

The form makes it possible for you to:

* create a classified record while deriving values from a classification guide or from another
classified record already present in the system

¢ change classification settings to upgrade or downgrade the record

¢ schedule downgrades and declassification

* declassify classified records or turn unclassified records into classified records

¢ identify reviewers if needed

Note: Values required to create classified records can be derived from classification guides which
act as a template to facilitate the process. If no classification guides are available, end users must
contact their Records Administrator.

Some optional attributes are conditional and become mandatory only when classified records are
declared. The Classifying Agency for example, is optional if the security ranking for the Current
Classification is set to Unclassified. A value other than Unclassified makes the Classifying Agency
mandatory.

All mandatory fields require entries to proceed with filing. Any field that is incorrectly addressed
prevents the form from being processed. Unaccepted entries are clearly described in red text at the
bottom of the form when processing is prevented. Make sure to provide entries for all the mandatory
fields and that all the entries are valid.

Table 22. Attributes for classified records

Record DoD 5015 V3 Classified (dmc_rm_dod5015v3_classified_rec)

Attribute Description

(*) indicates mandatory

attributes

*Record Name The name of the document is populated in this field automatically if
a single document was selected for the record. If multiple documents
were selected for a single record, Please Enter Record Name is
displayed for this value.

Record Category This field is automatically populated based on the applied naming

Identifier policy.
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Record DoD 5015 V3 Classified (dmc_rm_dod5015v3_classified_rec)

Attribute

(*) indicates mandatory

attributes

Description

*Subject

*Media Type

*Format

*Originating
Organization

Date Filed

Received Date

*Publication Date

*Unique Record
Identifier

Vital Record Indicator
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Any value you type for this field is acceptable. The principal topic
addressed in a document could be used.

Confirm with your Records Administrator how this field is defined in
your organization.

The value you select identifies the material or environment on which
information is inscribed (microfiche, electronic, and paper for example).
The values are created by your Records Administrator.

Confirm with your Records Administrator how this field is defined in
your organization.

The value you select identifies the format based on the application used
to create the document being declared a record.

The values are created by your Records Administrator.

Confirm with your Records Administrator how this field is defined in
your organization.

The value you type for this field should identify the official name or
code of the office responsible for the creation of the document being
declared.

Confirm with your Records Administrator how this field is defined in
your organization.

The value for this field is automatically populated when a document is
declared a formal record.

The value you select could be the date you received the document.
Confirm with your Records Administrator how this field is defined in
your organization.

The value you select could be the publication date of the document.
Confirm with your Records Administrator how this field is defined in
your organization.

Read-only field, pre-populated (system generated) to identify the
record object.

Read-Only checkbox. If checked it means that the document being
declared has an applied retention markup with the Vital designation.
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Record DoD 5015 V3 Classified (dmc_rm_dod5015v3_classified_rec)

Attribute Description

(*) indicates mandatory
attributes

*Authors Type in the name of the person(s) who authored the document that is
being declared a formal record.

Click Insert if you need to specify additional values for this attribute.
Delete removes the field which has its radio button selected. Though
you can insert more than one field to create a list of possible choices,

only one radio button can be selected.

Keywords Type in text that can be used to facilitate searching. The metadata on a
form associated to a particular record can be used for keywords.

Click Insert if you need to specify additional values for this attribute.
Delete removes the field which has its radio button selected. Though
you can insert more than one field to create a list of possible choices,
only one radio button can be selected.

Addressees Type in the primary name of individual or individuals who authored
the document.

Confirm with your Records Administrator how this field is defined in
your organization.

Click Insert if you need to specify additional values for this attribute.
Delete removes the field which has its radio button selected. Though
you can insert more than one field to create a list of possible choices,
only one radio button can be selected.

Other Addressees Type in the names of anyone else responsible who can address
questions if necessary.

Confirm with your Records Administrator how this field is defined in
your organization.

Click Insert if you need to specify additional values for this attribute.
Delete removes the field which has its radio button selected. Though
you can insert more than one field to create a list of possible choices,

only one radio button can be selected.

Locations Type in the name of the location to indicate where the record is kept.

Confirm with your Records Administrator how this field is defined in
your organization.

Click Insert if you need to specify additional values for this attribute.
Delete removes the field which has its radio button selected. Though
you can insert more than one field to create a list of possible choices,
only one radio button can be selected.
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Record DoD 5015 V3 Classified (dmc_rm_dod5015v3_classified_rec)

Attribute

(*) indicates mandatory
attributes

Description

Derived From

Other Sources

Project Name

Supplemental Marking
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Classification fields for a classified record can be derived, that is
populated automatically from a Classification Guide or from an
Original Classified Record. They can also be populated manually

if the radio button for none is selected. In either case, whether you
select the radio button for a Classification Guide or for an Original
Classified Record, you must select an item from the respective list box.

The following classification fields will copy their values to the form:

¢ Initial Classification

* Declassify On

¢ Declassify On Date

¢ C(lassified By

* Supplemental Marking
* Project Name

¢ Exemption Category

* Reason For Classification

All of these populate the form in both cases, using a Classification
Guide or an Original Classified Record.

The text box for this attribute lets you describe other sources you might
use or reference to obtain values if you do not derive them from a

classification guide or from an original classified record. You can Insert
and Delete text boxes as necessary to define more than one other source.

Select the attribute marking(s) from this attribute marking set that
provides the amount of security needed to access the record by those
members in the group tied to a particular attribute marking.

Select the attribute marking(s) from this attribute marking set if you
need additional security on top of existing security.
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Record DoD 5015 V3 Classified (dmc_rm_dod5015v3_classified_rec)

Attribute Description

(*) indicates mandatory
attributes

Downgrade on Schedule The following options are added to the bottom of the form when you
select the checkbox for this attribute:

* Downgrade On

* *Downgraded On Date

* *Downgraded On Event
e Target Downgrade Level
* *Downgrade Instructions
¢ Downgraded On

* Downgraded By

Note: Fields identified with an asterisk are conditional, which can be
optional or mandatory based on the trigger selected for Downgrade
On.

Downgrade is not applicable to unclassified records (which already
have the lowest security ranking of Unclassified equal to "0").

Downgrade On Use this option to identify the trigger that will be used to start the
downgrade. Though there are 3 triggers (Date, Event, and Date and
Event) in the list, a fourth item in the list is left blank to allow for a
manual downgrade.

Note: Though some of the options are conditional depending on the
trigger selected, only those options that become mandatory need to
be filled.

Downgrade On Date Specify the date you want the downgrade to be done on if the trigger
includes a date.
This field is conditional, it becomes mandatory only if you select Date
or Date and Event for the trigger.

Downgrade On Event Specify the event you want the downgrade to be done on if the trigger
includes an event.
This field is conditional, it becomes mandatory only if you select Event
or Date and Event for the trigger.

Target Downgrade Level You can only downgrade to any level lower than the current security
level but not all the way to Unclassified as this is declassifying which
is done differently on the form.
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Record DoD 5015 V3 Classified (dmc_rm_dod5015v3_classified_rec)

Attribute

(*) indicates mandatory
attributes

Description

Downgrade Instructions

Downgraded On

Downgraded By
Upgrade

Upgraded On

Upgraded By
Reasons for Upgrade

Review

Reviewed On

Reviewed By

*Initial Classification

*Current Classification
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Specify instructions for the downgrade.
This field is conditional, it becomes mandatory regardless of the trigger
selected unless no trigger is specified.

Read-Only field that is automatically populated when the downgrade
is processed.

Select any user from the list.

The following options are added to the bottom of the form when you
select the checkbox for this attribute:

e Upgraded On

e Upgraded By

* Reasons for Upgrade

The value for this field is automatically populated when the upgrade is
processed.

Add the name of the user.

Choose the radio button next to the preferred method to specify the
value and complete the entry.

The following options are added to the bottom of the form when you
select the checkbox for this attribute:

e Reviewed On

* Reviewed By

Note: Reviewed By is mandatory only when a date is specified for
Reviewed On.

Specify the date and time the review was completed, if a review was
involved.

Enter the name of the reviewer(s). This field is mandatory only if a
review date is specified.

The value for this field is automatically populated if values are derived
from a source such as Classification Guides or Original Classified Records.
Regardless of the source that values are derived from, you can reset
the value as needed.

The value for this field is automatically populated if values are derived
from a source such as Classification Guides or Original Classified Records.
Regardless of the source that values are derived from, you can reset
the value as needed.

EMC Documentum Webtop Version 6.8 User Guide



Records

Record DoD 5015 V3 Classified (dmc_rm_dod5015v3_classified_rec)

Attribute Description

(*) indicates mandatory
attributes

Classifying Agency Type the name of the classifying agency when you are creating a
classified record.

Confirm with your Records Administrator how this field is defined in
your organization.

Classified By This field becomes mandatory when creating a classified record when
the Current Classification is higher than Unclassified. It is otherwise
optional when creating unclassified records.

Select the radio button next to the means by which to specify a valid
user for this value. You can choose to select from a list or type in the
value.

Confirm with your Records Administrator how this field is defined in
your organization.

Reasons for Select from a list of valid values the reason for creating a classified

Classification record if a classification guide is not specified for Derived From or if
one is selected but has no value specified to automatically populate
this field.

You can change the default value set by the classification guide if
necessary.

Declassify On Select from the list of triggers the trigger needed to initiate
declassification for classified records. Although a blank is included
among the options in the list box, the other 4 options for the triggers are:

* Exemption Category and Date

e Manual Date

Event

Date and Event

Auto Calculated Date

Auto-calculated date takes the Publication Date entered on the form
and adds the Declassification threshold to generate the declassification
date.

Classified records at some point in time should be declassified. A
blank is included among the triggers as the value to be selected
for unclassified records when the Current Classification specifies
Unclassified.
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Record DoD 5015 V3 Classified (dmc_rm_dod5015v3_classified_rec)

Attribute Description

(*) indicates mandatory
attributes

The value for this field could be automatically populated according
to a classification guide if one is selected for Derived From. You can
change the value as needed.

This field cannot be automatically populated if Declassify On on the
classification guide selected is not given a value.

*Declassify On Date This field is mandatory if the declassifying trigger selected for
Declassify On is set to the Date or the Date and Event.

Declassify On Event This field is mandatory if the declassifying trigger selected for
Declassify On is set to the Event or the Date and Event.

Exemption Category Select from a list of valid values the exemption category if a
classification guide is not specified for Derived From or if one is
selected but has no value specified to automatically populate this field.

The exemption category is required if you select a declassification
date that exceeds the declassification threshold (in other words the
records would normally be declassified by a certain date but you are
asking for an extension).

You can change the default value set by the classification guide if
necessary.

A value other than classification guides selected for Derived From
makes this field read-only.

Declassified On Read-Only value that displays the time and date that the record was
declassified on (either manually or automatically by the declassification
job).

Declassified By Read only that identifies the person who performed the declassification
or the account associated with the job.

Create Record Displays a page that allows you to choose the record relationship type.

Relationship On this page there is also a locator that allows you to connect the record
being declared to another as a child or as a parent using the selected
relationship type.

Viewing document record associations

Use this feature to determine if a document has ever been declared a formal record. Each formal
record declared against a particular document is called a formal record association. A document can
be declared a formal record more than once if necessary.
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To view formal record associations:
1. Navigate to a document in the file plan under Cabinets.

2. Right-click the document displayed in the content pane and click View > Formal Record
Associations.

The screen refreshes to display all of the formal records that contain the object in question.

Linking a record

You can only link records in an open folder or a reopened folder. You must open the folder first, if it
was closed, in order to link a record in there. You may link a record stored in one policy managed
folder to another policy managed folder if the record needs to be regulated by more than one policy
managed folder. Records in linked instances inherit policies from all folders.

You can link a record from one policy managed folder to another policy managed folder, in the
same file plan or to another policy managed folder in another file plan, only if the policy managed
folder selected is in an open state. Linking a record to a policy managed folder that has been closed
(Records > Close Folder) is not permitted. For further details about link levels and containment
policies, refer to "About containment policies".

To link a record to an open folder or to a file plan

1. Navigate to and select the record.

2. Select Edit > Add To Clipboard.

3. Navigate to the folder or file plan to which to link the record.
4. Select Edit > Link here.

Creating and viewing record relationships

The object selected in the content pane might not be eligible for a record relationship depending on
the available record relation definitions in the Record Relation Definitions node. The Relation
Name (relation type) used to define the rules against the parent and child objects can prevent a

user from creating the relationship. The objects selected for a relationship must match the rules. If
the rule specifies that both the parent and the child have to be formal records, then anything else
selected prevents the relationship from being created. Only those record relation definitions in the
Record Relation Definitions node are available (filtered) in the list box, when you Create a Record
Relationship, if the parent and child selected match the rules. Swapping the parent and the child in a
record relationship could change filtering when they have different rules. The number of Record
relation definitions in the list box for example could be more or less. The user must also be a member
of the Creation Group Name selected for the Record Relation Definition being used. Only those
record relation definitions appear in the list box that the user has been added to.
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To create record relationships:

Note: A record relation definition is required to create a record relationship. Administrators can
verify and if necessary create the desired relation definition in the Record Relation Definitions node.
Record relation definitions available out-of-the-box include:

* Cross-reference Relationship

¢ Internal Email Attachment Relationship
* Supersede Relationship

* Supporting Relationship

* Suspend Relationship

Suspend and supersede relationships can be created only when the objects involved are under
individual retention. To create a suspend or a supersede relationship between records in a file plan,
the file plan must be under individual retention.

Usage of record relation definitions is not limited to formal records only, they can be used with typical
records and even plain old documents that are not retained. The following table lists the parent and
child types that can participate in a record relation.

Table 23. Record relationship valid object types

Record Relation Parent Child

Cross-reference Relationship dm_sysobject dm_sysobject

Internal Email Attachment dmc_rm_formal_record dmc_rm_formal_record
Relationship

Supersede Relationship dm_document dm_document
Supporting Relationship dm_sysobject dm_sysobject

Suspend Relationship dm_document dm_document

1. Navigate to a formal record, under Cabinets for example, and click it in the content pane.

2. Select Records > Create Record Relationship.

176 EMC Documentum Webtop Version 6.8 User Guide



Records

Figure 14. Create a record relationship default screen

Create a Record Relationship :
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* Record relation definition : | Cross-reference Refationship b

* Objecttorelateto : Select

3. Select child or parent to create the appropriate end of the relationship that you are interested in.

4. Select the Record relation definition from the list box that represents the relationship type you
want to create. The list box is empty if there are no record relation definitions or if none of the
existing definitions have rules that match. You would have to create the desired record relation
definition if it is not already available and then return to this procedure. If you are not in an
administrator role, contact your records administrator.

5. Click Select to locate the formal record to relate to.

6. Click OK to complete the operation.

To view record relationships:

There are two ways to view record relationships: View > Record Relationships which users
and administrators can utilize and View > Record Relationship Definition Usages which only
administrators can utilize.

1. Navigate to one of the formal records involved in a record relationship.

Note: Administrators can also navigate to a record relation definition of interest, right-click it,
and select View > Record Relationship Definition Usages.

2. Right-click the formal record displayed in the content pane and select View > Record
Relationships.

The relation type is indicated under the Definition Name along with the records selected for
the Parent and the Child.
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Figure 15. Record relationships screen
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Removing a record relationship

Users and administrators must be able to view the parent and child to remove a record relationship.
They also require Browse permissions and must be in the Removal Group Name, as listed in

a record relation definition.

To remove a record relationship:

1. Navigate to a formal record and select it in the content pane.

2. Click View > Record Relationships.

3. Right-click the object listed and select Records > Remove Record Relationship.

If the record has multiple relationships, that is if more than one object is listed, right-click the
desired object and then select Records > Remove Record Relationship.

Making a library request

Make Library Request is the right-click option, or menu option, used to reserve one or more physical
objects for yourself or on the behalf of someone else.

Members of the following roles can make library requests:

* Physical Records Manager

¢ Library Administrator

¢ Library User

All physical objects selected for a library request must have at least READ permissions.
The value for the Name must be unique and is used to identify the library request.

The mandatory Contact information, is used to track who is requesting the item.

The value for the Date Requested is automatically set by default to 30 days from the day the library
request is made. The default setting for the Date Requested can be changed as needed.

The Notification Preference you select indicates the means by which to communicate with the
Physical Records Manager who can honor your request.
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The shipping option can be selected so that the physical objects are shipped to the contact directly.
Ship to Contact directly however, is disabled if the contact specified is not associated to an address.

The Shipping Address is mandatory. The value for the Shipping Address is automatically populated
if the shipping option is set to Ship to Contact directly and an address is associated with the contact
specified. Though the Shipping Address is automatically populated, if the contact specified is
associated to an address, it can be edited to specify a new or different address by selecting Ship

to address instead of Ship to Contact directly.

Regardless of the radio button selected for the shipping option, the checkbox for Send all at once can
also be selected if all items requested need to be sent together.

Options in the following screen shot show default settings. The next screen shot shows the default
settings when the contact for the logged in user is not associated to an address. Ship to Contact
directly is disabled. The Shipping Address is displayed only if you change the default setting for
the Shipping Options to either Ship to Contact directly or Ship to address. The Shipping Address
is automatically populated if Ship to Contact directly is selected. The Shipping Address must
otherwise be specified manually if Ship to address is selected. You can see the Shipping Address
revealed in the screen shot that follows this one.
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Figure 16. Screen displayed when the contact IS associated to an address

Make Library Request :

* Name: |
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Admin
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[] send a1 at once

Shipping Address: Edit
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This next sample screen shot changes the request such that it is being made for someone else, as the
For me checkbox is deselected leaving it up to you to specify a contact, whether from an existing
list or by adding a new contact. The New contact button is only displayed if the user is a Retention
Manager. Only retention managers can create new contacts on the fly. If you click the button, a
new contact can be created.

Note: The contact is not removed if the library request is canceled.

If you choose Edit, a locator lets you select the contact for whom you are making the request for.
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Figure 17. Screen displayed when making the request for someone else if the user is a retention manager
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The interface assumes the reservation is being made for yourself when only one contact is associated
to you. You can tell that the reservation is for you when you see the For me checkbox displayed. The
value for the Contact is automatically populated and displayed along with a For me checkbox,
selected by default, for the logged in user only if the logged in user is already associated to exactly
one contact. The name or value for the Contact and the For me checkbox are otherwise not displayed,
as the system will not know which contact to display if you are associated to none or more than

one contact.

Deselect the For Me checkbox if you are making the library request for someone else. Then, click Edit
to specify the contact from an existing list of contacts or add the new contact name using the New
contact button (which is made available only if you are in the RPS Retention Manager role). The New
contact button, when displayed, facilitates specifying a new contact saving you the extra steps of
leaving this procedure to create a new contact. As well, the contact information will automatically be
filled in when you return from making the contact.

Note: The phone number provided for the Contact, if the Via Phone option is selected for the
Notification Preferences, is by default taken from the top of the list if the contact specified has
more than one number listed. The string of fives in the example illustrated below would be the
phone number used.
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Figure 18. Phone numbers listed for the Contact

Mew Contact: Info

1. Create

Hame: Warren

Email: Edit

Phone: Edit 555,555 BERE, God.666.6666, T77 777 77T7

Description:

User: Edit approwet ]

Address: Edit

The Phone numbers listed for the Contact can be rearranged as necessary when you select Edit.
Email listings are edited similarly. Each new number added however gets added to the bottom of
the list, as illustrated below, so if you want the new number to be used by default, make sure to
move it to the top of the list before you click OK. For example, if you want 777.777.7777 to be the
default number for the contact, move it to the top of the list and then click OK.
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Figure 19. Edit screen for phone numbers
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If you are making a request on behalf of another user, you need to select the contact from a list. The
requestor is defined to be the person who will be getting the item and is associated to an RPS contact.
As well, the contact must have an email address or be associated with a Documentum user.

The same physical object(s) can be requested by multiple library requests; the physical object(s) you
have requested can also be requested by others. Library requests are fulfilled at the discretion of the
administrator, not necessarily on a first come first served basis.

To make a library request (reservation):

1. Navigate to a physical object that you would like to reserve: typically a box, physical folder, or
physical document.

Contents in a container such as a box or physical folder are identified on the manifest for a library
request once the library request is created. Creating a library request for a box, for example, will
include any physical folder(s) and/or physical document(s) on the manifest if those physical
objects are in the selected box. The manifest only identifies the container if no other physical
objects are included in it.

N

Right-click the physical object and select Make Library Request.

You can select multiple physical objects, two boxes for example could be included in a single
library request, by selecting the two boxes and then right-clicking one of them to select Make
Library Request.
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Figure 20. Right-click options for a box
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The Make Library Request screen is displayed.

3. Enter values on the Make Library Request screen for the three mandatory attributes, and if
needed for the optional attributes, according to the following table:

Table 24. Attributes on the Make Library Request screen

Attribute Description

*Name Type a unique name so it can be identified when listed with other library
requests.

*Contact Use this attribute to make a library request for yourself or to make it

for someone else.

Deselect the For me option when making the request for someone else.
Click Edit if you need to add or change a contact.

Click the New contact button, revealed to Retention Managers only, if

you cannot find the needed contact from the existing list using Edit.

*Date Requested  The default value for this mandatory attribute is set to 30 days from
the current date. Pickup or shipment of requested items is expected
30 days from the day the request was made. You can change the
default setting as needed. You can change the default setting from
dmc_prm_docbase_config as needed.
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Attribute Description
Notification Select the preferred means of communicating.
Preference

Make sure that if you use the DCTM Inbox option that the contact is
associated with a DCTM user.

Shipping Options  Regardless of the radio button selected for the shipping option, you can
also select the checkbox to send all requested items at the same time,
limiting the request to only one charge-out. The default option is set
to Pickup. The Shipping Address is automatically populated if the
shipping option selected is Ship to Contact directly. You need to specify
the Shipping Address if the shipping option is Ship to address.

*Shipping Address The address locator or chooser is displayed when you click Edit.

Note Any additional instructions needed can be expressed.

The Choose an item screen is displayed when you click Edit for the Shipping Address. Only
address objects, if other objects are listed as well, are valid choices.

Figure 21. Choosing a shipping address

Choose an item:

Physical Locations/ Addresses

| Q
Hame Owner

123 Sezame 5t dme_rps_retentionmanager

B1 Tours rmadmin

ﬁ bin rmadmin

ﬁ Binz rmadmin

ﬁ Bina rmadmin

B Boxz rmadmin

ﬁ Phwzical Bin rmadmin

t. Phwzical Folder rmadmin

m uza rmadmin
Warkzpace Customizations rmadmin

4. Click Finish on the Make Library Request screen to accept the values entered.

The new library request is now displayed in the content pane under Library Requests. The
value for the Current State is Submitted and remains so until the library request is converted
to a charge-out.
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View/edit a library request

You must be in one of the following roles to view or edit a library request:

* Physical Manager

¢ Inventory Manager

¢ Library Administrator
¢ Library User

You can view and edit values associated with a library request from its Properties.

To view or edit a library request:
1. Navigate to Physical Records Manager > Library Requests.

2. Right-click the library request listed in the content pane and select Properties.
The Properties screen is displayed displaying the Info tab by default.
The Properties screen for library requests includes tabs for:

e Info

¢ Requested Items

¢ Pending Items

* Associated Charge-outs

* History

3. Click the tab you want to view or edit.

4. Click OK to accept all changes if any. Click Cancel, when necessary, to ignore any unintended
changes.

Click OK or Cancel if no changes were made.
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Virtual Documents

Virtual documents overview

A virtual document is a file that contains one or more files nested within it. The virtual document is
also called the parent document, and the files within it are called descendants or children.

For example, you could create a virtual document for a book, and populate the virtual document
with the files that comprise the book’s chapters. Each chapter is a separate file that is nested within
the parent document.

The files nested in a virtual document can themselves be virtual documents. This means you can
have multiple levels of nesting.

When you check out a virtual document, you can select whether to check out only the parent
document, or check out the parent document, and its descendants.

When you view a virtual document, you can select whether to view the document’s structure or its
content. When you view its structure, Virtual Document Manager (VDM) opens to display the
virtual document’s descendants.

A virtual document can contain descendants of different file formats. For example, a Microsoft Word
file could be the parent file, and its descendants could be an Excel spreadsheet, and TIFF image.

You can add, remove, and rearrange descendants in a virtual document. You can convert a virtual
document back to a simple document that contains no descendants.

Virtual documents are designated by this icon: B

Create a virtual document

To create a virtual document, you convert a simple document to a virtual document. This document
becomes the parent document, to which you can add descendants.

To create a virtual document:

1. Navigate to, and select the file to be converted.

2. Select Tools > Virtual Document > Convert to Virtual Document.

3. Add descendants, as described in Add a descendant to a virtual document, page 189.
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View the structure of a virtual document

When you view the structure of a virtual document, Virtual Document Manager (VDM) opens
to display the virtual document’s descendants. From VDM, you can add, remove, or change the
location of descendants within the virtual document. You can also perform standard file operations
on descendants by using the procedures you would use for any file in the repository.
To view the structure of a virtual document:
1. Navigate to the virtual document.

Select the virtual document.

2
3. Select Tools > Virtual Document > View Virtual Document.
4

To display the descendants in the navigation pane, do one of these:

¢ To display the next level of descendants, click the plus sign (+) next to the virtual document.
If a descendant is itself a virtual document, view its descendants by clicking its plus sign (+).

¢ To display all descendants, select the virtual document, and then select Display > Expand
selection

5. To simultaneously display both the repository directory structure, and the virtual document
structure, select Display > Show all.

To hide the repository directory structure, select Display > Show virtual document.

View the content of a virtual document

When you view the content of a virtual document, the content opens in an editing application.

If the repository includes XML functionality, and if you view an XML-based virtual document,
you can view both the parent, and descendants in a single, read-only file. If there is no content in
a virtual document, then Virtual Document Manager (VDM) automatically displays the virtual
document’s structure.

To view the content of a virtual document in read-only mode:

1. Navigate to the virtual document, and select it.

2. Select File > Open (Read Only).

Webtop does one of three things, depending on how your opening options are set in your virtual
documents preferences, as explained in Set your virtual document preferences, page 194.

3. Do one of these:

¢ If Webtop displays the document’s content, skip the rest of this procedure.

¢ If Webtop prompts you to select between content, and structure, select Open the content of
the document, and then click OK.

¢ If Webtop displays the document’s structure through VDM (instead of displaying its content
through an editing application), then select the document name within the header of VDM,
and then select File > Open (Read Only).
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Add a descendant to a virtual document

To add a descendant, you must have adequate permissions for accessing the parent document. You
can add the same document to a virtual document more than once.

To add a descendant to a virtual document:

1.

Do one of these:

¢ To select the descendant now, navigate to the descendant, and add it to your clipboard.

* To select the descendant later or to create a new file as the descendant, skip this step. You will
select the descendant later in this procedure.

Navigate to the parent document, and view its structure. For instructions on viewing the
structure, see View the structure of a virtual document, page 188.

Do one of these:

* To use a descendant from your clipboard, select Tools > Virtual Document > Add Child >
From Clipboard, then select the descendant, and then click OK.

¢ To navigate to the descendant in the repository, select Tools > Virtual Document > Add
Child > From File Selector, select the descendant, and click OK. For detailed steps see Locate
an item in a selection dialog box, page 21.

e To create a new file to be used as the descendant, select Tools > Virtual Document > Add
Child > Using New Document.

If the parent document is not already checked out to your computer, Webtop checks it out. If the
intended parent is not a virtual document, the system automatically converts the document to
a virtual document.

If you chose to create a new file to be used as the descendant, then create the new file by using the
standard procedure for creating a new file. Otherwise, skip this step.

Check in the parent document as follows:

a. Select the parent document.

b. Select Tools > Virtual Document > Save Changes.
c. Click OK.

d. Select checkin options, and click OK.

The new descendant is added as the last descendant in the parent document.

To add descendants by drag-and-drop:

1.
2.

Navigate to the parent document, and view its structure in the navigation pane.

In either the content pane or a new window, navigate to the files to add as descendants.
Note: To open a new window, select Tools > New Window.
Drag-and-drop the files from Step 2 to the appropriate location in the parent, dropping the

files by positioning your mouse pointer either high, low, or midway on an existing descendant,
as described in Table 25, page 190.

A shortcut menu appears.
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4. In the shortcut menu, select Add here.

The file is added to the parent document. If you did not select a specific location within the
descendants, the file is added as the last descendant in the document. If the intended parent is
not a virtual document, the system automatically converts the document to a virtual document.

If the parent document is not already checked out to your computer, Webtop checks it out.
5. Check in the parent document as follows:

a. Select the parent document.

b. Select Tools > Virtual Document > Save Changes.

c. Click OK.

d. Select checkin options, and click OK.

Table 25. Position of your mouse pointer when you use drag-and-drop in a virtual document

Mouse pointer Result

Position the mouse pointer high on the target The added files become the descendants that
file, as shown here. come before the target file in the order of

descendants.
Parent Document.rif

level-two :h1’l:j.I:J-:[§:i

Position the mouse pointer midway on the target The added files become descendants of the

file, as shown here. target file. If the target file is a simple document,
Webtop converts it to a virtual document.

Parent Document.rif

level-two :hild.tx%a

Position the mouse pointer low on the target, The added files become the descendants
as shown here. that come after the target file in the order of
d dants.
Parent Document.rif escendants
B level-two child.txt

Rearrange descendants in a virtual document

To reorder descendants in a virtual document:

1. Navigate to the virtual document, and view its structure, as described in View the structure
of a virtual document, page 188.)

2. Select the parent document.
3. Select Tools > Virtual Document > Reorder Children.

4. Select the descendant.
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10.
11.

Click Up or Down to move the descendant up or down in the list.
Repeat Step 4, and Step 5 for each descendant to be reordered.
Click OK.

If the parent document is not already checked out to your computer, Webtop checks it out.
Select the parent document.

Select Tools > Virtual Document > Save Changes.

Click OK.

Select your checkin options, and click OK.

To move descendants to other locations in a virtual document:

1.

Navigate to the virtual document, and view its structure, as described in View the structure of a
virtual document, page 188.

In either the tree pane or a new window, navigate to the descendant.

Note: To open a new window, select Tools > New Window.

Drag-and-drop the descendants to the appropriate location in the parent, dropping the
descendants by positioning your pointer either high, midway, or low on another descendant,
as described in Table 25, page 190.

A shortcut menu appears.

In the shortcut menu, click Reposition.

If the parent document is not already checked out to your computer, Webtop checks it out.
Check in the parent document as follows:

a. Select the parent document.

b. Select Tools > Virtual Document > Save Changes.

c. Click OK.

d. Select your checkin options, and click OK.

Remove a descendant from a virtual document

When you remove a descendant from a virtual document, the descendant’s parent document will be
checked out for you if it is not already checked out. Removing descendants does not delete the files
from the repository. It only removes the files from the virtual document structure.

To remove a descendant from a virtual document:

1.

Navigate to the virtual document, and view its structure, as described in View the structure of a
virtual document, page 188.

Select the descendants to remove.

Select Tools > Virtual Document > Remove Child.

If the parent document is not already checked out to your computer, Webtop checks it out.
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4. Check in the parent document as follows:
a. Select the parent document.
b. Select Tools > Virtual Document > Save Changes.
c. Click OK.
d. Select your checkin options, and click OK.

Specify that a certain version of a descendant
is always used

You can specify that a particular version of a descendant is always used when a virtual document
is opened or exported. Typically, a virtual document always uses the CURRENT version of a
descendant. But you can set a binding rule that specifies that another version is used.

If the version of the descendant is missing, then the virtual document has a broken binding. In your
preferences, you select whether to have Virtual Document Manager (VDM) display or ignore broken
bindings. See Set your virtual document preferences, page 194.

To specify that a certain version of a descendant is always used:

1. Navigate to, and select a descendant document in a virtual document. You can navigate to a
descendant by viewing the structure of the virtual document, as described in View the structure
of a virtual document, page 188.

2. Select Tools > Virtual Document > Fix to Version.

If the parent document is not already checked out to your computer, Webtop checks it out.
3. In the Always Use field, select the version to fix to the virtual document.
4. Click OK.
5. Check in the parent document as follows:

a. Select the parent document.

b. Select Tools > Virtual Document > Save Changes.

c. Click OK.

d. Select your checkin options, and click OK.

Set a version label for a virtual document

To set a version label for a virtual document:
1. Navigate to the virtual document, and select it.
2. Select Tools > Virtual Document > Modify Version Labels.

3. Enter a version label.

192 EMC Documentum Webtop Version 6.8 User Guide



Virtual Documents

4. To apply the version label to all descendants of the virtual document, check apply to all
descendants.

5. Click OK.

Create an archive of a virtual document

A archived of a virtual document is called a snapshot.

To view a list of snapshots created for a virtual document:
1. Navigate to the virtual document, and select it.

2. Select View > Snapshots.

To create a snapshot:
1. Navigate to the virtual document, and select it.
2. Select Tools > Virtual Document > New Snapshot.
3. In the Create tab, do these:
a. Enter a name for the snapshot.
b. Select a location for the new snapshot.
c.  Select the type of snapshot.

d. To freeze the snapshot, make sure Freeze Snapshot is checked. This should be checked by
default. By freezing the snapshot, you ensure that the frozen version of the document, and
frozen version of each descendant cannot be changed without creating a new version.

4. On the Info tab, set properties as described in Table 3, page 31 in the topic Set properties, page 30.

5. Set information in any remaining tabs as appropriate. For information on the functionality
affected by those tabs, see the topic in this guide that covers that functionality.

6. Click Finish.

To freeze or unfreeze a snapshot:
1. Navigate to the snapshot, and select it.

2. Select one of these:

¢ Tools > Virtual Document > Freeze Snapshot

Freezing a snapshot blocks users from editing the frozen version of the document or the frozen
version of each descendant. Any changes a user makes to the document or a descendant can
be saved only as a new version of the document or descendant.

e Tools > Virtual Document > Unfreeze Snapshot

Unfreezing a snapshot lets users again edit the document, and descendants without
versioning. However, if a descendant is part of multiple frozen snapshots, then you must
unfreeze all the snapshots to edit the descendant.
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Convert a virtual document to a simple
document

You can convert a virtual document to a simple document only if the virtual document has no
descendants.

To convert a virtual document to a simple document:

1. Navigate to the virtual document.

2. If you have not already done so, remove all descendants from the virtual document. See Remove
a descendant from a virtual document, page 191.

3. Select the virtual document.

4. Select Tools > Virtual Document > Convert to Simple Document.

Set your virtual document preferences

To set your virtual document preferences:
1. Select Tools > Preferences.

2. Select the Virtual Documents tab, and complete the fields in Table 26, page 194.

Table 26. Virtual document preferences

Property Description

Opening options Select what happens when you open a virtual
document by clicking its name. This does
not apply if the virtual document is already
opened in Virtual Document Manager (VDM):

* View structure: When you click the virtual
document’s name, the first level of nested
files appears.

* View content: When you click the virtual
document’s name, a read-only copy of the
content appears.

* Prompt each time: When you click the
virtual document’s name, you are prompted
to select to display the structure or the
read-only content.

If there is no content in a virtual document,
then VDM automatically displays the virtual
document’s structure, regardless of how you
set this preference.
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Property Description

Bindings Select whether VDM shows broken bindings.
A binding is broken if VDM cannot find
the version of a component specified by the
component’s binding rule

Copy Select what happens when you copy a virtual
document to your clipboard. You can select
one of these:

* Root only: Copies the content, and
properties of the parent file only.

* Root and descendants: Copies the parent
file, and all the descendants nested in
the parent file, including descendants of
descendants, and so on.

* Root and link to existing descendants:
Copies the parent file, and references the
descendants.

* Prompt me each time: Prompts you to
select what to copy.

Checkout Select what happens when you attempt to
check out an item that is locked by another
user:

* Download as read-only: Downloads a
copy of the item as read-only.

* Prompt me each time: Prompts you to
select whether to download as read-only.

3. To save your changes, click OK.
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PDF Annotations

PDF annotations overview

If your organization has installed the EMC Documentum PDF Annotation Service, then you can store
comments created in Adobe Acrobat or Reader into a repository. You can view, and enter comments
in PDFs directly from Webtop.

Comments are associated with a specific version of a document. If a document is versioned, the
comments on the previous version are not migrated to the new version.

Example: If you check out a 1.0 CURRENT version of a document, and then a second user adds
comments to the document, the comments are associated with the 1.0 version. If you then check in,
and change the version number to 1.1, then when you view the 1.1 CURRENT version, you will not
see the comments from the 1.0 version.

To use PDF Annotation Services, you must configure Webtop to open PDF Annotation Service when
you view a PDF.

Configure PDF Annotation Service to open
when user views a PDF

To configure PDF Annotation Service to open when a user views a PDF:
Select Tools > Preferences.
Select the Formats tab.

In the Choose object type list, select Document (dm_document).

1
2
3
4. In the Object’s primary format list, select Acrobat PDF (pdf).
5. In the Application for viewing list, select Comment.

6

If appropriate, repeat Step 3 to Step 5 for documents of other formats (such as Microsoft Word). If
doing so, do not select Acrobat PDF (pdf) in Step 4. Instead, select the appropriate format.

Add comments to a PDF document

To add comments to a PDF document:
1. Navigate to a PDF document.

2. Select the document, and then select File > Open (Read Only).
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The PDF opens in read-only mode in a separate window, with its comments.

If you use Internet Explorer, then the browser also launches an extra blank page. To avoid this,
select the Internet Explorer Tools > Internet Options menu option, then select the Advanced tab,
and make sure the Reuse windows for launching shortcuts option is specified.

To add comments, use the Acrobat commands for doing so. For more information, see your
Acrobat documentation.

To save your comments to the repository, click Adobe’s Send and Receive Comments button.

Comments that are saved in a repository have the Acrobat . XFDF format.

View comments in a PDF document

To view comments in a PDF document:

1.
2.

198

Navigate to a PDF document.

Select the document, and then select File > Open (Read Only).
The PDF opens in a separate window, with its comments.

If you use Internet Explorer, then the browser also launches an extra blank page. To avoid this,
select the Internet Explorer Tools > Internet Options menu option, then select the Advanced tab,
and ensure that the Reuse windows for launching shortcuts option is specified.
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Relationships

A relationship is a connection between two items in a repository. Relationships allow Webtop to
process the items together. Relationships also allow users to access certain items by first accessing
other related items. For example, if a document has been annotated by several reviewers, and if
each annotation has a relationship to the original document, a user can access the annotations by
viewing the document’s relationships.

To view an item’s relationships:

1. Navigate to the item, and select it.

2. Select View > Relationships.

To create a relationship between two items:
1. Navigate to the item to be the parent, and select it.
2. Right-click the item, and select Add Relationship.

3. In the selection area, select the item to relate to this item, and click OK. For detailed steps see
Locate an item in a selection dialog box, page 21.

4. Click Next.
5. In the Relationship list, select the type of relationship.
6. Click Finish.

To create a relationship between two items by drag-and-drop:
1. Navigate to either of the items.

2. If the other item is in a different location, open an additional browser window by selecting Tools
> New Window, and then navigate to the other item.

3. Drag-and-drop the child item to the parent item.
4. In the Relationship list, select the type of relationship.
5. Click Finish.

To remove a relationship between two items:
1. Navigate to either of the items, and select it.

2. Select View > Relationships.

EMC Documentum Webtop Version 6.8 User Guide 199



Relationships

3. Select the relationship to remove.
4. Click File > Remove Relationship.
5. Click OK.
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Renditions and Transformations

Renditions and transformations overview

A rendition is an alternate copy of a file or an alternate file that is associated with an original file. For
example, a rendition can be a copy of an image in a different file format or in a different resolution.

You can display all of a file’s renditions by selecting the menu option View > Renditions.

You can create renditions outside the repository, and import them in, or you can generate renditions
within Webtop, through transformation.

Transformations let you automatically transform the look, and format of an existing file in order to
create a new rendition associated with the original file.

When transforming a file, you choose a preset transformation task, and enter any applicable
transformation parameters. The transformation profiles that are available for a given file depend on
the file’s format, and the EMC Documentum products installed, and configured for the repository.

Transformations occur on one item at a time, and are processed asynchronously, meaning that
transformed items, and renditions might not be immediately available. You receive a notification
when a transformation is completed or if a transformation fails.

When a file is versioned, its renditions, including any thumbnail renditions, are not carried forward
with the new version of the file automatically. If you create a new version of the file, the renditions
remain with the previous version. However, Webtop may automatically generate new renditions
when you check in, and version a file if it was selected during rendition creation. See Creating

a rendition through transformation, page 202 for more information on automatically updating a
rendition upon versioning.

Note: Some rendition, and transformation functionality is available only on repositories that are
configured with EMC Documentum’s Content Transformation Services products. Without the
presence of these products, some rendition, and transformation functions described in this guide
may not be available.

Note: Webtop does not allow multiple renditions of the same format. Therefore, for any new
renditions created, Webtop replaces any existing renditions of the same format. For example, a
Microsoft Word document can only have one Acrobat PDF rendition at any time.

Viewing a list of the different renditions of a file

To view a list of the different renditions of a file:
1. Navigate to, and select a file.

2. Select View > Renditions.

Webtop shows all of the renditions for the file.
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Importing a rendition

To import a file from outside the repository to use as a new rendition for an existing
repository file:

1. Navigate to, and select a file for which to import a rendition.
2. Select File > Import Rendition.

3. In the File to Import field, enter the file to import. You can type the path to the file, or you
can browse to locate the file.

4. In the Format field, select the rendition’s file format if the correct format does not appear
automatically.

5. Click OK.

The file is imported as a rendition of the primary rendition.

Transforming a document to PDF or HTML
format

Webtop uses EMC Documentum Content Transformation Services products to provide the
functionality to transform documents to PDF or HTML format. When a document is selected for
transformation to PDF or HTML format, the request is sent to a queue where it awaits processing
by the Content Transformation Services product. The default transformation parameters are used
for that document type. When processing is complete, a new file in either PDF or HTML format is
stored in the original’s list of renditions.

It may also be possible, depending on what other Documentum products are installed on your
system, to transform a document to PDF or HTML formats with options. See Creating a rendition
through transformation, page 202, and Creating a related file through transformation, page 203
for more information.

To transform a document to PDF or HTML.:

1. Navigate to, and select a document to transform to PDF or HTML.

Note: You can transform a parent file or another rendition. (Locating renditions is described in
Viewing a list of the different renditions of a file, page 201.)

2. Select Tools > Transform > PDF Rendition or Tools > Transform > HTML Rendition.

The transformation request is immediately sent to the appropriate queue for processing, and
appears in the renditions list for the parent file when it is completed.

Creating a rendition through transformation

Webtop uses EMC Documentum Content Transformation Services products to transform a file using
a set of properties in order to create a new rendition.
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Transformations to create new renditions occur on one item at a time, and requests are processed
asynchronously, meaning that new renditions may not be available immediately. You receive a
notification in your Inbox when a transformation is completed or if a transformation fails.

!\ Caution: Not all features mentioned in the following procedure are available for all file formats,
and some file formats cannot be transformed. Format availability depends on the Content
Transformation Services products installed, and any special configuration on your system.

To create a new rendition through transformation:

1. Navigate to, and select the file to transform to create a new rendition.

Note: You can transform a parent file or another rendition. (Locating renditions is described in
Viewing a list of the different renditions of a file, page 201.)

2. Select Tools > Transform > More Formats.
3. The Transform wizard appears. Do the following:
a. Select a transformation profile, and click Next.

b. If the Transformation Details screen appears, enter any information necessary for setting the
parameters of the transformation, and click Next.

c. Inthe Save As screen, select Create a New Rendition, and click Next.

d. Inthe Rendition Definition screen, complete the fields as required. At this time, you may
choose to save the transformation so that it is performed each time the file is versioned.

e. If you have selected multiple files for this transformation, click Next. Alternatively, if you
wish to apply the selected parameters to all of the files selected for the transformation, or if
you have selected only one file to transform, click Finish.

The transformation request is immediately sent to the appropriate server queue for processing.
When the transformation is complete, a notification is sent to your Inbox.

Creating a related file through transformation

Webtop uses EMC Documentum Content Transformation Services products to transform a file using
a set of properties in order to create a new related file.

Transformations to create new related files occur on one item at a time, and requests are processed
asynchronously, meaning that new files may not be available immediately. You receive a notification
in your Inbox when a transformation is completed or if a transformation fails.

!\ Caution: Not all features mentioned in the following procedure are available for all file formats,
and some file formats cannot be transformed. Format availability depends on the Content
Transformation Services products installed, and any special configuration on your system.

To create a new related file through transformation:

1. Navigate to, and select the file to transform to create a new related file.

EMC Documentum Webtop Version 6.8 User Guide 203



Renditions and Transformations

Note: You can transform a parent file or a rendition. (Locating renditions is described in Viewing
a list of the different renditions of a file, page 201.)

2. Select Tools > Transform > More Formats.

The Transform wizard appears.
3. Select a transformation profile, and click Next.

4. If the Transformation Details screen appears, enter any information necessary for setting the
parameters of the transformation, and click Next.

5. In the Save As screen, select Create a New Object, and click Next.

6. The New Object Definition screen enables you to enter or apply properties for the new files.
This includes name, title, permission set, lifecycle, and location. The only required property is
the name. This screen also enables you to choose whether to perform this transformation every
time these new files are versioned.

Do the following:

a. Enter a name for the new file. The file name is entered by default.
b. If you wish, enter a title for the file.

c. If you wish, select an alternate object type for the file.

d. Click Edit to enter an alternate permission set to the file.

e. To apply a lifecycle to the files, click Edit.

f. Select the location for the new file. You have two options:

e Same as parent file

Places the new file in the same cabinet or folder location as the original.
¢ New location

Requires you to select a new location in an edit window.

g. To perform this transformation each time the original file is versioned, click Save
Transformation.

7. If you have selected multiple files for this transformation, click Next. Alternatively, if you wish to
apply the selected parameters to all of the files selected for the transformation, or if you have
selected only one file to transform, click Finish.

The transformation request is immediately sent to the appropriate server queue for processing.
When the transformation is complete, a notification is sent to your Inbox.
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Presets

Presets overview

A preset determines the selections or actions available in particular situations. Creating a preset
offers a way to reduce screen options to those options that are relevant to the user’s task in the
particular situation.

A preset is assigned to a particular item or set of items. For example, a preset could be assigned to
a particular user group. Or a preset could be assigned to a particular user group when combined
with a particular folder location. The item or set of items is called the preset’s scope. The scope
assigned to each preset must be unique.

A preset comprises one or more rules. Each rule determines the selections or actions available within
a specific functional area. For example, a rule can determine available lifecycles, available actions,

or available autocomplete text. For a list of the functional areas for which you can create rules,

see Preset rules, page 207:

When you create a preset for a folder, the rules apply not only to files that are created in the folder,
but also to files that are imported into the folder. For example, after importing a file into a folder that
allows only LifecycleA to be applied, the user would not be able to apply LifecycleB to that file. In
addition, Preset rules descend to subfolders.

The default order of precedence for applying presets is as follows: a preset for a location takes
first precedence; then a preset for a user; then a preset for a role; then a preset for an object type.
Customized installations might vary.

To access presets, navigate to Administration / Presets.

It is important to note that presets are not used to provide security.

Create a preset

To create a new preset:

1. Navigate to Administration / Presets.

2. Select File > New > Preset. The Presets:Setup page is displayed.
3. Enter a name and description for the preset.
4

Select the user, role, or group to apply the preset to, by clicking Select in the Apply to a
User/Role/Group field, selecting the relevant user, role, or group, and clicking OK. For more
information, see the Locate an item in a selection dialog box section.

5. Select the repository location to apply the preset on, by clicking Select in the Apply to existing
location field, selecting the relevant repository location, and clicking OK. For more information,
see the Locate an item in a selection dialog box section.
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6. Select the type of item the preset is to apply to by clicking Select next to the Apply to specific
type field, selecting the relevant item, and clicking OK. For more information, see the Locate an
item in a selection dialog box section.

7. Select whether the new preset applies to all repositories or just to the current repository by
clicking Select in the Apply to specific repository field, selecting the relevant repository, and
clicking OK. For more information, see the Locate an item in a selection dialog box section.

8. Click Next.
The Rules tab is displayed.

9. Optionally, you can use an existing preset as a template for the new preset. To use an existing
preset as a template for the new preset, click Select next to the Start with another preset option,
select the existing preset, and click OK.

10. To define preset rules, see Edit preset rules, page 206.

Edit an existing preset

To edit a preset:
1. Navigate to Administration / Presets, and select the preset.
2. Select File > Edit.

3. To edit the Rules tab, see Edit preset rules, page 206.

Edit preset rules

This procedure assumes you have opened a preset by either creating a new preset or editing an
existing one.

To edit preset rules:

1. In the Rules tab, in the first list, select the type of rule. For rule descriptions, see Preset rules,
page 207.

2. In the Available list, do one of these:

* For the Actions rule: Select the action to exclude, and click the arrow to move your selection
to the Excluded list box. To display additional actions, use the fields above the list.

¢ For the Attributes rule: Select an object type, then select an property, then type in the values
to be available as auto-attributes for that property, and then click Apply.

¢ For the Navigation rule: Select the repository nodes available when a user logs in, and in
the Section to start in field, select which node is the first node that opens when the user
logs into a repository.

e For all other rules: Select the item to which to give access, and click the arrow to move your
selection to the Selected list box. To display additional values, use the fields above the list.

The rules you have selected for this preset appear in the summary at the bottom of the page.
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3. To select another rule or another rule value, return to Step 1

4. Click Finish.

Preset rules

See Table 27, page 207 for an explanation of the functions you can assign to a preset.

Table 27. Preset rules

Preset rule

Description

Permissions

Formats

Types

Groups

Workflows

Lifecycles

Templates

Actions
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The permission sets that can be assigned to an
item.

The file formats that can be assigned to new,
imported, or checked in files. Additional
formats based on the file’s extension might also
be available.

The repository object types that can be assigned
to new or imported files.

Each item in a repository has an associated object
type. The object type defines the characteristics
of the item. For example, there is an object
type for documents, an object type for folders,
and an object type for email messages. Your
organization can create customized object types.

The filters available for narrowing a list of users
or groups in a selection list for a permission set
or quickflow.

The workflow templates available for starting
a new workflow.

The lifecycles available to assign to a file. Note
that when a user assigns a lifecycle to a file, the
list of available lifecycles might be narrowed
further by the file’s object type.

The templates available for creating new files.
Note that when a user selects a template for
creating a new file, the list of templates might be
narrowed further by the type, and format of the
file the user is creating.

The menu items, tool buttons, action links, and
action buttons available.

207



Presets

Preset rule

Description

Attribute

Navigation

The default values available for a property when
a file is created or linked. This setting follows
these rules:

e If a property is single-valued, and the value
is already set, the existing value is not
overridden.

¢ If the property is multi-valued, the specified
value is added.

e If the data dictionary does not allow the
value, the value is not set.

If the auto-attribute set of values gets out of
synchronization with the data dictionary, the
data dictionary set of values is presented to
the user.

e If this setting is applied to a folder, it is
applied to all files imported into the folder.
When a preset is modified , the changes apply
only to newly created items.

o If this setting is applied to a user, role, or
group, it is applied to all files created by that
user or the users in that role or group.

* These cannot have preset values: the
object_name attribute, the a_content_type
attribute, read-only attributes. If an attribute
is read-only because of an item’s current
lifecycle, and state, the auto-attribute value
is not set.

® Preset attributes are limited to these types:
string, integer, double.

¢ For import, if all mandatory attribute values
are set by the auto-attribute preset, the import
is silent after the user selects files for import.

The repository nodes available. This applies
only when the preset is assigned to a user,
group, or role. When you select this rule, you
choose the repository nodes available, and you
also designate which node is the first node that
opens when a user logs in.
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Remove a preset from an item

To remove a preset from an item:

1. Navigate to Administration / Presets, and select the preset.
2. Select File > Edit.

3. Click Select next to the type of item the preset applies.

4

In the selection dialog box, clear the item by selecting it, and clicking the remove arrow.

Delete a preset

When you delete a preset, it is removed from all the items that use it.

To delete a preset:

1. Navigate to Administration / Presets.

2. Select the preset.

3. Select File > Delete.

4. To view technical information, click Help.
5

At the warning prompt, click Continue.

The Webtop Express preset

The Webtop Express preset governs repository access for users who are given the express_user role.
The Webtop Express preset is intended for users who need only limited access to repositories. Table
28, page 209 describes the access granted by the Webtop Express preset.

Administrators who belong to the dmc_wdk_presets_coordinator role can edit the Webtop Express
preset. To edit the Webtop Express preset, use the usual procedure for editing a preset.

Table 28. Express user capabilities

Preset Values

Formats None | Text | PDF | all MS Office formats
Types dm_document | dm_folder

Templates Displays templates that correspond to formats
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Preset Values

Actions Document: Content transfer, subscriptions,
email, quickflow, Properties, clipboard actions,
create, delete
Excluded: Relationships, export to CSV,
favorites, notifications, lifecycle, and virtual
document actions, tools (most); new workflow
template, room, form, cabinet

Locations My Home Cabinet | Cabinets | Subscriptions |
Recent Files | Inbox (not Searches, Categories,
Administration)
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Permission Sets

Permission sets overview

Each item in the repository has a permission set that determines who can access the item. The
permission set lists the users, and groups who have access to the item, and specifies the level of access
given to each. For example, a permission set might give one user permission only to view an item,
while it gives another user additional permissions to edit, and delete the item.

The permission set specifies the level of access by assigning each user or group basic permissions, and
extended permissions. For descriptions see Basic permissions, page 211, and Extended permissions,
page 212.

When you create a new item in the repository, you choose the permission set that is assigned to
the item. If you do not choose a permission set, Webtop automatically assigns the permission set
specified in your user properties as your default permission set.

To access permission sets, navigate to Administration / Security.

Basic permissions

When adding a user or group to a permission set, you assign the user or group one of the permission
levels described in Table 29, page 212.
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Table 29. Basic permissions

Permission level

Permissions

None

Browse

Read

Relate

Version

Write

Delete

No access is permitted to the item.

User can view the item’s properties but not the
item’s content.

User can view both the properties, and content
of the item.

User can add annotations to the item.

User can modify the item’s content, and they can
check in a new version of the item (with a new
version number). The user cannot overwrite an
existing version or edit the item’s properties.

User can edit item properties, and check in the
item as the same version.

User can delete items.

Extended permissions

You can add one or more extended permission to a user or group’s basic permission level in a
permission set. Extended permissions are described in Table 30, page 212.

Table 30. Extended permissions

Extended permission

Description

Execute Procedure

Change Location
Change State
Change Permission
Change Ownership
Extended Delete

User can change the owner of an item, and can
run external procedures on certain item types.

User can move the item.

User can change the item’s lifecycle state.
User can modify the item’s permissions.
User can change the owner of the item

User can delete the item.
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Create or edit a permission set

To create or edit a permission set:

1.
2.

Navigate to Administration / Security.
Do one of these:
¢ To create a new permission set, select File > New > New Permission Set.

¢ To edit an existing permission set, navigate to, and select the permission, and then select
View > Properties > Info.

Enter or edit the name of the permission set.

To change who owns the permission set, click Select Owner, select the new owner, and click OK.
For detailed steps see Locate an item in a selection dialog box, page 21.

In the Class field, select one of these:

¢ Regular

The permission set can be used only by the user or group that creates it. Any user or group in
the repository except the repository owner can create a regular permission set.

e Public

The permission set can be used by anyone in a repository. Any user or group in the repository
can create a public permission set. Public permission sets can be modified or deleted only

by the permission set owner, a superuser, a system administrator, or the repository owner.

If the repository owner is the owner of a particular permission set, it is called a system
permission set.

Click Next to open the Permissions tab.

By default, a permission set includes the dm_owner user, and the dm_world group. The
dm_owner user is the user who is the owner of the permission set. The dm_world group is
the group that contains all repository users.

To edit the Permissions tab, see Edit permissions, page 213.

Edit permissions

To edit permissions:

1.

If already viewing the Permissions tab, go to Step 2. If you are not already viewing the
Permissions tab, select a file or permission set, and then select View > Properties > Permissions.
Tip: You can edit permissions for multiple items at once by selecting multiple items, and

selecting View > Properties > Permissions. The Permissions tab displays only the values that are
common to all the items selected.

To assign a different permission set, click Select, select the permission set, and click OK. For
detailed steps see Locate an item in a selection dialog box, page 21.
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To change the assigned permission levels, do these in the Additional Permissions or Additional
Common Permissions area (depending on which is displayed):

a. To add users or groups, and assign them permissions, click Add, select the users or groups,
and click OK. Go to Step c.

b. To edit permissions for users or groups, select the users or groups, and click Edit.

c. In the Basic Permissions list, select the permission level for the user or group. For
descriptions of basic permissions, see Basic permissions, page 211.

d. Inthe Extended Permissions list, select any extended permissions to give the user or group.
For descriptions of extended permissions, see Extended permissions, page 212.

e. Do one of these:

¢ If you did one of these, click Finish:
— Selected just one user or group.
— Selected multiple users or groups but will apply the same level to all remaining ones.

¢ If you selected multiple users or groups, and will apply a different level to the next one,
click Next, and return to Step c.

f.  To make more changes to permission levels, repeat Step a through Step e.

g. To remove users or groups from the permission set, select the users or groups, and click
Remove.

To restrict users or groups from access in repositories where Trusted Content Services is enabled,
do these in the Restrictions or Common Restrictions area (depending on which is displayed):

a. To add restrictions to additional users or groups, click Add, select the users or groups,
and click OK. Go to Step c.

b. To edit restriction on users or groups, select the users or groups, and click Edit.
If validation conflicts are displayed, do one of these:

* To continue despite the conflicts, click OK.
¢ To resolve the conflicts, click Cancel, and select new users or groups.

c. In the Basic Permissions list, select the permission level to deny the user or group. For
descriptions of basic permissions, see Basic permissions, page 211.

d. Inthe Extended Permissions area, select the extended permissions to deny the user or group.
For descriptions of extended permissions, see Extended permissions, page 212.

e. Do one of these:

¢ If you did one of these, click Finish:
— Selected just one user or group.

— Selected multiple users or group but will apply the same restrictions to all remaining
ones.

¢ If you selected multiple users or groups, and will apply different restrictions for the
next one, click Next, and return to Step c.

f. To make more changes to restrictions, repeat these substeps.
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g. To remove users or groups from having restrictions, select the users or groups, and click
Remove.

5. To edit required groups or required group sets in repositories where Trusted Content Services is
enabled, do these in the Advanced Permissions area:

a. In either the Required Groups area or the Required Groups Sets area, do one of these:

* To add users or groups, click Add, select the users or groups, and click OK.
* To edit users or groups, select the users or groups, and click Edit.
¢ To remove users or groups, select the users or groups, and click Remove. Skip to Step e.

b. In the Basic Permissions list, select the permission level to deny the user or group. For
descriptions of basic permissions, see Basic permissions, page 211.

c. Inthe Extended Permissions area, select the extended permissions to deny the user or group.
For descriptions of extended permissions, see Extended permissions, page 212.

d. Do one of these:
e If you did one of these, click Finish:

— Selected just one user or group.
— Selected multiple users or group but will apply the same level to all remaining ones.

¢ If you selected multiple users or groups, and will apply a different level to the next one,
click Next, and return to Step b.

e. To make more changes to required groups or required group sets, repeat these substeps.

6. When you are done editing permissions, do one of these:

* To save your changes, click OK.

* To go to another tab, click the tab.
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Users, Groups, and Roles

Users

This section describes these:

* Locate a user, page 217

e Create or edit a user, page 218

e User properties, page 218

¢ Import users from information contained in an input file, page 220
* Make a user active or inactive, page 222

¢ Change the home repository of a user, page 222

* View the groups to which a user belongs, page 222

* Reassign one user’s items to another user, page 222

® Delete a user, page 223

* View user management logs, page 223

Locate a user

To locate a user:
1. Navigate to Administration / User Management / Users.

2. Do one of these:
¢ C(Click Show All Users.

* In one or more search fields, type information about the user, and then click Search.

A list of users appears.

Tip: To display the search fields again, click More Options.

3. Locate the user in the list using standard navigation. For instructions, see Navigate a repository,
page 18.
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Create or edit a user

You must have adequate privileges to create or edit users.

* If the server authenticates users against the operating system, each user must have an account on
the server host.

* If you create users who will be managed by an LDAP server, the user_name, and user_login_name
properties of the dm_user object must have unique, non-null values, and the user_address
property of the dm_user object must have a non-null value.

To create or edit a user:

1. Navigate to Administration / User Management / Users.

2. Do one of these:

e To create a new user, select File > New > User.

¢ To edit an existing user, locate and select the user, and then select View > Properties > Info.
For instructions on locating a user, see Locate a user, page 217.

3. Enter values to define the new user. For an explanation of user properties, see User properties,
page 218.

4. Click OK.

User properties

See Table 31, page 218 for descriptions of user properties that might require further explanation,
beyond their field names.

Table 31. User properties

Field Description

State Determines whether the user can connect to the
repository. An active user can connect to the
repository. An inactive user cannot.

Name The user’s name as it appears on the user’s
home cabinet, and on items the user creates or
modifies.

User Login Name The name with which the user logs in to the
repository.

User Source The authentication source. Select None if the

user is authenticated in a Windows domain or
if the user has an account on the Content Server
host, and is authenticated by the operating
system.

E-Mail Address The address to which notifications are sent for
workflow tasks, and registered events.
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Field

Description

User OS Name

Windows Domain

Home Repository
Restrict Folder Access To

Default Folder
Default Group

Default Permission Set

Db Name

Privileges

Alias Set
Workflow Disabled

Propagate changes to members
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The login name for authenticating the user on an
operating system or on an LDAP server.

The user’s Windows domain, to be used if the
repository is on a Windows host or on a UNIX
host with a domain map for Windows domain
authentication.

The repository where the user receives
notifications, and tasks.

Restricts the user’s repository access to particular
repository locations.

The location for storing items the user creates.
The group assigned to items the user creates.

The permission set assigned to items the user
creates.

The user’s name in an RDBMS. This is used if the
user is a repository owner or registers RDBMS
tables.

This authorizes the user to perform certain
activities.

When setting this, if you grant superuser
privileges to a user after installing or upgrading
a repository or after manually running the
toolset.ebs script, add that user manually to the
group called admingroup.

If you revoke a user’s superuser privileges,
remove the user from the admingroup.

The user’s default alias set.

Indicates that the user is not available to receive
workflow tasks.

If creating a global user, this propagates

your changes to members of the repository
federation. A global user is a user who is found
in all members of a repository federation, and
whose property values are the same in all of the
repositories. Global users are managed through
the governing repository. Global users can also
have local properties, which you can modify in
a local repository.
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Field Description

For more information on global users, see the
Documentum Administrator User Guide.

Turn off authentication failure checking Allows the user more login attempts than the
limit set in the repository config object.

Import users from information contained in an input file

To import a user from information contained in an input file:

1. Determine what type of authentication the repository uses. If the server authenticates users
against the operating system, each user must have an account on the server host before you
create the users.

2. Create the input file. See Input file for new users, page 220.
3. In Webtop, do these:
a. Navigate to Administration / User Management / Users.
b. Click File > Import User.

c. Inthe Input File Path field, click Browse, and select the location of the input file for creating
the new users.

d. As appropriate, enter additional values that apply to all the users you are importing. Values
specified in the input file override values specified on this page. For an explanation of user
properties, see User properties, page 218.

e. Click Finish.

Input file for new users

You import users from information contained in an input file.

Before you create the users, determine what type of authentication the repository uses. If the server
authenticates users against the operating system, each user must have an account on the server host.

If the server uses an LDAP directory server for user authentication, the users do not need to have
operating system accounts.

If you specify the attributes user_group (the user’s default group), and acl_name (the user’s default
permission set), any groups, and permission sets must already exist before you import the users.

If you are creating a user who is authenticated using a password stored in the repository, the
password cannot be assigned in the input file. You must assign the password manually.

Each user to be imported starts with the header object_type:dm_user. Follow the header with a list of
attribute_name:attribute_value pairs. The attributes user_name, and user_os_name are required. In
addition, the default values in Table 32, page 221 are assigned when the file is imported.
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Table 32. Default values for new users

Argument Default
user_login_name user name
privileges 0 (None)
folder [user name
group docu
client_capability 1

Each attribute_name:attribute_value pair must be on a new line. For example:

object type:dm user

user name:Pat Smith

user group:accounting

acl domain:smith

acl name:Global User Default ACL
object type:dm user

user name:John Brown

If the file contains umlauts, accent marks, or other extended characters, store the file as a UTF-8 file,
or users whose names contain the extended characters are not imported.

The attributes you can set through the input file are:

user name
user os name

user os domain

user login name

user login domain

user password

user address

user db name

user group_ name

user privileges (set to integer value)
default folder

user db name

description

acl domain

acl name

user source (set to integer value)

home docbase

user state (set to integer value)

client capability (set to integer value)
globally managed (set to T or F)

alias set id (set to an object ID)
workflow disabled (set to T or F)

user xprivileges (set to integer value)
failed auth attempt (set to integer value)

You can specify as many of the above attributes as you wish, but the attribute_names must match the
actual attributes of the type.

The attributes may be included in any order after the first line (object_type:dm_user). The Boolean
attributes are specified using T (for true) or F (for false). Use of true, false, 1, or 0 is deprecated.

Any permission sets that you identify by acl_domain, and acl_name must exist before you run
the file to import the users. Additionally, the ACLs must represent system permission sets. They
cannot represent private permission sets.
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Any groups that you identify by user_group_name must exist before you run the file to import
the users.

Content Server will create the default folder for each user if it does not already exist.

Make a user active or inactive

To make a user active or inactive:

1. Locate, and select the user. For instructions, see Locate a user, page 217.
2. Select View > Properties > Info.

3. To make a user active, click Active.

4. To make a user inactive, click Inactive.
5

Click OK.

Change the home repository of a user

The home repository is where the user receives Inbox tasks, and notifications.

To change the home repository of a user:

1. Locate, and select the user. For instructions, see Locate a user, page 217.
2. Click Tools > Change Home Repository.

3. Select the new home repository.

4. Select when to run the job that assigns the new home repository.

5

Click OK.

View the groups to which a user belongs

To view the groups to which a user belongs:
1. Locate, and select the user. For instructions, see Locate a user, page 217.

2. Select View > Locations.

Reassign one user’s items to another user

This procedure is useful if you are deleting a user from the repository, and want to reassign the
user’s files, and objects to another user.
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To reassign one user’s items to another user:
1. Locate, and select the user. For instructions on locating a user, see Locate a user, page 217.
2. Click Tools > Reassign User.

3. Click Select User, and select the new user to which to reassign items. For detailed steps see
Locate an item in a selection dialog box, page 21.

4. Complete the remaining fields:

* Run the Re-name job
Select whether the items are reassigned immediately.
¢ Checked Out Objects
Select whether to unlock items that the previous user had locked.

5. Click OK.

Delete a user

EMC Documentum strongly recommends making users inactive rather than deleting them from
the repository.

It is important to know that if you delete a user, the content server does not delete the references to
that user in other repository objects, such as groups, and permission sets. This means that if you
delete a user, you must do one of these:

* Reassign the user’s objects to another user. See Reassign one user’s items to another user, page 222.

* Create a user with the same name. If you create a user with the same name, the new user inherits
the group membership, and object permissions belonging to the deleted user.

You cannot delete the repository owner, installation owner, or yourself.

View user management logs

To view user logs:
1. Navigate to Administration / User Management / Users.

2. Select one of these:

* View > Reassign Logs

* View > Change Home Repository Logs

Groups

A group is a collection of users, other groups, and roles. A group can own sysobjects, and permission
sets. By default, a group is owned by the user who creates the group.

EMC Documentum Webtop Version 6.8 User Guide 223



Users, Groups, and Roles

To locate groups, navigate to Administration / User Management / Groups.
To open a group, double-click the group.

This section includes these:

* Create or edit a group, page 224

¢ Group properties, page 225

¢ Add or remove members in a group, page 226

* Reassign one group’s items to another group, page 227

* View the groups to which a group belongs, page 227

¢ Sort Groups and members within groups, page 227

* Delete a group, page 228

Create or edit a group

To create or modify a group, you must have adequate privileges. See Table 33, page 224.

Table 33. Privileges for groups

Privilege Description

Create Group Can create a group with yourself as the owner.

Can modify groups to which you belong.
System Administrator Can modify any group.

Superuser Can create a group, and assign a different user
as the owner.

To create or edit a group:
1. Navigate to Administration / User Management / Groups.

2. Do one of these:

* To create a new group, select File > New > Group.

¢ To edit an existing group, locate, and select the group, and then select View > Properties >
Info.

For instructions on locating a group, see Groups, page 223.

3. Enter the appropriate information to define the group. For an explanation of group properties,
see Group properties, page 225.

4. Click OK.
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Group properties

See Table 34, page 225 for descriptions of fields that might require further explanation, beyond

their field names.

Table 34. Group properties

Field

Description

Name

Group Native Room

Class

E-Mail Address

Owner

Administrator

Alias Set
Global Group
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The name of the group. The name must consist
of characters that are compatible with Content
Server’s server OS code page.

Available in repositories with Collaborative
Services is enabled. If you select a room, the
group is considered a private group in the room.

Distinguishes between groups, and roles. Select
Group.

The server does not enforce the value of this
property, and does not set the property to any
value other than group.

The email address for the group. This is typically
the email address of the group’s owner. If no
value is entered in this field, the group email
address defaults to the group name.

The owner of the group. The user you select
has the Create Group privilege. If you are a
superuser, you can select the owner. Otherwise,
you can set this to a group of which you are a
member.

The administrator for the group. The
administrator can modify the group. If this is
null, only a superuser, and the group owner can
modify the group.

The alias set for the group.

If you are connected to the governing repository
of a federation, this makes the group a global

group.
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Field

Description

Private Group

Dynamic Group

Makes the group a private group. Otherwise,
the group is public. By default, groups created
by users with system administrator or superuser
privileges are public, and groups created by
users with a lower privileges are private.

Makes the group a dynamic group. A dynamic
group is a group comprised of potential
members, any of whom can be made actual
members at runtime.

The default membership setting for a dynamic
group is Treat users as non-members. This

means that at runtime, the potential members
do not automatically become actual members.

At runtime, however, the application from
which a user accesses the repository can request
that the user be made an actual member.

You can use dynamic groups to model role-based
security. For example, suppose you define a
dynamic group called EngrMgrs. Its default
membership behavior is to assume that users are
not members of the group. The group is granted
the privileges to change ownership, and change
permissions. When a user in the group accesses
the repository from a secure application, the
application can issue the session call to add

the user to the group. If the user accesses the
repository from outside your firewall or from
an unapproved application, no session call

is issued, and Content Server does not treat

the user as a member of the group. The user
cannot exercise the change ownership or change
permissions permits through the group.

Add or remove members in a group

To add or remove members:

1. Navigate to Administration / User Management / Groups, and double-click the group.

2. To add members:

a. Select File > Add Members

b. Select the members. For detailed steps see Locate an item in a selection dialog box, page 21.

c. Click OK.
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3. To remove a member:
a. Select the member.

b. Click File > Remove Members.

Reassign one group’s items to another group

To reassign one group’s items to another group:
1. Navigate to Administration / User Management / Groups, and select the group.
2. Select Tools > Reassign.

3. Click Select, and select the new group to which to assign items. For detailed steps see Locate an
item in a selection dialog box, page 21.

4. Complete the remaining fields:

¢ Run the Re-name job
Select whether the items are reassigned immediately.
* Checked Out Objects
Select whether to unlock items that the previous user had locked.

5. Click OK.

View the groups to which a group belongs

To view the groups to which a group belongs:
1. Navigate to Administration / User Management / Groups, and select the group.

2. Select View > Locations.

Sort Groups and members within groups

With Webtop 6.6, an Administrator can sort Groups, and members within a Group using the column
header. This functionality enables you to manage large number of groups and members within

the group.

To sort Groups using the column header:

1. Navigate to the Administration node.

2. Select User Management > Groups.

A list of existing groups is displayed.

3. Click the column header to sort the groups in ascending or descending order.
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To sort members within a Group using the column header:
1. Navigate to the Administration node.

2. Select User Management > Groups > Users.

A list of existing users in the selected group is displayed.

3. Click the column header to sort the members within a group in ascending or descending order.

Delete a group

EMC Documentum recommends that you do not delete groups. Instead, remove all members of the
group, and leave the group in the repository.

Roles

A role is a group that contains the users, and groups assigned particular duties within a client
application domain.

To locate roles, navigate to Administration / User Management / Roles.

Note: A role that has been created as a domain is listed in the groups list, not the roles list.
To open role, double-click the role.

This section includes these:

¢ Create or edit a role, page 228

* Role properties, page 229

¢ Add or remove members in a role, page 229

* Reassign one role’s items to another role, page 230

* View the groups to which a role belongs, page 230

* Delete a role, page 230

Create or edit a role

Note: If you create a role as a domain, it is listed on the groups list, not the roles list.

To create or edit a role:
1. Navigate to Administration / User Management / Roles.

2. Do one of these:

e To create a new role, select File > New > Role.
e To edit an existing role, locate, and select the role, and then select View > Properties > Info.

3. Enter values to define the role. For an explanation of properties, see Role properties, page 229.
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4. Click OK.

Role properties

See Table 35, page 229 for descriptions of fields that might require further explanation, beyond
their field names.

Table 35. Role properties

Field Description

Class Select Role. This lets your applications
distinguish between groups, and roles. The
server does not enforce the value of this
property, and does not set the property to any
value other than group.

E-Mail Address The email address of the role’s owner. If no
value is entered, the email address defaults to
the role name.

Owner The role owner can modify the role.

Administrator A user or group, in addition to a superuser or
the role owner, who can modify the role. If this
is null, only a superuser, and the role owner can
modify the role.

Private Group Creates the role as a private role. Otherwise the
role is a public role. By default, roles created by
users with system administrator or superuser
privileges are public, and roles created by users
with a lower user privilege level are private.

Create role as domain If you create a role as a domain, it is listed on the
groups list, not the roles list.

Dynamic Group Creates the role as a dynamic group. For more
information on dynamic groups, see Group
properties, page 225.

Add or remove members in a role

To add or remove members:
1. Navigate to Administration / User Management / Roles, and double-click the role.
2. To add members:

a. Select File > Add Members

b. Select the members. For detailed steps see Locate an item in a selection dialog box, page 21.
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c. Click OK.
3. To remove a member:
a. Select the member.

b. Click File > Remove Members.

Reassign one role’s items to another role

To reassign one role’s items to another role:
1. Navigate to Administration / User Management / Roles, and select the role.
2. Click Tools > Reassign.

3. Click Select, and select the new role to which to assign items. For detailed steps see Locate an
item in a selection dialog box, page 21.

4. Complete the remaining fields:

¢ Run the Re-name job
Select whether the items are reassigned immediately.
* Checked Out Objects
Select whether to unlock items that the previous user had locked.

5. Click OK.

View the groups to which a role belongs

To view the groups to which a role belongs:
1. Navigate to Administration / User Management / Roles, and select the role.

2. Select View > Locations.

Delete a role

EMC Documentum recommends that you do not delete roles. Instead, remove all members of the
role, and leave the role in the repository.
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Appendix A

Keyboard Shortcuts for Microsoft
Windows and Mac Operating Systems

You can use keyboard shortcuts to select menus, and buttons using your keyboard instead of your
mouse. Table 36, page 231 describes the default keyboard shortcuts. Customized installations might
vary.

Table 36. Keyboard shortcuts

Action Microsoft Windows shortcut ~ Mac OS shortcut
Create a new document Shift-N Shift-N
Check out @) ©)

Edit E E
Check in I I

View \Y% A
Open in read-only mode Enter Enter
View properties p p
Import Shift-1 Shift-1
Export Shift-E Shift-E
Save as A A
Search Shift-S Shift-S
Subscribe 8] 8]

Add to clipboard Shift-C Shift-A
Copy here Shift-V Shift-C
Move here Shift-M Shift-M
Link here Shift-L Shift-L
Delete Delete Delete
Start a quickflow Q Q
Apply alifecycle to a document L L
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Action

Microsoft Windows shortcut

Mac OS shortcut

Promote a document to its next

lifecycle state

Demote a document to its
previous lifecycle state

Declare a record
Create a discussion

Covert a simple document into
a virtual document

Email

Select all the items on the page
Select the next item

Select the previous item

Select the item above

Select the item below

R

D

Shift-R
Shift-U
Shift-T

M

Ctrl-A
Right arrow
Left arrow
Up arrow

Down arrow

R

D

Shift-R
Shift-U
Shift-V

M

Cmd-A
Right arrow
Left arrow
Up arrow

Down arrow

Go to the next field or button Tab Tab
Go to the previous field or Shift-Tab Shift-Tab
button
Help Shift-H Shift-H
Log out Shift-O Shift-O
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A

access levels

overview, 211 to 212
access restrictions

in permission sets, 214
accessibility mode

selecting, 15 to 16, 23
active users, 105
Add Repository option

log into new repositories, 17
advance queue processors, 85
Advanced Document Transformation

Services, 201
advanced searches

run, 62
alerts

in Inbox, 79

See also notifications

alias sets, 103

in lifecycles, 114
assemblies

view, 193

See also snapshots

asynchronous

transformations, 201
attached files

in tasks, 79

remove, 87

view, 80
attachments

locate, 57

open, 56

view, 55
attributes

automatic, 208
audit events

in workflows, 89
Authentication

WebSEAL, 16
auto-attributes
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presets, 208
autocomplete

accept a suggestion, 23

clear cache, 23

settings, 23
automatic tasks

complete, 91

failed, 91

in workflows, 87
available

for tasks, 83

B

background color, 146
background operations
view status, 25
basic permissions
overview, 211
binding rules
show broken bindings, 195
specify, 192
bookmarks

add repository document or folder, 46

subscriptions, 49
breadcrumbs
overview, 18
See also navigation path
Browse permissions, 212

C

cabinets
create, 30
histories, 31
properties, 30
calendars
create, 122
create events, 122
export and import, 126
recurring events, 124
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234

Calendars, 111 to 112
categories
copy, 43
delete, 43
link to multiple locations, 45
navigate, 21
search, 62
submit items to, 21
work queue categories, 101, 107
checkin
check in, 33
Check in from file, 34
common tasks, 31
generate versions, 35
generating renditions, 201
overview, 31
checkout
cancel, 36
check out files, 32
directory, 32
location, 32
overview, 31
view checked out files, 36
view recently checked out, 36
child documents
in virtual documents, 187
See also descendants
clipboard
add to, 44
remove from, 44
view, 44
collaborate
overview, 117
color
apply to background, 146
apply to text, 146
columns
display, 20
in lists, 20
comments
add in discussions, 119
delete in discussions, 119
edit in discussions, 119
reply to in discussions, 119
search for, 119
comparison operators, 97
connection brokers
select, 17
content

common tasks, 29
See also files

in repository, 13

in virtual document, 188
contextual folders

create, 121

overview, 121
Contributor role

in collaborative services, 136
convert

Desktop DRLs to Webtop URLs, 47
create

presets, 205
create_group privileges, 94
credentials

delete, 22

save, 15, 22

view, 22
csv file

export to, 50
current version

create, 35

make, 34

overview, 35

D

data tables

create, 127

create entries, 128

edit, 131

import and export, 132

overview, 126
DCS

see collaborate, 117
Delete permissions, 212
descendants

add, 189

in virtual documents, 187

locate, 188

remove, 191

reorder, 190 to 191

view, 188
Desktop DRLs

convert to Webtop URLs, 47
details

workflows, 89
directories

checkout, 32
discussions
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add comments, 119

delete comments, 119

edit comments, 119

overview, 118

reply to comments, 119

search for comments, 119
dm_email_message

assigned to email messages, 54
dm_owner

in permission set, 213
dm_QmPriorityAging job, 100

dm_QmThresholdNotificiation job, 100

dm_world
in permission set, 213

doc profiles. See work queue override

policies

Document Transformation Services, 201

documents

common tasks, 29

See also files

transforming to HTML, 202

transforming to PDF, 202
Documentum Collaborative Services

see collaborate, 117
domains

log in to, 15
drag-and-drop

enable, 22

to add descendants, 189

to check in from file, 36

to create relationship, 199

to export, 42

to import, 39

to move descendants, 191

to perform actions, 24

to subscribe to items, 49
DRL

document version, deleted, 49
dynamic groups

overview, 226, 229
dynamic priorities, 100

E

email messages
attachments, 55 to 57
export, 54
import, 53
lifecycles, 54
overview, 53
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send links, 47
transform, 55
view, 55
entering values
classified records, 164
email records, 161
formal records, 154
standard records, 157
Excel file
export to, 50
Export
search results, CSV, 51
express user
role, 17, 209
extended permissions
overview, 212

F

favorites
add repository document or folder, 46
recently used files, 36
repositories, 18
subscriptions, 49
federations
users, 220
file
save as, 148
file formats
associate with object types, 37
preferences, 37
See also formats
restore default associations, 39
files
attach, 80, 87
cancel checkout, 36
check in, 33
check out, 32
common tasks, 29
copy, 43
copy locally, 41
create, 29
delete, 43
demote, 114
deselect, 18
drag-and-drop, 24
edit, 32
export, 41
histories, 31
import, 39
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lifecycle states, 113, 117 common tasks, 145
lifecycles, 29, 33, 39, 113 create, 147

link to multiple locations, 45 enter data in, 145
link to other repositories, 45 format text, 145
presets, 205

promote, 114 G

properties, 30
remove, 87

remove lifecycles, 114
renditions, 201
replace, 36

General tab
in preferences, 22
Get Next Task, 85
Get Next Task Automatically, 85

select, 18 Get Task
send to review, 87 enable, 110
select, 85

send to workflows, 87
transforming, 201 global users

unlock, 36 propagate, 220
governed objects

overview, 133

versions, 35
view, 37
view locations, 46 group

virtual documents, 187 private, 226
virtual links, 37 public, 226

filters groups
in lists, 19 add to a work queue, 104

add users, 226
create, 224
delete, 228
dynamic, 226, 229

in selection dialog box, 21

in work queues, 86, 95 to 97
Find All Versions option

in searches, 65

Find Hidden Objects option edit, 224
in searches, 65 in work queues, 104, 106

folders locate, 223
overview, 223
presets, 205

contextual, 121

copy, 43

create, 29 reassign items, 227
delete, 43 remove users, 226
deselect, 18 users, 222

Groups

display on startup, 22
view, sort, column header, 227

drag-and-drop, 24
histories, 31

link to multiple locations, 45 H
presets, 205

. hidden objects
properties, 30 display, 23
se.lect, 18 . in searches, 65
view locations, 46 highlights

form templates
Records Manager, 149
formal record forms
entering values, 155

in search results, 66
historical reports
workflows, 92

. histories

ormatsf of repository items, 31
f preferences, 37, 39 hot keys

orms
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overview, 231
HTML

renditions, 201

transforming to, 202

view links, 37
HTML source, 147

I am available
select, 83
I am currently set to unavailable
select, 83
Inbox
available for tasks, 83
columns displayed, 20
common tasks, 79
display on startup, 22
get next task, 85
manage tasks, 84
open items, 79
overview, 79
unavailable for tasks, 83
view, 79
work queues, 85
Increment Priority, 100
Initial Priority, 100

J

jobs
dm_QmPriorityAging job, 100
in shortcuts, 46

K

keyboard
hot keys, 231
shortcuts, 231

L

languages
choose, 15 to 16
filter for, 19
Last Results option
in searches, 69
LDAP
changing passwords, 16 to 17
create users, 218 to 220
LDIF file formats, 220
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library requests
edit, 186
making, 178
view library requests, 186
lifecycles
apply, 29, 113
assign, 29, 33, 39, 54, 113
common tasks, 113
demote, 114
filter for, 19
overview, 113
promote, 114
remove, 114
resume, 115
states, 113, 117
suspend, 114

Lightweight Directory Access Protocol

changing passwords, 16 to 17
See also LDAP
links
common tasks, 44
create, 46, 147
delete, 43
in email messages, 47 to 48
subscriptions, 49
to multiple locations, 45
to other repositories, 45
view locations of, 46
lists
click filenames, 37
columns, 20
filenames, 37
filter, 19, 21
navigate, 18, 21
sort, 19
Starts With field, 18
view, 18
locations
log in, 15 to 16
view, 46
locked files
overview, 31
retain lock on checkin, 34
set preferences for, 195
sort by, 19, 36
view, 37

when check out virtual document, 195

locked users
create, 218
logs
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user, 223

match filters

assign to a queue, 97
matching filters

enable multiple skills, 97
Max Priority, 100
member list for a room

open, 137
menus

open with right-click, 24
messages

view, 25
metadata

export, 50
My Documentum

access, 26

folder, 26
My Files

columns, 20

display on startup, 22

view, 36
My Home Cabinet, 18
My Work Queues, 107
My Workflows

view, 89

N

navigation path
overview, 18, 21
new window
open, 24
None permissions, 212
notes
create, 120
delete, 121
editing, 120
searching for, 120
notifications
in work queues, 100
overview, 79
set, 50
numbered lists, 146

O

object types
associate with file formats, 37, 39

defined, 37
in presets, 207
offline mode
access, 26
ordered lists, 146
override policies. See work queue override
policies
Owner role
in collaborative services, 136

P

parent documents
of virtual documents, 187
See also virtual documents
passwords
changing, 15 to 16
PDF documents
add comments, 197
annotate, 197
configure annotation services, 197
view comments, 198
Percent Quality Check, 100
permission sets
basic permissions, 211
common tasks, 211
See also permissions
create, 213
extended permissions, 212
locate, 211
permissions
basic permissions, 211
common tasks, 211
See also permission sets
create permission set, 213
edit, 213
extended permissions, 212
locate, 211
manage, 211
overview, 211
set, 213
view, 213
policies. See work queue override policies.
See work queue policies
work queue override policies, 103
preferences
columns displayed, 20
general, 22
searches, 77
set, 22
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virtual documents, 194
presets

auto-attributes, 208

common tasks, 205

create, 205

delete, 209

edit, 206

overview, 205

remove, 209

types, 207

view, 205

Webtop Express, 209
primary renditions, 201
priority levels, 100
privileges

superuser, 219

user, 219
process template, 96
Process_report_admin, 94
processor profile, 95, 105

processor profiles. See work assignment

processor profiles
properties

in repository, 13

set, 30

view, 30

Q

quality check, 100
queries
search queries, 67
queue categories. See work queue
categories
queue policies, 96, 99, 103
See also work queues
queue processors
enable selective pull, 110
manage, 103
Queue_admin, 94
Queue_advance_processor, 93
Queue_manager, 94
Queue_processor, 93
queues. See work queues
quickflows
send, 88

R

Read permissions, 212

EMC Documentum Webtop Version 6.8 User Guide

read-only view
of email messages, 55
of files, 37
record relations
create record relationship, 175
remove record relationship, 178
view record relationship, 175
records
classified, 167
common tasks, 149
create record relationship, 149
declaring formal records overview, 149
declaring formal records
procedure, 149
linking, 175
record relationships, 175
removing record relationship, 178
unclassified, 167
Regulatory Publishing Transformation
Services, 201
Relate permissions, 212
related items
creating through transformations, 203
delete, 43
transformations, 201
relations
common tasks, 199
See also relationships
relationships
common tasks, 199
create, 199
delete, 199
remove, 199
view, 199
renditions, 201
associated with one version, 201
creating, 202
importing, 202
overview, 201
primary, 201
viewing, 201
reports
workflows, 91 to 92
repositories
accessibility mode, 15 to 16, 23
add, 17 to 18
browse, 21
change, 17
favorites, 18
groups, 223
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240

log in, 15,17

log in to accessibility mode, 15

log into accessibility mode, 16

log out, 17

multiple, 15, 17 to 18, 37

names, 17

navigate, 18

overview, 15

remove, 18

saved credentials, 15, 22
repository information

export, 50
required group sets

in permission sets, 215
required groups

in permission sets, 215
Reset, 23, 145
Restore Default

in Formats tab, 39
restrictions

in permission sets, 214
results

external sources, 68

searches, 66 to 67, 69, 73
reviews

common tasks, 79

quickflows, 88

workflows, 87
Rich Text Editor

in collaborative services, 117
right-click

to perform actions, 24
RM

form templates, 149

records, 149
role

express user, 17, 209
roles

add users, 229

create, 228

delete, 230

edit, 228

in work queues, 93

locate, 228 to 229

overview, 228

presets, 205

Process_report_admin, 94

properties, 228

Queue_admin, 94

Queue_advance_processor, 93

Queue_manager, 94
Queue_processor, 93
reassign, 230
remove users, 229
room membership
about, 136
add members, 139
add members to a local group, 140
change local roles, 140
create local group, 140
edit local group properties, 140
invite members, 139
manage, 139
remove local groups from a room, 140
remove members, 139
rooms
copy, 138
create, 134
delete, 138
edit properties of, 136
governed objects, 133
Group Native Room, 225
local groups, 136
local roles, 136
membership, 136
move, 138
overview, 132
visit, 133
RTE
in collaborative services, 117
See also Rich Text Editor

S

save as
file, 148
saved credentials
delete, 22
set, 15, 22
view, 22
search templates
copy, 77
create, 75
edit, 76
modify, 76
run, 75
searches
advanced searches, 62
configuration, 70
copy, 74
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edit, 62,73
experience, 69
export results, 50
external results, 68
highlight results, 66
indexed repository, 71
last results, 69, 73
monitor, 66 to 67
operators, 59, 65
overview, 59
preferences, 77
results, 66 to 67, 69, 73, 77
saved searches, 72 to 73
search templates, 74 to 77
searchable items, 71
simple searches, 59
status, 66 to 67
securities
common tasks, 211
See also permissions
selection dialog boxes
locate an item, 21
sessions
accessibility mode, 15 to 16, 23
log in, 15,17
log out, 17
settings
preferences, 22
See also preferences
shortcuts
keyboard hot keys, 231
links, 44
recently used files, 36
subscriptions, 49
to items in other repositories, 45
Show More, 31
simple documents
convert to, 194
simple search
run, 59
simple searches
run, 59
sites
histories, 31
properties, 30
skill attributes, 96
skill profile. See work assignment matching
Skills for Work Assignment Match, 106
smart navigation
search results, 67,77
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snapshots
create, 193
freeze, 193
unfreeze, 193
version labels, 192
view, 193
software version
view, 27
spell check, 147
Staging, 113
Starts With field
in lists, 18
status
background operations, 25
status bar
messages in, 25
structure
of virtual document, 188 to 191
virtual documents, 190 to 191
subscript, 146
subscriptions
cancel, 49
columns displayed, 20
create, 49
display on startup, 22
subscribe, 49
subscribe other users, 49
unsubscribe, 49
view, 49
superscript, 146
superuser
privileges, 219
supervisors
change, 91

T

tables, 147

tasks
accept, 81
attach files, 80
automatic, 91
complete, 81
delegate, 82
failed, 91
open, 79
overview, 79, 87
perform, 80
reassign, 82
reject, 82

241



Index

242

repeat, 83
select, 85
suspend, 84
unsuspend, 84
work queues, 84, 107
taxonomies
navigate, 21
See also categories
templates
lifecycles, 29, 33, 39, 54, 113
remove lifecycles, 114
search templates, 74 to 77
text
create links from, 147
format, 145
thresholds, 100
thumbnails
view, 19
transformations, 201
creating new files, 203
creating new renditions, 202
overview, 201
profiles, 201
results, 201, 203
to HTML, 202
to PDF, 202
translations
filter for, 19

U

unavailable
for tasks, 83

URLs
create links, 147

User managers
create new user, 141
in collaborative services, 141
modify users, 142
restricted folders, 143
unlist users, 143

users
active, 218, 222
add to a group, 226
add to a role, 229
add to a work queue, 104
add to permission sets, 213
assign tasks, 108
create, 218, 220
delete, 223

\'

edit, 218

global, 220

groups, 222

import, 220

in work queues, 104, 106
inactive, 218, 222

locate, 217

logs, 223

monitor queue users, 107
overview, 217

presets, 205

privileges, 219
properties, 218

reassign items, 222
reassign tasks, 108

state, 222

value to be used in the comparison, 97
VDM

overview, 187
See also virtual documents

version labels

add, 192

version of software

view, 27

Version permissions, 212
versions

current version, 34 to 35
delete, 43

renditioning, 201

save new, 33

view, 35

view directory

default location, 37

Virtual Document Manager

overview, 187
See also virtual documents

virtual documents
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add descendants, 189

common tasks, 187

content, 188

convert to simple documents, 194
create, 187

fix to a version, 192

move descendants, 190 to 191
overview, 187

preferences, 194

remove descendants, 191
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reorder descendants, 190 to 191
show broken bindings, 195
snapshots, 193
structure, 188
version labels, 192
view content, 188
view structure, 188
virtual links
view, 37

W

WDK
view version, 27
Web Development Kit
view version, 27
WebSEAL
Authentication, 16
Webtop Express
preset, 209
windows
open new, 24
WIP, 113
work assignment match
add filters to a queue, 97
processor profiles, 106
work assignment match filters
add to a queue, 97
remove from a queue, 98
work assignment matching
configure, 95
define filters, 96
set skills in process template, 96
work assignment processor profiles
add skills, 104 to 105
change skills, 105
delete skills, 106
Work Queue Assignment page, 103
work queue categories
create, 101
define, 101
delete, 101
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move, 109
reassign, 108
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work queue users. See queue processors
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configure notifications, 100
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define, 101
delete, 102
get next task, 85
groups, 104, 106
manage your Inbox, 84
modify, 108
monitor, 107
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move tasks to new queues, 109
overview, 93
perform tasks, 84
policies, 98
queue policies, 98
reassign tasks, 108 to 109
remove a group, 104
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resume suspended tasks, 110
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select tasks, 85
set priorities, 100
suspend tasks, 109
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